• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 347
  • Last Modified:

black screen on SiS 5597 X startup

Linux-Red Hat 6.1
screen blanks out on starting up X
AMD K-6 266 Mhz 64 MB RAM
onboard SiS 5597 video and CMI 8330 sound, USR 56k ISA modem, Lexmark 1100 printer and Visioneer 3100B scanner

Mike Burgess mwburgess@teacher.esc4.com

While the video adapter works for a few boots, it inevitably stops launching X from the command line and gives a black screen.  I'm using this with the edits referenced on the linuxcare support site to solve the problem of blacked out text on my video adapter (i.e. Options added to the device section in XF86Config).  It solves the problem but only for a while, until the screen decides to black out.  I'm very experienced troubleshooting Windows and Mac, but I'm new to Linux.  
0
miki92
Asked:
miki92
1 Solution
 
nholowatCommented:
Support for the SiS cards seems very poor and I had the same problem with a SiS6326 chip where 'd get blocks of black where the text was and when I went into a terminal I couldn't see what I was typing.  The new XFree86 sever (SVGA) 3.3.6 is available from the RedHat rawhide site and is supposed to fix alot of those problesm.  Give it a try.  Also SuSe has and XFcom server with instruction on their site for SiS.
Best of luck.
0
 
ricksonCommented:
if u are using the red hat there is hard to find the driver for sis. so better use other linux that appear to have sis driver besides redhat.
0
 
miki92Author Commented:
Rickson,
which distribution would you recommend
Thanks
0

Featured Post

Learn to develop an Android App

Want to increase your earning potential in 2018? Pad your resume with app building experience. Learn how with this hands-on course.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now