• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 198
  • Last Modified:

HD in DOS Compatibility Mode

I'm working on a computer with the "HD is using MS-DOS Compatibility Mode" message in Control Panel/System/Performance/File system tab

Computer: P200, 32 MB RAM, WIN95, 2.1 GB HD.

The following observations pertain to this issue using MS Knowledge Base for guidance:

No conflicts in Device Manager for HD Controller.

"Disable Protected Mode Drivers" unhecked in Control Panel/Performance/File System/Troubleshooting tab.  All other boxes unchecked.

No special load drivers commands in Config.sys.

esdi_506.pdr protected mode driver is present and loaded sucessfully according to Bootlog.txt.

Bootlog.txt does show load fail for:
Load Failure Code is 0002

ios.log shows:
"Unit number 02 going through real mode drivers". Same message for units 03 and 04.

Would appreciate next steps to determine cause of problem.

1 Solution
   This may be a possible cause of virus.  GO to start, programs, msdos prompt and type CHKDSK.  Look at the number for "Total Bytes Memory" if it is less than 655,360 then you probably have a virus.(This is invalid if you have a SCSI card in your system)Also look in system in control panel, go to preformance and look at the details it may also say something about a possible virus.
    I hope this is helpful for you.
I would remove the system devices (in device manager) related to bus-mastering, irq-steering and the primary/secondary hd controllers and then let windows autodetect them on a reboot.
If your conventional memory comes up clean....

Expand the HD Controllers entry in DevMan.

If you see something like:

Primary IDE Controller (single FIFO)
Standard Dual PCI IDE Controller
Standard IDE/ESDI Hard Disk Controller

then you have a motherboard that win95 does not properly support because of the chipset.

You will need to apply a patch that will update the mshdc.inf file that tell win95 how to operate the hd controller.
Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Normaly, if the IDE controllers are not shown with a yellow exclamation point in Device Manager, then all is OK.  Boot to Safe Mode, and remove all devices as mojo333 suggested.  Otherwise, the system will lock when you remove the IDE controllers.

Look in the registry for a NOIDE entry.  If it exists, remove it.  Do be careful, and always backup your registry before making any changes.

No offense, but that isn't strictly true anymore.

Before dma drives you could usually get away with it, unless the second channel drops off entirely.

Since DMA drives have come out I have seen a lot of really *strange* things that are resolved with the proper update.
First you need to find the right "PIIX" driver(If you Motherboard has Intel chipset)start looking at support.intel.com.

Then remove all the old settings from your IDE drivers i registry. Start a Dos Prompt, and type Regedit, search for "BADIDE", the firste result you will get should be in  "Hkey_local_machine\enum\pci...... something (depends on your hardware) BUT there should be 2 strings, containing your Primary and Secondary IDE channels...(BADIDE, GOODIDE, HDC) if any of these is included delete the 2 strings !

Then you need to remove all substring after "Hkey_local_machine\system\currentcontrolset\servises\class\hdc eg. 0000, 0001, 0002 all of these

Final, Install your PIIX Driver again and reboot your system...

bobengelAuthor Commented:
Haven't had a chance to try the above yet but will post results if it works.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now