dialup networking activates when I start any database

This has been driving me nuts for quite sometime.

I have a Windows 98 pc with Oracle installed, as well as sql server and interbase (I have had the problem also with each individually).

Whenever I start or connect to a database, directly or via an application, my dialup networking activates, and I need to cancel it. After that the database access proceeds fine.

This is quite bothersome.

I have tried uninstalling and reinstalling my dialup networking which someone suggested may change the order that the software looks for the database, but it did not help.

My address is kishj@concentric.net if you have any ideas, though please post them here for general benefit as well.

Thanks
Jeff

kishjAsked:
Who is Participating?
 
bchewConnect With a Mentor Commented:
The "quick logon" selection is in In Control Panel, Networks, Client for Microsoft Networks.  However, without a PATH to a network drive that should not matter.  While you are in there, you should delete all of the duplicate entries and any protocols you do not acutally need (probably all except TCP/IP?)

Then your configuration would look like this:

control panel
  network applet
    configuration tab
      client for microsoft networks
      dial-up adapter
      SMC EZ card 10/100 (SMC1211TX)
      IPX/SPX-compatible Protocol -> Dial-Up Adapter
      IPX/SPX-compatible Protocol -> SMC EZ Card 10/100 (SMC1211TX)
      NetBEUI->Dial-Up Adapter
      NetBEUI-> SMC EZ Card 10/100 SMC1211TX)
      TCP/IP-> Dial-Up Adapter
      TCP/IP-> SMC EZ Card 10/100 SMC1211TX)

      File and printer sharing for Microsoft Networks
   
Or better yet, like this:

control panel
  network applet
    configuration tab
      client for microsoft networks
      dial-up adapter
      SMC EZ card 10/100 (SMC1211TX)
      TCP/IP-> Dial-Up Adapter
      TCP/IP-> SMC EZ Card 10/100 SMC1211TX)

      File and printer sharing for Microsoft Networks

0
 
1cellCommented:
if you are starting the apps from a shortcut, try going to the programs' directories and executing them with the actual program file.  Just a guess but let me know what happens.
0
 
EDStechCommented:
It sounds like the oracle database is making a call to an external data source which is viewed as a network resource.  This would cause the DUN to start up and try to dial the network to allow access to the resource.

Go run internet explorer without being online the net.  Does it try to dial the net?  If so, you need to turn off that auto connect.  Sadly, I can't recall how to do this and by the time I look it up someone else will have answered, so have it at gents.  ;)
0
SMB Security Just Got a Layer Stronger

WatchGuard acquires Percipient Networks to extend protection to the DNS layer, further increasing the value of Total Security Suite.  Learn more about what this means for you and how you can improve your security with WatchGuard today!

 
fracheCommented:
Please give more information about your network/ internet parameters :
Modem, Network card, ip protocol

I think it's a IP problem from DNS. Oracle try to resolve name with external DNS ( provider DNS ).

IP parameter for internet must be declared in dialup networking.
Nothing about Internet DNS in :
Control Panel / Network / ip protocol

You try to create a host file in your c:\windows directorie.

ex :

172.25.0.10    pcoracle.dom
0
 
ddaCommented:
Can you post your TNSNAMES.ORA, SQLNET.ORA and LISTENER.ORA files here? They are in /network/admin subdirectory of %ORACLE_HOME.
0
 
kishjAuthor Commented:
Yes, I will do all I can. Let me see, can I attach, or is it cut and paste? Please note that this even happens with interbase and sql server, so I think it is something weird with the network/dialupt paths, though it could be a setting with each database.
0
 
Somebody_elseCommented:
run internet explorer and go to the menu bar at the top, there will be a selection called "view" select this and choose "internet options", then when the dialog box pops up choose the "connection" tab, the will be a box with options in it, one of the options will be called "connect to the internet using a local area network", click the circle next to this one so that it is chosen then apply the changes and, voila`, your dun won't initialize when you try to connect.
0
 
kishjAuthor Commented:
Thanks for the response, and you were kind of correct.
Now the database connections don't startup the dialup networking, but now non of my internet software can connect either! The programs report "Unable to establish an internet connection".

So technically it solved the problem, but the solution is not practical (I don't want to have to change the setting everytime I want to run programs and then access the internet). Do you have another suggestion, or a modification of this suggestion?


Thanks anyway..


I am including some of the other information asked for by the comments below, in case there is some follow up.





1 - shortcut or not, the same happens.
2 - yes, autoconnect is on, but it is at work too, and I don't experience this problem... At least the autoconnect in the dialup networking. I don't know why its getting activated in the first place. Is this what you are referring to?
3 - I don't really see anything in control panel - modem that would affect this situation? As far as networking...
control panel
  network applet
    configuration tab
      client for microsoft networks
      dial-up adapter
      SMC EZ card 10/100 (SMC1211TX)
      SMC EZ Card 10/100 PCI (SMC1211TX)
      SMC EZ Card 10/100 PCI (SMC1211TX)
      IPX/SPX-compatible Protocol -> Dial-Up Adapter
      IPX/SPX-compatible Protocol -. SMC EZ Card 10/100 (SMC1211TX)
      IPX/SPX-compatible Protocol -. SMC EZ Card 10/100 PCI  (SMC1211TX)
      IPX/SPX-compatible Protocol -. SMC EZ Card 10/100 PCI  (SMC1211TX)
      NetBEUI->Dial-Up Adapter
      NetBEUI-> SMC EZ Card 10/100 (SMC1211TX)
      NetBEUI-> SMC EZ Card 10/100 PCI (SMC1211TX)
      NetBEUI-> SMC EZ Card 10/100 PCI (SMC1211TX)
      TCP/IP-> Dial-Up Adapter
      TCP/IP-> SMC EZ Card 10/100 (SMC1211TX)
      TCP/IP-> SMC EZ Card 10/100 PCI (SMC1211TX)
      TCP/IP-> SMC EZ Card 10/100 PCI (SMC1211TX)
      File and printer sharing for Microsoft Networks
    Identification Tab
      Computer name 'Jeffs433Celeron'
      Workgroup 'kishWorkgroup'
      Computer Description 'Jeff'
    Access Control Tab
      Share-level access control turned on via radio button
      Obtain list of users and groups from: 'KishWorkGroup'

Some of the properties for selected line items from tabl one:
Dial-Up Adapter Properties
  Driver Type Tab
    Enhanced mode (32 bit and 16 bit) NDIS driver
  Bindings (the following three items are checked)
    IPX/SPX-compatible Protocol -> Dial-Up Adapter
    NetBEUI -> Dial-Up Adapter
    TCP/IP -> Dial-Up Adapter
SMC EZ Card (all 3) have the same 3 protocols selected
The 3 IPX/SPX under Bindings have both items checked:
    Client for Microsoft Networks
    File and printer sharing for Microsoft Networks
For all TCP/IP items, DNS is disabled. I have a hard coded ip address as follows:
    ip addres 192.9.200.2
    subnet mask 255 255 255 0

I am not sure what you mean about the host file. I mean, I have one, and it is as follows:


127.0.0.1       localhost
192.9.200.2      Jeffs433celeron

The Oracle files:

TNSNAMES.ORA:
#This is a SQL*Net Configuration file generated by SQL*Net Easy Configuration.
#Attention: Do not modify this file yourself.
#If you do, your SQL*Net Easy Configuration may not function properly.
     
Example1.world =
  (DESCRIPTION =
    (ADDRESS_LIST =
        (ADDRESS =
          (COMMUNITY = tcp.world)
          (PROTOCOL = TCP)
          (Host = Production1)
          (Port = 1521)
        )
    )
    (CONNECT_DATA = (SID = SID1)
    )
  )
Example2.world =
  (DESCRIPTION =
    (ADDRESS_LIST =
        (ADDRESS =
          (COMMUNITY = spx.world)
          (PROTOCOL = SPX)
          (Service = Server_lsnr)
        )
    )
    (CONNECT_DATA = (SID = ORCL)
    )
  )
Example3.world =
  (DESCRIPTION =
    (ADDRESS_LIST =
        (ADDRESS =
          (COMMUNITY = nmp.world)
          (PROTOCOL = NMP)
          (Server = FinanceServer1)
          (Pipe = ORAPIPE)
        )
    )
    (CONNECT_DATA = (SID = ORCL)
    )
  )
Tcp-loopback.world =
  (DESCRIPTION =
    (ADDRESS_LIST =
        (ADDRESS =
          (COMMUNITY = tcp.world)
          (PROTOCOL = TCP)
          (Host = 127.0.0.1)
          (Port = 1521)
        )
    )
    (CONNECT_DATA = (SID = ORCL)
    )
  )
Beq-Local.world =
  (DESCRIPTION =
    (ADDRESS_LIST =
        (ADDRESS =
          (COMMUNITY = beq.world)
          (PROTOCOL = BEQ)
          (PROGRAM = oracle73)
          (ARGV0 = oracle73ORCL)
          (ARGS = '(DESCRIPTION=(LOCAL=YES)(ADDRESS=(PROTOCOL=beq)))')
        )
    )
    (CONNECT_DATA = (SID = ORCL)
    )
  )
kishj.world =
  (DESCRIPTION =
    (ADDRESS_LIST =
        (ADDRESS =
          (COMMUNITY = tcp.world)
          (PROTOCOL = TCP)
          (Host = Jeffs433celeron)
          (Port = 1521)
        )
        (ADDRESS =
          (COMMUNITY = tcp.world)
          (PROTOCOL = TCP)
          (Host = Jeffs433celeron)
          (Port = 1526)
        )
    )
    (CONNECT_DATA = (SID = orcl)
    )
  )
ntorcl.world =
  (DESCRIPTION =
    (ADDRESS_LIST =
        (ADDRESS =
          (COMMUNITY = tcp.world)
          (PROTOCOL = TCP)
          (Host = jeffs433celeron)
          (Port = 1521)
        )
        (ADDRESS =
          (COMMUNITY = tcp.world)
          (PROTOCOL = TCP)
          (Host = jeffs433celeron)
          (Port = 1526)
        )
    )
    (CONNECT_DATA = (SID = ORCL)
    )
  )

SQLNET.ORA:

AUTOMATIC_IPC = OFF
TRACE_LEVEL_CLIENT = OFF
names.directory_path = (TNSNAMES)
names.default_domain = world
name.default_zone = world
names.default_domain=world

LISTENER.ORA:

LISTENER =
  (ADDRESS_LIST =
        (ADDRESS =
          (PROTOCOL = TCP)
          (Host = Jeffs433Celeron)
          (Port = 1521)
        )
        (ADDRESS =
          (PROTOCOL = TCP)
          (Host = 127.0.0.1)
          (Port = 1521)
        )
#        (ADDRESS =
#          (PROTOCOL = SPX)
#          (Service = Jeffs433Celeron_lsnr)
#        )
  )
STARTUP_WAIT_TIME_LISTENER = 0
CONNECT_TIMEOUT_LISTENER = 10
TRACE_LEVEL_LISTENER = ADMIN
SID_LIST_LISTENER =
  (SID_LIST =
    (SID_DESC =
      (SID_NAME = ORCL)
    )
  )



0
 
ddaCommented:
As far as I know, intranet addressed should start with '192.168.xxx.xxx'.
Try to change it.
Another suggestion. As long as you want to access only the local oracle database, you can use "2:" when connecting:

slplus name/password@2:

HTH,
Dmitry.
0
 
fracheCommented:

- Not OK with DDA :
Your @IP is Ok for Internet : private classe B address.
( like '192.168.xxx.xxx' private classe A address).
- Your host file is OK.
- Parameters for modem (dial up adapter)must be declared in "dialup networking".
-> workstation
 - dialup network
 - control panel
0
 
kishjAuthor Commented:
frache,

are you asking me for information? I am not sure if you are telling me I need to set some parameters in dialup networking, or if you are asking me for information.

dda,

This might do something for Oracle, but won't help me with the general problem, right?

Thanks
Jeff
0
 
ddaCommented:
Yes, you're right. I have only Oracle here, so please try my suggeston, connect to the local database without listener, via @2:.
0
 
bchewCommented:
Do you have a network resource listed in your PATH?  And do you have "Quick Logon" enabled?

Bert
0
 
kishjAuthor Commented:
1 - where do I look for quick logon?
2 - my path is as follows(I don't see any other computer on the path):

PATH=C:\WINDOWS;C:\WINDOWS;C:\WINDOWS\COMMAND;C:\ORAWIN95\BIN;C:\PROGRA~1\NETWOR
~1\MCAFEE~1;;C:\PROGRA~1\BORLAND\CBUILD~1\BIN;;C:\PROGRA~1\BORLAND\CBUILD~1\PROJ
ECTS\BPL;;C:\ORAWIN95\BIN;C:\PROGRA~1\ULTRAEDIT;C:\DOWNLOADS\UTILITIES;C:\MSSQL7
\BIN;C:\BC5\BIN;C:\DOWNLOADS\TOOLS\PFE32;;C:\PROGRAM FILES\BORLAND\DATAGATEWAY\B
IN;
0
 
Somebody_elseCommented:
now that you're explorer settings are correct you have to specify the server and gateway settings so that your internet software can use the internet server to connect to the internet or if you don't have a dedicated internet connection the you have to dialup the ISP before trying to connect.

btw, not to nitpick but I did answer the original question you posted. You didn't specify any other requirements either.
0
All Courses

From novice to tech pro — start learning today.