telnet

i have got redhat linux 6.0 installed and when i try to telnet from a remote machine to  my machine using the root account i get " login incorrect" message.i am using the correct password for sure. it happens locally also.
please help me with this.
shajigAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

bughead1Commented:
That is, I believe, what it is supposed to do. Telnet is already insecure enough without allowing a root user to login from someplace else.  

Try this:  telnet in as an ordinary user.  As soon as you are logged in, "su" to root.

If you aren't sure what that means -- "su" is switch user or something like that.  If you just enter su at the command line, by default it is assumed you want to become root. So, when it asks for a passwd after you enter su, type the root password for that machine.

I have one RH 6.0 box and 4 Slackware boxes in my home LAN. They all work the same in this respect.  I like to add an account called "admin" that I use for remote login.  You don't even need to create a home directory for "admin."
0
bughead1Commented:
Sorry, I overlooked the fact that you said it happens locally, too.  I've run into that on some RH 6.0 machines when  I  put together passwords with symbols like $ & and so on. Doesn't always happen. You might try logging in locally with the root password without the symbols. I have no clue why this occurs, I have experienced it on three RH 6.0 machines, other RH 6.0 machines didn't do this -- and I've never experienced it on any of the Slackware machines I put together.

However, you are still probably going to need to login as an ordinary user and su to root during telnet sessions
0
IexpertCommented:
telnetting as root is bad practive and disabled by default. This is because anyone can sniff your password easily when you telnet as root.

You can instead telnet is as a normal user and su to root. I.E. type su
then you'll be prompted for the root password, and tada you're root.
A lot better than the NT model let me add, where you have to close
all programs log out and log back in as Administrator!

Anyway.. If you insist on telnetting as root, remove the file /etc/securetty
Or even better add the terminals (to the file /etc/securetty) that you want to allow root access on. The names are added one per line, for e.g.:

ttyS0
ttyS1
ttyp0
ttyp1

This will allow you to login as root on COM1, COM2 and 2 LAN telnet connections.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.