CD-ROM drive not mounting

HELP!   (Weed, please do not answer)

My new Apple CD-ROM drive has suddenly stopped mounting CDs!!  The tray opens fine, it pulls in fine, but nothing shows up on the desktop.  Pushing the eject button (on the faceplate) makes the tray come back out again -- with a disk inside it!  Nothing appears on the desktop no matter how long I wait.

My equipment and software:
PowerMac 9500, G3/333 card, fairly new AppleCD 1800i (12x speed), MacOS8.6,
Floppy disks mount okay, Zip disks mount okay, external SCSI devices mount okay.

The situation that may have caused it to break down is as follows:
Running VirtualPC with Windows 95, I try to install Microsoft's "Start Now! MSN Internet Access" from the CD that came in the postal mail (junk mail).  It had Internet Explorer 5.0 that I wanted but didn't want to download.  After the installation wizard goes halfway, everything freezes.  Not only does VirtualPC freeze, but my Mac freezes, too.  I had reboot with Control-Command-Power.  VirtualPC also had to be relaunched a couple of times to get back to normal.

I'm suspecting a physically broken CD-ROM drive.  But how could a disk break a drive?  This AppleCD 1800i unit is a "new" unit that was probably pulled out of an overstocked Macintosh and sat on the shelf for a few months.  How can I be sure it's not the software or the driver or a set of extensions?

Things I've tried include:
Starting up with "MacOS 8.6 Base" set in Extension Manager.  No difference.
Starting up with a bootable MacOS 8.5 CD and holding the "C" key.  It boots from hard drive.
Mounting with SCSI Probe 5.1.1.  Mounting Log says, "Device 0.3.0: FAILED: driver installed but no drive entries."
Looking at the Extensions folder.  No recent changes to the Apple CD/DVD Driver extension.  It looks okay.
Looking at the Prefs folder.  Nothing that says CD-something recently changed.

HELP!
archkenAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

brian_bCommented:
Well, there's only 2 things left to do, replace the cd-rom cable. If it's scsi, and you know the HD works and is scsi as well, connect the HD cable to the CD-Rom instead, and the power connector from the HD as well, and try booting off an apple cd-rom. I've had instances where a power connector was bad, but only once. If this doesn't work, then it's obvious the cd-rom is dead. Did you check to see that any jumpers might have failed, or fallen out of place?
Lastly. There's a patch that will mount almost all CD-Roms. The link to this is http://www.delta.edu/~dgschmid/patches.html
I've used it to get some cheap NEC cd-roms to work on my beige G3, so if it worked for them, it should definitely work for an apple drive.
Sounds to me like the drive is hosed though and you've already tried most everything.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
brian_bCommented:
That'll teach you to install microsoft stuff on a mac...  8)
Also, check SCSI id settings. SCSI probe should tell you that anyhow.
0
archkenAuthor Commented:
Thanks for the download link to the patch.  Unfortunately, it did not help.  I also tested the cables as you suggest.  No change.  All SCSI ID jumpers are okay.  All connectors look okay.  It's most peculiar because for two weeks it worked fine.  There were no physical changes that occurred before the "break down."

With the computer case still open, I replace this 12x unit with an old dual-speed unit.  Both are Apple-labeled CD-ROM drives.  The dual-speed works fine.

So this seems more and more a physical problem inside the unit.  Most peculiar, however, is that the clear plastic label over the drive reveal the disc spins!  So it pulls in and it spins -- but it does not mount on the desktop.  Weird.

Is there any other way to verify that it is absolutely NOT software-related?  I'll have to return the drive for warranty repair or replacement, but I wouldn't to go through the hassle if it turns out only to be a software issue.

[Damn microsloth junk mail]
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

brian_bCommented:
hehe, just face it, it's dead. The motor can work fine, but laser can be dead, simple enough.
0
redironmanCommented:
Here's what I'd try....

By the situation, it definitelysounds like a software problem.  If it's not, it was too coincidental.  Since you found a CD drive that works with your system (the 2x), do a clean install of the system onto your harddrive.  I always start my startup system name with a space to keep it on top and separate.  After the 4 hour clean install (with the 2x!), replace your cd extensions with the newly installed ones.  Also replace your drivers (Yes, there was an 'S' on that!) for your cd's.  To find the drivers (which should be in a driver folder in an STF file) hold your apple/squiggly/control key, and type 'f' for find file.  Look up 'cd' to find your cd files.  While you are at it, make sure you upgrade to the same system # (8.6), and replace the 'System' file in the system folder.  It sounds like something was damaged (especially when you shut down after the freeze) that needs replaced.  GOOD LUCK!!!  
0
brian_bCommented:
Sorry, but if it once worked for booting with the c key, or command-option-shift-delete, and it doesn't now. It has nothing to do with drivers. Although were you ever able to boot to the MacOS cd with this drive before?
Second. That patch I sent you works really good from what I've heard from people. I used it to bring up a really old 1X apple external CD-Rom, So I'm a believer.
Anyhow. You tried with base extensions, what about a clean system folder, core.
If this, and the CD-Rom patch I sent ya fail, then once again. She's dead.
I don't know if they're free or have demos, but there's two other products out there. CD-Rom SpeedTools, and FWB CD-Rom Toolkit. Both are specifically for mounting those rare cd-rom readers drivers.
TTYL
0
brian_bCommented:
What does Apple System Profiler say for Driver, Vendor, Revision# and Product ID?
0
redironmanCommented:
Booting from the system boot disk with the c button held down does not require a driver on the hard disk.  When you boot from the system disk, your Mac uses a driver off of the cd.  Try what I said and let us know if it works.....
0
archkenAuthor Commented:
Thanks for the comments.

I always hesitate when looking at the option of re-installing the OS -- especially a clean install.  Every time that I must do it, my settings and preferences and desktop and everything else (my universe is on my Mac, btw) takes at least a FULL WEEK to get back to normal.  Yes, I'm one of those Mac fanatics.  =-)

This stupid 12x CD drive sure seems dead.  To answer brian b's second question -- yes, I was able to boot from the Mac8.5cd with this unit when I first installed it.  I made sure it was a "bootable CD-ROM drive" like they advertised.  The download patch did not have any affect on any of my CD drives -- this suspect 12x, an old 2x, and also a Plextor CD-R located in an external SCSI box (which I don't need as a CD reader anyway).  So for these drives, the patch is irrelevant -- but thanks anyway for the link.

Apple System Profile says something like:
Matshita Product ID CR-507-C.  It's no longer inside my Mac, however.  When the 12x unit stopped mounting, booting with the c button does NOT make the CD drive boot.  It booted from the hard drive like without the c button pressed.

So I must agree that it's a dead unit.  Good news is that, over the phone, the saleslady said they will honor the warranty.  I'm waiting to see for certain if they will do that -- and how long it would take.

0
centervCommented:
Sure sounds like the drive died on you as you were playing with MS.
And here I am writing this on a wintel.
Anyway, I feel for you about the clean install, so I'm going to share with you what I've been doing for years very successfully.
I use a jaz disk, but you can do the same thing using floppies.
When you have your system running perfectly to your liking, copy your finder, system, system preferences, and any other items that you deem necessary and put them away.
When you get a corrupt system, take the corrupted  items out of their folder or rename, and put in the trash. You can't empty the trash now.
Copy the new items from the floppy in the proper locations, restart and empty the trash.
New system in place.
With jaz, I install the full system on a disk and have access to replace any item.
I can't tell you the countless hours it saves me.
May not be totally clean but it works.
0
archkenAuthor Commented:
Thanks, centerv, for the advice on System item copies.  My external hard drive does, in fact, come in handy for this purpose.

Good news is that the 12x CD-ROM just came back from the reseller.  I think it's a refurb unit, but it works fine.
0
archkenAuthor Commented:
So this question should be coming to a close, and I suppose I must accept one of the comments as the answer -- probably brian b's.

My hesistation about this refurb unit (I think) is again about how the malfunction occurred in the first place:
If I try to do the same again, will it break again?

If I launch VirtualPC, then try to install the software from the Microsoft junk mail CD (haven't thrown it out yet), then will it ruin my CD-ROM drive again?  Was that the reason for my broken CD-ROM drive in the first place?  OR was it just a coincident?

This replacement unit works fine.  I just checked that it's a bootable CD-ROM drive, just like a new Mac's.  I'd hate to break it again with that Microsloth junk.  How can I be sure?

Any ideas?
0
brian_bCommented:
heh, I wouldn't say it was any particular thing that killed your cd. Just freak luck you happened to be using a MS CD. The cd-rom has a motor, and a laser reader. It see's data as data and sends it to the controller nomatter what format/program it is. when it leaves the cd it's nothing but a stream of 0's and 1's. Only time cd's have a hard time, or give the reader a hard time, is when their either poorly mastered, like fragmented, or have multiple sessions. Then the head goes all over the place. Did the ms cd have multiple volumes or a hybrid disc?
But like I said, data is data to the CD-Rom itself. I wouldn't be afraid, then again, I would be afraid of MS Stuff  8P
Components just crap every now and then......

0
archkenAuthor Commented:
Everything works!  IE 5 for Win95 also installed fine in VirtualPC using the replaced 12x CD-ROM drive.  The broken drive was probably coincidental.

FOLE (for our learning experience), there may still be a cause in using a disc that's unusual in some way.  If the disc does not mount, but keeps trying to mount, and the computer freezes forcing a reboot, wouldn't the reboot in the middle of the disc mounting process cause the read/write head to misbehave?  -- especially when the driver is emulated through VirtualPC's software?  Even with genuine Win95 CDs, a volume usually takes longer to mount compared to my native Mac desktop.  This is just a wild guess.  Using an ancient home-grown CD-R that does not mount, both OS's actually froze again until the disc was yanked out of there.  No crash, but it sure looked scary.  Looked exactly like before.  A reboot may have killed it again, but I knew it was an ancient disc.  Still scary.  Dunno.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apple Hardware

From novice to tech pro — start learning today.