Why doesn't Win 98 recognise my new CD-RW drive

I recently bought an Acer 4X4X32 CD-RW drive.  My preferred configuration was to install it as the master on my secondary IDE port and leave my HDD and CD-ROM drive as master and slave respectively on my primary IDE.

However, Windows 98 does not seem to detect the CD-RW drive on the secondary IDE, even after running ADD NEW HARWARE from the control Panel.  I have already checked the following:

1)Both IDE ports are enabled in my motherboard BIOS
2)Both IDE ports are enabled in Win 98 device manager|IDE HDD controller
3)CD-RW drive jumper is set as "Master" when connected to the secondary IDE.

I think it's something obvious that I've overlooked, but I can't figure out what it is...

Since I can't use my CD-RW drive on secondary IDE, I've currently hooked it up as the slave in my primary IDE

Any Suggestions ?
equahAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MrbreezeCommented:
When you say
<Both IDE ports are enabled in my motherboard BIOS> are you speaking of Standard CMOS and set the Primary and Secondary channels? Are the Primary Master and slave set to auto in type and mode as well as the Secondary master set to auto in type and mode.
                       Mrbreeze
0
jhanceCommented:
There should me no problem running the CD-RW drive as a MASTER or SLAVE on the secondary controller.  

Have you checked the cable?  It may be faulty or it may be plugged in backwards.

Maybe a silly question, but I'll ask just to be sure.  Are you plugging the power cable into the CD-RW drive?

On some Motherboard/BIOS setups not only do you have to enable the 2nd IDE port (which it seems you've mentioned that you have already done) but you must also set the BIOS to detect the drive.  Start your BIOS setup and see if the secondary IDE is set to "NO DRIVE".  If it is, set it for "AUTO" or go the the "Detect IDE Drives" section of the BIOS and let it detect the drive.

(NOTE: The exact wording of the BIOS setup messages may differ depending on your BIOS.)
0
centervCommented:
Check the properties/settings or the CD-RW under the device manager, and if DMA is checked, uncheck it and reboot.  Hope it helps.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

sorgieCommented:
Does the CDRW require a jumper set to master if it is the only device on the controller?
Check your documents, some devices don't require any jumper when they are the master but only device on the controller,
Good Luck
0
baldrickCommented:
On a different tack - One time my CDROM drive vanished completely from within Windows. No real mode drivers had been loaded, and all the latest virus scanners reported no problems. The drive just vanished completely.

I assumed (wrongly) that the drive controller had failed until a friend advised me to drop to DOS (preferably from a clean boot floppy disk) and run FDISK /MBR.

Sure enough, the drive appeared again... I've absolutely *no* idea how or why this worked, mind...
0
bbrinizerCommented:
You will have to have both cd rom and cd read/writer on the same cable and move the hard disk to the other 'ide ribbon'. Then restart you computer and check as the startup screen comes up that the bios sees you hardware. You may have to reinstall your cd read/witer software again afterwords.
0
MrbreezeCommented:
I think you meant that as a comment because it is incorrect. You do not have to run the CDRW on the same cable as the CD. Also this is Win98 and you don't need software to run the CDRW, Windows drives it.
                          Mrbreeze
0
whoamiCommented:
bbrinizer,

What brought you to the conclusion that he would have to have both cd and cd/rw on the same cable?  This is less than satisfactory and not an answer that equah would like to choose.
0
rayt333Commented:
bbrinizer
You are not new here so what's up with the BS answer? From the looks of some of the other comments they were troubleshooting the problem and you stopped that with an answer off in left field somewhere. Please refraim from posting such nonsense except as a comment which can be ignored if wrong and let others try to resolve the problem.
0
MrbreezeCommented:
But no comment on any of the comments we have made?
                         Mrbreeze
0
equahAuthor Commented:
Thanks all for replying...

I think it's safe to assume that the problem has nothing to do with the BIOS settings or any faulty connections as the CD-RW drive was detected during boot-up.

I'll try centery's suggestion and see how I go...

equah
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.