Printing from MS-DOS, EPSON LX300

I am doing a job for one of my clients, they use a DOS based program on a LAN, I have changed the LAN freom being NOVELL 3.12 with diskless DOS workstations,to NT 4.0 and Win98 workstations.

The problem is that the program prints to two different printers, HP 2100 on LPT1 (physically on one computer, and captured to the network path on the others). and LPT2 for Drug labels on the LX 300.  Which at this time is physically connected to the Server, shared and captured to all the workstations LPT2.

This works fine, but when the client moves to the new building they need the Printer (LX300) connected to one of the workstations and shared from there.  But when you print from the DOS program it doesn't do anything, the printer light goes off, and the print cue says there are 17 bytes printing (which is about all the print job is.)  If you turn the printer off and on again it prints that print job, but then the same thing happens if you print again.

The DOS program is set up to send an ESCape sequence to initialize the printer (27, 120, 48) I think.  It's almost as though whatever it sends to initialize the printer freezes it, then by turning it off you are resetting it, and when turned back on it receives the DATA as though nothing were wrong....But what is wrong?????

The Hardware on the NT server is identical to that of the Win98 workstation.  It seems to be a driver or software problem not with the DOS program, (since it will print from all the workstations if physically connected to the server.)  But more so the intervention of the Win98 driver.  Any other driver I can get?  Patch???? redirection program????


LVL 2
nicademusAsked:
Who is Participating?
 
foulcConnect With a Mentor Commented:
simply call type "filename" > "port"
In the program , it works fine
0
 
1cellCommented:
here's some info on it.  you bight be in or out of luck by the looks of things

http://support.epson.com/webadvice/wa0044.html
0
 
AST99Commented:
Nicademus

The first thing you should do is to print the default settings of the printer and check there. I worked on one of these 2-3 years ago but can't tell you what it was you had play around with.

The default settings are activated by holding down some sort of a button and turning it on. The instructions are then printed and you have to control and change settings by pressing various buttons. Keep in mind the instructions are rather cryptic so take your time.

As for calling Epson, the printer is probably Out of Warranty and they charge you for the support and there is no guarantee that if you pay, you get an answer. But for sure, look into the default settings. You might want to call their fax back and request info on this.

Good luck

AST99
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
1cellCommented:
ast99,  the link above takes us to a page where we see that epson does not have ODS drivers for this printer.  The only drivers which might make it work would be inherent to the software which is doing the printing.  The instructions for the printer will not solve this.
0
 
1cellCommented:
after reading your question a bit closer

<<If you turn the printer off and on again it prints that print job, but then the same thing happens if you print again.>>

this would imply that there is either a problem with the driver or the spool itself.  It really shouldn't be a problem with the spool since the file is only 17 bytes.  the driver seems to at least to the job of getting the data out in the irght format which is not to difficult for text.  

What mode is the parallel port in???

Try switching between EPP, ECP, and straight parallel
0
 
zombiwulfCommented:
This may sound silly, but how long are you waiting for the job to start?

Win95's dos by default waits 45 seconds after the data stops sending before it assumes that the job is complete; there isn't an autoendcap like there is with Novell.
0
 
nicademusAuthor Commented:
Well, thanks all for the expedient response, The ports have been configured in ECP, EPP, SPP, ECP & EPP 1.7 and 1.9 "Compatible", etc.
It's interesting what you said zombiwulf.

It reminded me that if I change the spool settings so that it prints directly to the printer the DOS program just sits there but has done the same thing, frozen the printer, but not printed.  The only difference being that if I turn the printer off and on it doesn't print the job because it was not spooled anywhere.
Does the 45s count when you have it "Print directly to printer"?

But it can't be the program, can it? since the program prints to the printer when it is connected to the NT server.

It made me think that NT drivers are most similar to Windows 95a drivers so what if I tried a win95a WS with it? But I don't want that because it defeats the Y2K, FAT32, etc. purpose of win98 being on the W/S.
0
 
1cellCommented:
In regards to the driver question in your last post,from what I got out of the epson site, the drivers for this printer in DOS would be provided by the application.
0
 
nicademusAuthor Commented:
There are not actually any drivers for the program, but the program sends ESCape characters directly to the port to set up such things as FONT size, paper length, tab width, condensed/narrow font, etc.  And the thing is that when you do the switching off/on it still prints these characteristics perfectly, if you can imagine a medicine bottle with a prescription sticker on it, that is the kind of label it is printing on, it prints just in the space nescesary, with condensed font.
So why is it that what "eventually" gets to the printer is the data and it's formatting codes.  I wonder if there is a capturing or piping program which will let me see what (in escape sequences) is being sent to the printer at any one time, so I might be able to see which code is stopping the printer in it's tracks, and then which characters are being sent after the "reset"?

More to follow...back soon.
0
 
nicademusAuthor Commented:
I have been in touch with one of the software manufacturers Technicians.  It seems there has been a couple of cases before.  The problem according to them is the BIOS in the epson printer does not get along well with newer printer ports, particularly ONBOARD printer ports.

he described the symptoms exactly, that when you print it turns the printer off, not so much putting it off-line, but actually powering it down!
It's because new ONBOARD printer ports seem to send a different init code, like a positive trigger instead of a Neutral or something.

Any thoughts on this train of thought?

(printer is about 5 or six years old.)

I can buy a new one (they still manufacture them you know - with the newer compatible BIOS)
0
 
1cellCommented:
couldn't disagree though I really don't know...........

wonder if the bios is souldered in.  if not, you could probably buy just that unless there's a way to flash a printer bios.

if you want to spend the money, get a new one and see if it solves it.  if not, return it.

0
 
nicademusAuthor Commented:
Sorry Foulc your answer is a little vague, are you saying that as a capture setting.

as in the windows printer port to file: instead of lpt1:

that will let me capture it as I asked, but I'm still looking for a bit broader answer.  If you don't mind I'll hold off on accepting that answer, besides it'll be a few days before I can test that theory.  Anyone who wants to post any more comments though is more than welcome.

1CELL I have a feeling it would be in a LIF socket, and get this...the Tech guy told me that the guy he spoke with got the new bios for about $25.00AUD, and then put it in himself.
Then I ring Epson to see where I can get it from, guy there says Oh well it's not as simple as just getting the chip you have to have someone put it in and then there are a couple of other things they have to do, I'll give you one of the service center's numbers.

Ring them, $75.00 just to have them look at it, then I bet they will charge me about $50 for the BIOS itself.

The printer is about five years old and my Client has told me to just buy a new one.  I'm going to do that on Monday, but if it doesn't work, you'll be hearing more from me, that's for sure.

And if it works I'll definately let you know, because it is bound to be something you'll come across again, re MSDOS print jobs.

Ciao.


0
 
vikiingCommented:
>>I wonder if there is a capturing or piping program which will let me see what (in escape sequences

You can go to "Properties" tab of your printer (Control panel -> Printer - choose your printer --> Right click) and change output to a FILE, rather than LPTn. That will create a file with the whole sequence of bytes you send to print.



>>simply call type "filename" > "port"
In the program , it works fine

That's only true when you want to capture screen output and send it to a file, not to capture printer output.



>.  It seems there has been a couple of cases before.  The problem according to them is the BIOS in the epson printer does not get along well with newer printer ports, particularly ONBOARD printer ports.

I don't think that's the reason; I have newer machines, with onboard printers, which deal with the ancient Epson LX-810, or a Citizen GSX-200, and everything works OK.
0
All Courses

From novice to tech pro — start learning today.