samba and win98

i have installed red hat 6.0 and have confugured samba. i managed to get my linux box in the network neighbourhood of the win98 computer.but when i double click it i get the network busy error.i have edited the smb.conf file by adding workgroup= workgroup and since i had to communicate with the 98 computer i uncommented the line for encrypted passwords too.i can telnet also.it works fine. after some time when i tried to restart the service on the samba server i noticed that the shutdown failed .i wonder what could i have done wrong? please help  me on this issue. tks!
shajigAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mmipsCommented:
Did you create a smbpasswd file...Otherwise samba won't know anyone...there is a mksmbpasswd script that you need to run against your current passwd file...Also you might run the configuration tester...If your Redhat distro didn't include it you could get it from the samba web site... Here is my smb conf...

# Samba config file created using SWAT
# from localhost (127.0.0.1)
# Date: 2000/01/15 10:34:16

# Global parameters
      workgroup = WORKGROUP
      netbios name = FEYNMAN
      server string = RedHat 6.1
      interfaces = 192.168.10.25/255.255.255.0
      encrypt passwords = Yes
      smb passwd file = /etc/smbpasswd
      username map = /etc/username.map
      log level = 0
      log file = /var/log/samba-log.%m
      max log size = 50
      socket options = TCP_NODELAY IPTOS_LOWDELAY SO_SNDBUF=4096 SO_RCVBUF=4096
      hosts allow = 127.0.0.1 192.168.10.
      hide dot files = No
      strict locking = Yes

[homes]
      comment = Home directories
      read only = No
      create mask = 0750
0
dcavanaughCommented:
You're off to a good start with the smbpasswd file.  

As in mmips example, the "encrypt passwords" line <must> be yes, otherwise you will not get Win98 working.

From your Win98 machine, can you ping the IP address of the Samba server?  If not, the problem is IP connectivity not Samba.  I mention this only because many of the "Samba doesn't work questions" are really Ethernet configuration or IP address/routing issues.  

The icon in network neighborhood proves only that the server can transmit a broadcast packet and the client can pick it up.
0
biard1Commented:
Set up a user account on the Linux machine with the same user name and password that is used to log into the windows machine.  Make sure when doing so, it writes entries for that user to the smbpasswd file.  Then log in to the win98 machine.  You should now be able to use the shares in NWNBHD.  
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

LuanCommented:
redHat6.0 has a major bug when using samba with win98 or winNT. You have to recompile ther kernel and disable the "win95 bug work around" in the section "filesystems" of the kernel configuration. After that your win client should see the linux box in the network neighbourhood.

good luck
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
biard1Commented:
I don't think that's entirely true.  I have RH 6.0 running on a server here.   Our workstations run Windows 98, 95 and NT workstation.  All three can see the server and interact fine.  I never recompiled my kernel once, nor did I ever see any docs that stated this as an issue.  I just enabled the encrypted passwords, and set up user accounts on the Linux box to match those on the workstations.  Redhat's SMB How-To explains in detail how to do this.

http://www.redhat.com/mirrors/LDP/HOWTO/SMB-HOWTO.html
0
LuanCommented:
Have a look at my other detailed answer with nearly the same problem.

http://www.experts exchange.com/Q.10268863
0
biard1Commented:
Well, he didn't use the kernel recompile.  He used a reinstall, which uses the SAME kernel.  So, I don't follow how this is pertinent.  I, by the way, did a server install, as did the person in your "link" above.  I got it to work with all forms of windows, as I stated above.  Therefore, I believe it is completely unnecessary to recompile kernel.  But, if that's how you get your jollies, by all means.
0
shajigAuthor Commented:
here again when i try to stop the samba services /etc/rc.d/init.d/smb stop    
i get the foll. message:

shutting down smb services     [ok]kill:bad signal spec'g'        [failed]

 and nextly  the starting works fine.

this is real funny coz i still cant get my machine to talk to win 98 computers.
:)
0
biard1Commented:
I would download and reinstall the latest version of SAMBA.

http://www.samba.org
0
shajigAuthor Commented:
i had samba-2.0.6 version. now when i try to install samba-2.0.8 from the red hat cd i get a conflict message with samba 2.0.6. how can i uninstall the old version of samba and i also deleted the smb.conf file but still the same message.
0
dcavanaughCommented:
I can think of a few ways to do this, but the easiest is to remove the existing samba packages.  

You may want to save your old /etc/smb.conf file for reference (if you spent some time setting it up).  Just rename it out of the way:
mv /etc/smb.conf /etc/smb.conf_save

Use the following command to get a precise list of the package names:
rpm -q -a | grep -i samba

For each package shown, do this:
rpm -e <pacakge_name>

Example:
rpm -e samba-2.0.6a-12

Then proceed with the samba install.

I still think you should verify IP connectivity by pinging from both server and client machines, but assuming you got that far, upgrading to the latest samba is certainly worth a try.
0
biard1Commented:
If you reject the above answer, you will likely get some extra feedback from other experts.  They usually won't post comments to an answered question.
0
lurwasCommented:
I've just completed my installation of Samba. I'm using RedHat 6.0 on one side, and Windows 98 SE on the other side.
You should surf to:
http://www.linuxnewbie.org/nhf/intel/network/samba/samba1.html
There you can find the excact information that is needed...:)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.