Solaris Install Pt. II

I tried installing Solaris 7 x86 with an updated boot disk.  Once again the installation failed.  The actual errors are as follows:

1. Cannot determine Boot Device name.  Please check machine 'boot device' and diag-switch'.

2.  "No Disks found."  Check to make sure disks are cabeled and powered up.

I have a Pentium III 500 128 MB RAM.  There are two hard disks connected to a ATA66 controller.  The first hardisk, configured as Master, is 20GB and contains Win98;  My second hard disk, configured as Slave, is 13GB in size.  I plan on using all 13GB of second disk for the UNIX operating system.  

In addition to this, I cannot seem to bring up the format utility from solaris to convert the 'free-space' of second hard disk to unix partitions.

I also tried installing Caldera 2.2 as a test to see if it can find my hard disks.  The installation also failed as well.

What can I do to make Solaris (or LINUX) see my hard disks?  Also, how can I bring up the format utility in Solaris?
shipleyAsked:
Who is Participating?
 
jlevieConnect With a Mentor Commented:
I suspect that you may just be out of luck with that particular controller. If Solaris (or Caldera) had the correct drivers for your controller, they would show both disk drives. Although you didn't say, I'm guessing that Caldera couldn't find any drives either.

The normal behavior of Solaris during installation is that once the device scan is complete it will show a list of all detected devices that it recognizes and all "bootable" devices. The fact that it doesn't offer either of the disks as "bootable" devices indicates to me that it doesn't have a driver that can "see" the disks.

All may not be lost. It's possible that a later version of Solaris (or Linux) might have a driver that works. There are several sub-releases of Solaris 2.7, identified by a date code printed on the CD. I believe that HW 8/99 is the latest for x86. You might also try Solaris 8. Or it may be possible to fiddle with bios settings for the disk controller and put it in UDMA/33 mode and have it work. I did find a note on RedHat's site about UDMA/66 controlers that might be useful (http://www.redhat.com/support/hardware/intel/61/rh6.1-hcl-i.ld-4.html)


0
 
samriCommented:
Shipley,
   Normall when you boot up from the Soalris 7 Device Configuration Assistant, (aka the boot disk), it went through a series of hardware detection stage.  Did you manage to go thru this where the computer display a list of detected hardware on your system.  Verify that the displayed items matched the configuration you have in your machine.  Otherwise, you need to do a specific scan.  
  The menu key (F1 thru F4) is pretty easy to use, and make sure that you have checked the Sun website (as I mentioned earlier) for hardware compatibility.  
  If you have tried almost everything you can think of, I believe you can drop an email to Sun and ask them for some help.
  One more thing, I wonder whether your machine are a "standard" system or a customized one.

Good luck.

Samri
0
 
samriCommented:
Shipley,
   Sorry had to come again for some comment.

Could you briefly explain at what point you got that error.

I believe you have gone thru the h/w detection, and you checked on the wrong device to boot you solaris installation.  (I think), please verify that you mark the device where your Solaris CD is loaded, and proceed.

Just to make sure, have you went past the portion where the X Window is tested?


Samri
0
 
shipleyAuthor Commented:
My PC is "somewhat" customized.  Its a Gateway Performance 500.  The only thing that was customized was what h/w I wanted on my system.

I have gone through the h/w detection stage.  I get two options to boot my Solaris OS:  

1. Drive E: My DVD Rom Drive (where the Solaris CD is located)
2. Drive F: My CD-RW drive

I check the box with my DVD device.

Next I do the X-Windows and test it.  It works fine here.  Then I choose web-start for the installation.  This fails and defaults me back to Interactive Install, which reports "No Disks found".

Should my hard disks show up on the h/w detection list?  Currently they do not, but a Mass Storage Controller does which I assume is my ATA66 Controller.

As for dropping Sun an email, I cannot seem to find the proper email address for technical support on their web page.  If you can provide this as well, I would appreciate it.
0
All Courses

From novice to tech pro — start learning today.