• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 285
  • Last Modified:

pppd annoyance

I've got ip-forwarding and ipchains set up, as well as pppd. (This sounds like a win95 problem but it's not.)

I can dial-in with win9X dialup networking and connect as long as I "open a terminal window after dailing".
The terminal window looks the same as the one at my ISP after I created a simpler /etc/issue2 for mgetty to display. But something still won't allow win9X to dial in without opening and logging on in the terminal window. Without it Linux just hangs up on me.
1 Solution
Did you compile mgetty with the -DAUTO_PPP option ? This is the part that allows mgetty to detect the automatic PPP negotiation that Win95 DUN uses. Check it in the mgetty makefile, not in the .h file
dudleyfAuthor Commented:
Well you are probably right. The only problem is that mgetty came pre-compiled and there was no makefile. I downloaded the mgetty.tar.gz file and saw that -DAuto_PPP is not enabled by default. However if it were compiled in there is a login.config file that needs to be set to enable it. I uncommented that line and it still didn't work. So I'm guessing I'll have to compile the download  
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

A proven path to a career in data science

At Springboard, we know how to get you a job in data science. With Springboard’s Data Science Career Track, you’ll master data science  with a curriculum built by industry experts. You’ll work on real projects, and get 1-on-1 mentorship from a data scientist.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now