large hard disk using MS-DOS compatiblilty mode

I recently upgraded from an 8.4gb disk to a 2.5gb Western Digital ATA-66 7200rpm drive.  My motherboard does not support ATA-66 but I don't think the drive is actually trying to use ATA-66.  Everything works perfectly but that drive is using MS-DOS Compatibility mode.  

I have the old 8.4gb disk slaved, and it uses the protected mode drivers with no problem.  

I have booted into safe mode and tried to remove the primary hard disk controller (dual fifo) but it says to remove the parent device first (Intel PCI Bus Master IDE Controller).  I tried that but after removing the parent device I still could not remove the controller.  After rebooting it autodetected the PCI Bus Master IDE Controller and then we were back to MS-DOS Compatibility mode.

What gives?
jsextonAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

dew_associatesCommented:
JS, depending upon who made the drive, you will either have to jumper the drive to enable ATA 33 or use a patch. Also, there may be a cabling issue to deal with.

As for the MS-DOS compatibility mode, once you straighten out the hardware issues, you'll have to remove an entry in the registry.

To do that, open REGEDIT by clicking Start, Run and typing in REGEDIT and clicking okay.

Go to the key noted below and remove the NOIDE entry from the following registry key:
 
HKEY_LOCAL_MACHINE\SYSTEM\CURRENTCONTROLSET\SERVICES\VXD\IOS

Dennis

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
cremmeCommented:
Go into the registry and goto "HKEY_LOCAL_MACHINE\ENUM" and delete the "MF"
0
Patricia Siu-Lai HoCommented:
jsexton,in extending Dennis' <use a patch>. Have you checked with the motherboard and upgrade the IDE driver to support UDMA.
pslh
0
Rowby Goren Makes an Impact on Screen and Online

Learn about longtime user Rowby Goren and his great contributions to the site. We explore his method for posing questions that are likely to yield a solution, and take a look at how his career transformed from a Hollywood writer to a website entrepreneur.

jsextonAuthor Commented:
pslh,
  The motherboard I am using is an Abit BX6-2 and does not support ATA-66.  Would I still need a patch for it?

Dennis,
  I ran Western Digital's software that came with the drive and sure enough ATA-66 was enabled.  I disabled it (now using ATA-33) but still no dice.  There was no "NOIDE" value in the registry key you specified.  I followed cremme's suggestion (thanks!) to force Windows to reinstall the hard disk controller.  Still, the drive is using MS-DOS compatibility mode.

I noticed that both hard disks are using MS-DOS compatibility mode; don't think that the old drive (D:) was before but I'm not sure.

Now what?!  Thanks for all your suggestions :-)
0
dew_associatesCommented:
Did you check the key in the reg that I mentioned above to make sure the NOIDE entry was gone?
0
jsextonAuthor Commented:
Dennis,

There was no "NOIDE" value in the registry key you specified
0
smeebudCommented:
I just got a
Diamond Max Plus
http://www.maxtor.com/diamondmaxplus/6800p.html

I had simalar problems:
I found out yesterday that you need to, with these new drives use the 80 wire ribbion.........It's still 40 pin but has a ground for each wire. With that if you turn off S.M.A.R.T in the bios......we don't need that.........that the drive will default to 33 all by itself and have no conflicts holding up the speed issue.

Unless of course your motherboard is ready for ATA 66

Regards, Bud
http://www.geocities.com/~budallen/
Bud's Win95 Win98 Tips and Troubleshooter
0
Patricia Siu-Lai HoCommented:
Js, you may check this.

[ BX6(Rev 2.0) Pentium®III AGP Based ATX Mainboard With CPU SOFT MENUTM II Technology ]


1. Intel® 440BX chipset (82443BX and 82371EB)
2.Supports Ultra DMA/33 IDE protocol

Have you partitioned your drive in FAT and not in FAT32 when using Fdisk and answer N to the question of Support large drive (Yes/No). If in Fat now, you may need to repartition it or convert by converter Fat32.

http://www.abit-usa.com/english/download/index.htm
!!!Attention!!! This BIOS update is for the BX6--Revision 2 ONLY!!!
Filename: BXRNW.EXE
Date: 12/08/1999
ID: NW

Driver
ABIT on-board UDMA/ATA/66 controller
Driver for Windows 95/98 Filename: 1200.exe
Date: 11/09/1999
 1.Driver updated.

pslh
0
dew_associatesCommented:
JS, both Smeebud and Pslh both raise good questions, which cable are you using with this drive and have you updated the bios appropriately?
0
jsextonAuthor Commented:
Now I have a question - can I upgrade the Abit BX-6.2's BIOS to support ATA/66?  The board originally is only supposed to support UDMA/33.  Is this upgradable via BIOS??!  I don't think the file (1200.exe) mentioned in pslh's post is for the BX6 (?).

hmm, I thought I used the cable that came with the ATA66 hard disk, but I'll have to check.  I assumed that it wouldn't matter which cable I used since my motherboard does not support ATA66 (or does it?).

I'll check into the cable issue when I get home - thanks for bearing with me!  We'll figure this out eventually ;-)

Jon
0
Patricia Siu-Lai HoCommented:
Jon, I would like to share with you what I knew.
For a normal UDMA ATA33 or UDMA ATA66 hard disk has been used in a motherboard that only support UDMA ATA33:-
First, you have to upgrade or use the driver to enable the UDMA IDE controller function. Secondly, under such a condition UDMA ATA66 will only run with ATA33 mode automatically by the drive itself. Changes the bios cannot help too much to make the hard disk of ATA66 to run in ATA66 mode.

Unless you added in a card that support UDMA ATA66 in connection with a specific ATA66 cable. In the market, there are some of these cards for this purpose.

pslh
0
dew_associatesCommented:
Jon, a bios change cannot enable ata66, as this is a function of the chipset, not the bios. Let us know about the cable issue.
Dennis
0
Patricia Siu-Lai HoCommented:
Jon, for the cable:- In my opinion, you need to use an ordinary IDE cable which can be used also under ATA33 mode for ATA66 hard disk.

Moreover, please check with the arrangement.

Primary IDE slot <--- cable  long end-----> [slave hard disk] <--- cable --> [primary hard disk]

If slave hard disk is a ATA33 , primary hard disk is a ATA66, in the same chain all drives will be run in ATA33 mode automatically.

ATA66 cable (only used for IDE slot that support ATA66).

pslh
0
jsextonAuthor Commented:
ok, i'm not sure what I did before to fix it, but I checked device manager last night and there are no problems with the disk now!?  I had cold booted a couple times with no luck after disabling ATA66 with WD's tools and removing the hard disk controller driver, but now, several days later, the problem has disappeared.

pslh, you were right about being able to use a standard IDE cable (not the ATA66 cable that came with the new hard disk) since I am only using UDMA33 on the ATA66 drive.  Also, I am still using the same BIOS I have used for about 4 months (gx revision I believe).

I enabled DMA for that hard disk and everything is running much faster (yes the board supports UDMA33 but not 66 - thanks for the info).

Now for the points.  I'm awarding Dennis the 100 points since he was correct with the hardware issues.  pslh, thanks for all your help - I've left another question worth 50 points in this category for you.  

Thanks everybody!

Jon
0
dew_associatesCommented:
Thanks Jon, aside from the points, the most important thing is that the PC is repaired.
0
Patricia Siu-Lai HoCommented:
Thanks Jon!   pslh
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.