• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 164
  • Last Modified:

networking two computers

I have two computers joined with a twisted pair cat-5 cable, each with a network card. Using the "find computer" facility in both machines I can see the other. However I cannot get them to view the respective hard drives etc. I've set up sharing on each but it doesn't work. I suspect that I need to configure the network neighborhood settings but I don't know how. Can someone advise? One machine is running W95 and the other is running W98.
0
netstep
Asked:
netstep
  • 5
  • 5
  • 4
  • +8
1 Solution
 
bchewCommented:
If you go to Control Panel, Networks, is the "File and Printer Sharing" service installed?.  If not, press the button "File and Printer sharing".  It will ask you for a location for files.  It needs the Win95 CD or the location on your hard drive where the CAB files are located.

If it IS already installed, what other protocols and services do you see?  How are they each configured?  Is the "Workgroup" entry under "Identification" the same for both computers?  Are the computer names themselves different?  Can you see each other in Network Neighborhood?  What shares have you created and did you get any errors when you did it?  Do those shares show up in your Windows Explorer with little "hands" beneath the folder or disk drive?

Bert
0
 
compmaniaCommented:
Please list each protocol here from both computers.
0
 
mustang407Commented:
Yes you have to go set up network neighborhood on the two machines.

To do this, Right click on it and select properties.  On this screen you should see your nic (network interface card).  You will need to add a Protcol to the two machines.  ipx/spx is a good one to start with. TCP/IP is good but more complicated. (if you want instructions on this email me at mustang407@hotmail.com)   Once you have added that protocol, make sure you have file sharing on for your MICROSOFT NETWORK.  You might need to add that SERVICE on the same screen.  ANOTHER VERY IMPORTANT THING, on the identification tab, the two machines must have different names, but MUST be in the same workgroup for them to see each other.  Once you have all that done on BOTH machines, you will just need to go to "my computer" right click on the drive, select sharing, and turn sharing for that drive on.  You can share cd roms as well as hard and floppy drives this way.  

Hope that all helps
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
bchewCommented:
Hello Mustang407.  I see you are new to Experts Exchange.  WELCOME!

There are a few protocols usually followed by the experts here.  First, an answer should not be posted until the questioner asked someone to do so.  Posting an answer "Locks" the question, moving it from the "Questions waiting to be answered" area.  This makes it difficult for others to see and offer help for the problem.  Also, the questioner has the option of accepting any comment they choose as the answer so posting one is never actually necessary.

Second, repeating comments made by others, especially in an "answer" is usually not looked on kindly by others in the forum.

Good luck and, again, welcome.

Bert
0
 
mustang407Commented:
mustang407 changed the proposed answer to a comment
0
 
slang9Commented:
The cable between the machine must be a crossover cable, not ordinary cat-5. Just making sure someone covered this.
0
 
zombiwulfCommented:
Once the cabling has been addressed, try running 'net diag' from a dos window.

If this does not pass,don't bother with windows settings.
0
 
cooljudsonCommented:
Is one of your computers' file systems FAT16 (look in fdisk.exe to tell)?  FAT32 and FAT16 systems don't like to read each others hard drives...
0
 
mrorangeCommented:
What kind of nic's are in each machine?
Are they both ethernet or tolken ring?

You havn't stated what protocols you are using.  If you are only using the two machines then net Beui will be the fastest, (not all games will work with this though).

You need to assighn an unique computer name for each machine..

As bchew rightly stated you have to enable file and print sharing, then right click on your hard drive and select sharing.

Once this is done you should be able to see the other computer by double clicking on the network neighbourhood icon.
----------------------------------------

if you are using TCP/IP.  
Once you have assigned your ip addressed EG.
machine 1 = 192.0.0.3
machine 2 = 192.0.0.4
subnet mask for each machine = 255.255.255.0

On each machine start by pinging 127.0.0.1 this pings yourself and shows if TCP/IP is working correctly.  then try pinging the other PC by its IP address...

Fat16, Fat32, NTFS ect ect will have no problem reading each others HD over a properly setup network..

hope this helps....
0
 
rkumar121699Commented:
Right Click on Network Neightbourhood.

I hope you added File and printer sharing.

Add NETBEUI Protocol which comes under Microsoft.

Then goto Identification tab.(second tab)

Give a name for Workgroup (same on both systems).

Click Ok and restart the system.

Thats it.  

Hope this will do .

Kumar





0
 
rkumar121699Commented:
Why I mentioned NETBEUI Protocol instead of TCP/IP is that, you dont have to bother about IP adddress at all while using this.

0
 
netstepAuthor Commented:
hi,

sorry for the delay in getting back.

Cable is a twisted/crossover.
Both file systems are FAT 32.
File and print sharing is on for both machines.
One computer is called "animal"  the other is called "beast". These were set on the ID tab.

I can still see the other machine when using "find compute" but I can't access them.

In network properties there is the following:

FW1 Adaapter
Realtek PnP LAN Adapter
TCP/IP Fw1 adapter
TCP/IP Realtek PnP LAN Adapter
File and Print Sharing for MS Windows.

0
 
zombiwulfCommented:
What I don't see here is the netbeui protocol. Netbeui has gotten a bad rap lately because it isn't routable and is perceived by some as less cool than tcpip, but on a non-routed network netbeui works great. It's small, efficient and fast.

While MS implementation of tcpip does have netbios name support, the updating of the browse list is very slow.

Install netbeui on both pc's - follow the comments from others regarding unique computer names and a common workgroup name, make sure you have shared something on both pc's, and I'll bet you will be able to browse at that point.
0
 
bchewCommented:
Check to be sure that at least one of the computers still has "Browse Master" set to either "Enabled" or "Automatic".  (Control Panel, Network, "File and Printer Sharing", Properties.) Both machines should have been set to "Automatic" when F&PS was installed.

Bert
0
 
mrorangeCommented:
If you dont use TCP/IP in either machine then you should remove it.

Then add netbeui on each machine as zombiwolf stated.

If you do use it then assighn an IP and subnet mask as i previously stated above.

The properties that you stated, is that on one machine or is that the properties of both machines?



0
 
netstepAuthor Commented:
In response  to your question it's for both of them. I would prefer to use TCP/IP if possible as more games etc. can use it.
0
 
mrorangeCommented:
If you dont use TCP/IP in either machine then you should remove it.

Then add netbeui on each machine as zombiwolf stated.

If you do use it then assighn an IP and subnet mask as i previously stated above.

The properties that you stated, is that on one machine or is that the properties of both machines?



0
 
mrorangeCommented:
Have you assigned your IP address yet if so what are they?

can you ping yourself?
Can you ping the second machine?
0
 
bchewCommented:
rkumar,
please see my comment to Mustang above.  It would apply to you as well:o)

netstep,
You should reject an "answer" that does not address your problem so your question will be moved back to the "Questions waiting for answers" area.  That makes it easier for other experts to offer assistance.

Also, please run WINIPCFG /ALL on each computer and post the results here.

Bert
0
 
netstepAuthor Commented:
In response  to your question it's for both of them. I would prefer to use TCP/IP if possible as more games etc. can use it.
0
 
bchewCommented:
Netstep, you repeated your previous comment.  Is that what you meant to do or were you trying to give us more information?

Bert
0
 
rkumar121699Commented:
If you want to use TCP/IP istead of NETBEUI.

see the comment of Mrorange given above.
he gave it right.

* You have to add TCP/IP protocol
and goto the Properties of the same

* Goto IP Address tab
Select the Radio Button "Specify an IP Address"

* Give an Unique IP Address like

 200.1.1.1 , 200.1.1.2

* And Subnet Mask as

  255.255.255.0 (same on both systems).

you just leave other tabs/options as it is.

Click Ok.


*  Also. Have you mentioned Workgroup Name
on Identification Tab of Network Neighbourhood Properties.

If not do mention a common name for both the systems ( i.e  MyNetwork )


Now Restart your system.

Click Start / Run. and give the command.

Ping 127.0.0.1

If your TCP/IP works fine it should display as follows


Pinging 127.0.0.1 with 32 bytes of data:

Reply from 127.0.0.1: bytes=32 time<10ms TTL=128
Reply from 127.0.0.1: bytes=32 time<10ms TTL=128
Reply from 127.0.0.1: bytes=32 time<10ms TTL=128


Then try pinging to the other system
From 200.1.1.1  try the following


Ping 200.1.1.2

If This also gives you similar result as above then your Network is ready to go.

Open Network Neighbourhood and check for the shared drives

Good Luck again

Kumar


































0
 
sash031299Commented:
just checking, when you start windows, do you log in to the network, or do you just press ESC or cancel??
you must login to the network in order to use the resourece on it
0
 
ho_yin_leungCommented:
I know where the problem coming from, indeed, I had same problem before.
Other than correct Network Configuration. If you connect 2 machine Peer-to-Peer with RJ45 10/100BaseT (without hub), you need a special cable type cable call "Crossover RJ45 Cat5", it's specially used on 2 10/100BaseT Network PC without any hub.
0
 
netstepAuthor Commented:
Many thanks to everyone who has offered advice and help.

I have tried rkumar's last comment and it worked. Therefore I would like to accept this as the answer.

How do I award rkumar the points?
0
 
netstepAuthor Commented:
It's OK - thankyou I've managed to accept the answer and award the points.

Thanks again to everyone.
0
 
rkumar121699Commented:
Netstep,

You did it. !!!!

you can get me at rkumaraswamy@india.com

for further queries if any.


Thanx for your marks :)

- Kumar
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 5
  • 5
  • 4
  • +8
Tackle projects and never again get stuck behind a technical roadblock.
Join Now