PROBLEM WITH SUBMIT

I HAVE A DILLEMA WITH SUBMIT BUTTON. NOW THAT I INSTALLED PWS ON MY PC I TRIED CREATING A LOGIN.HTML AND VALIDATE.ASP SCRIPT WHICH VALIDATES THE USER. MY QUESTION IS HOW COME WHEN I PRESS SUBMIT IT ASKS ME IF I WANT TO DOWNLOAD THE VALIDATE.ASP SCRIPT? WHAT NEEDS TO BE DONE IN PWS TO EXECUTE ASP SCRIPTS?
THANKS FOR YOUR COMMENTS.
VirtualRealityAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

NickRackhamCommented:
You need to make sure that the folder in which the validate.asp pages is in has had the properties changed to "allow scripts to be run" In FP right click the folder that the .asp page is in and this should give you the option to check the "allow...." box. Check it, click OK and you should be away.

Regards

Nick
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
VirtualRealityAuthor Commented:
I SHARED THE DIRECTORY AND ASSIGNED WEB RIGHTS TO EXECUTE THE SCRIPTS IN THIS DIRECTORY.
WHEN I CLICK SUBMIT IT STIL OPENS DOWNLOAD DIALOG BOX AND OPENS VALIDATE.ASP IN THE VISUAL INTERDEV INSTEAD OF EXECUTING ASP SCRIPT.
0
NickRackhamCommented:
OK, So you're using Interdev. You will need to ensure that the VID server extensions are installed on the Web Server in order for the .asp files to run. The server extensions add the asp.dll (going from memory here) files. Without this the web server still thinks that you're trying to run a program in an unauthorised folder.

The Visual Interdev Extensions are part of the Install routine, If I remember correctly on the second CD.

Regards

Nick
0
C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

VirtualRealityAuthor Commented:
No No Nick I am writing my asp pages in another tool called  UltraEit32 and html files in front page98 and when looking at login.html from front page I click submit and interdev shows up for no apperant reason. Should I try to add/remove it or it wont help? I dont have CDs right this moment to check ext.
Is there a way to set these ext. from pws?
0
VirtualRealityAuthor Commented:
Nick, are you saying that the option of pws to execute asp scripts is on the setup cd of a web server or on the cd of interdev?
0
NickRackhamCommented:
OK, If Interdev pops up then that is the program set within Explorer, View | Options | File Types. Locate the asp extensions in this list and using Edit, choose which program you wish to use to open and edit .asp files.

As you've got Interdev installed the install routine may have buggered up the FrontPage extensions in PWS. (Don't you just love this Micro$oft stuff) If you are using PWS V4, locate the FP98swin.exe or the FPsrvwin.exe in the C:\Program Files\FrontPage\Version 3.0\ directory. Run this program and choose the Check and Fix then Upgrade buttons. Once you've done close this down and it's probably best to reboot (Just for the sheer hell of it, and to get the chance to grab a coffee!!) Once it's back up and running double check that the folders your .asp files are in has the option set to run scripts, as detailed previously, and you should be in business.

HTH

Nick
0
SiteSeeCommented:
If you are unable to check off in FrontPage whether you want Scipt or Execute, or Browse rights on folders/files, then you are dealing with a Disk-Based Website...
In order to specify unique permissions on a file or folder in a  website, as in your case, you must have a SERVER-based web....
What Webserver are you using..?
IIS or PWS??Do this:
if IIS....do this:

....in NT explorer, create a folder..in InetPub or wherever...name it whatever you will remember it will be your new SERVER-based web...
In MMC...right-click select your Default Web..NEW....WEB...Go through this wizard, type in an IP address like 127.1.1.100 ..or similar that you will remember...select the folder you just created, and selecting Allow Scripts to be run(not executables)...Allow Anonymous access...
done...
NOW...right-click that new website in MMC and select TASKS...Configure server extensions...proceed through this wizard...you can do mail later...
done...
Now, in MMC...right-click that new web, and START...
now open FP2000...select Open Web..open the web you have been working with...PUBLISH it to the new IP...Close this web...Open Web....in the bottom field...type in that new IP you set-up like:
http:127.1.1.100 
THIS is a server-based web...
henceforth, you should open your website like this if you want to be able to work with your db...and other extension utilizing features...

Steve


0
NickRackhamCommented:
Steve, are you following me? or am I just being paranoid!! <g>
0
labambinaCommented:
I did not read all the above comments so appologies to anyone with an already posted a similar answer.

with pws anf fpage 98 you must install asp service. You have it on the fp98 CD. just install it
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Development Software

From novice to tech pro — start learning today.