Won't detect modem.

I have Red Hat Linux 5.2 on my system, sharing with Windows 98.  I am using the X Window System.  I have tried several different fixes, including some on the Red Hat webpage.  I do not have a winmodem (even says that it is compatable with Linux on the box).  I have tried everything I can think of.  I have done several tests on the modem (It works with Windows), including checking for a Windows/Linux switch on the modem (there isn't one).  I am not going to go through everything that I have tried, but I will welcome any suggestions.  It has been a little while since I have worked with Linux (a couple of months), and I am not too keen on several different aspects of it.  So, bear with me.
FredcanflyAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

j2Commented:
without telling us exactly what you HAVE tried, and exactly what modem it is, i do no tsee the point in just "throwing suggestions at you". And if the modem says "Linux compatible" i woudl imagine that the install guide covers how to install it?
j2Commented:
Here is another thought.. are you sure the modem is supported with the 2.0.x kernels that RH 5.2 used?
FredcanflyAuthor Commented:
Well, I have done everything in the Red Hat FAQ's.  My modem is a off-brand modem.  I am at work right now, but I do know that it is a v.90 Fax/Voice modem.  I have gone through setting up modem, using the Dummies Guide (no good for troubleshooting).  I am sure that the modem would respond if my settings were correct.  I also tried changing the initialization string, and it found the modem 1 time, but then would not connect with the error of no modem detected.  I will try to get back to you with more info later tonight.  Thank you.

Trevis
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

j2Commented:
isa? pci? chipset? internal/external?
biard1Commented:
Check the modem for jumpers.  If it has some, make sure it is not set to plug and play.  Set it to a hard address and irq.  It needs to be one not in use on system already.  If you have 2 serial ports, disable the second one in BIOS.  Then set the jumpers to com2, irq3.  Then run the command modemtool from a shell prompt.  Set the /dev/modem link to ttyS1 which is com 2.  Then save changes and start your ppp connection.
FredcanflyAuthor Commented:
j2 - I will get back to you tommorrow (I hope?).

biard1 - thank you for the suggestion, but I have tried that.  I also used a program to find the modem.  I don't remember which program.  I will find that.  It is at my home computer.  I am at work.  I don't remember if I put it on com2 and irq 3, but I will see.

Thank you for your help.

Trevis
FredcanflyAuthor Commented:
It is an internal pci voice fax/data modem.  It is also Hayes compatable (I don't know if that matters?).  My modem manual isn't giving me the chipset, though.  Could it be called something else?

biard1 - I wasn't able to find what program I used, but I also used the modemtool command.  I tried it again, and it didn't pull up with my modem.  It just said that it couldn't find any devices attached.

Any ideas?
j2Commented:
PCI modems are not supported at all. Unless it is based on the Lucent Venus chipset. (Which is only sold under the "Lucent" trademark)

See http://www.redhat.com/support/hardware/intel/61/rh6.1-hcl-i.ld-14.html for details.

If it says "Linux" on the box, there has got to be instructions enclosed as how to install it.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
FredcanflyAuthor Commented:
Can I ask a question?  I mean I hate to think that it just won't work, but I have been searching now for a good 4 hours.  I know that I don't have a brand name Lucent chipset.  I was just wondering if the fix might just downloading a Lucent driver (don't know if that is possible?).  I have found that the modem in Windows runs just fine on Lucent drivers (was trying that for a while today).  How would I download such a driver for Linux in Windows?  Would this even be able to work?
j2Commented:
http://www.linuxvoodoo.com/drivers/cards/modems/beta/lintest.html

But it only works on a single very spcific chipset.
j2Commented:
and also, it ONLY works with the  _RedHhat_ distribution, version _6.1_ or later. (requires glibc and kernel 2.2.x)
j2Commented:
I still think the drivers enclosed with the modem will work, but i am also quite sure that it requires a 2.2.x kernel or later. (with all the bells and whistles that comes with a 2.2.x)
FredcanflyAuthor Commented:
Thank you very much for the help.  I actually think that is the answer.  I think that I will now just download 6.1.  Thanks again.

Trevis
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.