IIS 2.0 Error 10038

I have IIS 2.0 installed on a windows NT 4 workstation SP3....every time I try to start the www web service it gives an error message "Socket Operation on nonsocket" error number 10038.....

Any ideas on how to solve this...
thanks
maboAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
Steve RoseConnect With a Mentor Commented:
TechNet lists this as a bug fix included in pack 4.

I would Install IIS 4.0.It is a free product, which can be downloaded and installed from Microsoft’s web site, or if you have TechNet they should have sent it to you on CD. With all the advances in web publishing IIS 2.0 is going to be prone to problems. I would install SP5 for NT when you are done. There are Win2k issues with any service pack under 4. I would not install 4 though because there have been many issues with it. 5 runs stable.
0
 
maboAuthor Commented:
Thanks for your response......but can I install IIS 4.0 on a Windows workstation machine.....I think it needs NT server.....for workstation MS have a cheap version called Microsoft® Peer Web Services version 2.0 ....

To correct my original question...I am actually running  Microsoft® Peer Web Services version 2.0 ...and NOT IIS 2.0......which means I get the error message "Socket Operation on nonsocket" error number 10038..... in Microsoft® Peer Web Services version 2.0 ....every time I try to start a www service.....

Any suggestions on how to fix this....
0
 
Steve RoseCommented:
Install the Windows NT 4.0 Option pack. It will know you have NT wrk installed and install the current version of the peer web server. There are some older web based applications that can cause this if you are running them via the web server. This evolves the Win32 API and the C runtime code. This typically happens on Windows NT 3.51 and back. It can also be caused by SP3 as stated in the TechNet article I have cut and pasted below.

PSS ID Number: Q185727
Article last modified on 10-15-1999
 
winnt:4.0,4.0 SP3
 
winnt
 

======================================================================
-------------------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Windows NT Server versions 4.0, 4.0 SP3
 - Microsoft Windows NT Workstation versions 4.0, 4.0 SP3
 - Microsoft Windows NT Server version 4.0, Terminal Server Edition
-------------------------------------------------------------------------------
 
SYMPTOMS
========
 
The _open_osfhandle() function allocates a C run-time file handle and sets it to
point to the operating-system file handle. When _open_osfhandle() function is
used on a socket descriptor, both _close() and closesocket() should be called
before exiting. However, on Windows NT 4.0 Service Pack 3, closesocket() after
_close() returns 10038.
 
RESOLUTION
==========
 
To resolve this problem, obtain the latest service pack for Windows NT 4.0 or
Windows NT Server 4.0, Terminal Server Edition. For additional information,
please see the following article in the Microsoft Knowledge Base:
 
   Q152734 How to Obtain the Latest Windows NT 4.0 Service Pack
 
STATUS
======
 
Microsoft has confirmed this to be a problem in Windows NT 4.0 and Windows NT
Server 4.0, Terminal Server Edition. This problem was first corrected in Windows
NT 4.0 Service Pack 4.0 and Windows NT Server 4.0, Terminal Server Edition
Service Pack 4.
 
This bug is not present in Windows NT 4.0 Service Pack 1, Service Pack 2, or the
original build of Windows NT 4.0.
 
MORE INFORMATION
================
 
When _open_osfhandle is used on a socket descriptor, both _close() and
closesocket() should be called before exiting. _close() only closes the file
handle. closesocket() has to be called as well to close the socket descriptor
and clean up the underlying socket object.
 
Additional query words:
 
======================================================================
Keywords          : kbnetwork NT4SP4Fix kbbug4.00 kbAPI kbSDKPlatform kbWinsock kbfix4.00.sp4 kbGrpNet
Version           : winnt:4.0,4.0 SP3
Platform          : winnt
Issue type        : kbbug
Solution Type     : kbfix
=============================================================================
Copyright Microsoft Corporation 1999.

0
Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

 
Steve RoseCommented:
Hope this helps. The first thing I would do is install a higher service pack. SP3 has y2k issues and needs to be upgraded even if you are not getting any errors. SP4 has its own problems but SP5 has ran stable. The last IS department I worked in had 10,000 plus users to confirm this. :')
0
 
maboAuthor Commented:
Thanks again for your response....I installed SP5 then windows NT4 Option pack....then installed SP5 again....however www services did not start...this time it gave a different error message..."Can not start service, not enough storage space"...which is strange....because I have more than 1GB of free HD..and 96MB RAM....

Any ideas or suggestions.......
0
 
Steve RoseCommented:
Increase the size of your page file,  spread it out between more than one drive, and get it off of your boot drive. Run disk keeper light to defrag the hard drive. NT NTFS partitions will become fragmented and create this error. Microsoft states that fragmentation is not something you need to worry about on NTFS partitions but that is a bold face lie. If you install NT server on a P200 and install all your applications it will take it 1 to 3minutes to boot and settle down after it hits the desktop. After defrag it only takes about 30 seconds. Then install the NT 4.0 option pack to re-install the latest version of the peer web server.

If there is not plenty of free space on the drive defrag will not run correctly and you have to move files around which can become a real pain but it needs to be done. 1 gig may not be seen as plenty of hard drive space because it looks at the % free on the partition and will not look at total free on the system. 96 meg of ram is still not much when running server or workstation. I run 128 and have had this error with an empty 13 gig drive in the system.
0
 
maboAuthor Commented:
Yeap..it worked..thanks...
0
All Courses

From novice to tech pro — start learning today.