Reservation database - Error while creating reservation

Hi,

We have an Reservation database (Reservation.nsf) created from the Std45ResourceReservation Template.
The server and the client versions are 4.6.4

Problem:
Few users (among the the 100 and more users) are getting the error message given below while creating a Reservation.
The system accepts the user's data and gives the error while pressing the "save" button.

Error:
"The time you have scheduled for this resource is not available."

P.S: All the systems has Windows NT workstations and there is nothing wrong with the System time settings of those computers and we have tried to reinstall Lotus Notes client on those machines... but still the problem exists.

Please help us to sort out this problem..

Regards,
Kumaran

Comment:
We've recreated busytime.nsf also.. but still the error exists..!
mkumaranAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

pentapodCommented:
Have you checked the Notes time settings?  Open the user's personal address book and go to the Locations view, and open the location they are using (probably Office).  Under "Advanced" check they're in the correct time zone, and whether daylight savings time is enabled.  
Also you can double-check the problem by having these users create a reservation during a week when you know there is absolutely nothing scheduled.  See what time they see the meeting, then open the database on your machine and see if the time has changed.  If it looks like a different time on your machine, it's definitely a Notes Time Zone problem.

....Pentapod
0
anuuCommented:
hi,

Users get this error when the reservation time specified by the user is already used/reserved by another user.

If db is setup properly, when the user tries to enter the reservation time, a whole set of free slots for the resource must be displayed. You can ensure that the right free-slots appear by verifying the resource details in the address book.

If you need further details let me know.
0
anuuCommented:
Perhaps you would like to check a few other things:

1. User ACL (A mim of Author Access)
2. Users accessing the reservation db have access to the server on which the resources and the site profiles are stored.

0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

LotusDaveCommented:
sometimes deleting the busytime database helps.

at the console enter the following commands

tell sched quit
dbcache flush

then delete busytime.nsf using the o/s.

at the notes console enter

load sched

this will create a new busytime.nsf
0
mkumaranAuthor Commented:
Edited text of question.
0
stharrisCommented:
Solution:
Changing the Short Date Style format at the operating system level (under Start, Settings, Control Panel, Regional Settings, Date) from "dd-MMM-yy" to "M/d/yy" (or another format with two character month) fixes the problem.

This has been reported to Lotus Engineering and SPR'd

Steps To Reproduce Problem:

1.      At the operating system (OS) level change the Short Date Style under Start, Settings, Control Panel, Regional Settings, Date to 'dd-MMM-yy'.
2.      In the Resource Reservation database, select Create, Reservation.
3.      Reserve a Room.
4.      Find an available time for a specific room.
5.      Choose Specific Room.
6.      Fill in the Duration date.
7.      Select 'Find an available time'.
8.      Select one of the recommended meeting times free time reports and select OK.
9.      Select the Save action button.  The error message occurs.

Technote: 172645
http://support.lotus.com/sims2.nsf/802ee480bdd32d0b852566fa005acf8d/ae942292fdc0603a86256799005716aa?OpenDocument
0
mkumaranAuthor Commented:
I've found the solution last week itself...

thanks,
kumaran
0
mkumaranAuthor Commented:
This question has a deletion request Pending
0
stharrisCommented:
This question no longer is pending deletion
0
stharrisCommented:
Did this fix the problem?
0
stharrisCommented:
mkumaran,

Was the solution the answer I gave?  If not what was the solution you found last week?  

St. Harris
0
stharrisCommented:
Solution:
Changing the Short Date Style format at the operating system level (under Start, Settings, Control Panel, Regional Settings, Date) from "dd-MMM-yy" to "M/d/yy" (or another format with two character month) fixes the problem.

This has been reported to Lotus Engineering and SPR'd

Steps To Reproduce Problem:

1. At the operating system (OS) level change the Short Date Style under Start, Settings, Control Panel, Regional Settings, Date to 'dd-MMM-yy'.
2. In the Resource Reservation database, select Create, Reservation.
3. Reserve a Room.
4. Find an available time for a specific room.
5. Choose Specific Room.
6. Fill in the Duration date.
7. Select 'Find an available time'.
8. Select one of the recommended meeting times free time reports and select OK.
9. Select the Save action button.  The error message occurs.

Technote: 172645
http://support.lotus.com/sims2.nsf/802ee480bdd32d0b852566fa005acf8d/ae942292fdc0603a86256799005716aa?OpenDocument 


0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Lotus IBM

From novice to tech pro — start learning today.