SoundBlaster Live! installation

Could someone please tell me how to install a SoundBlaster Live! and most importantly getting it to work in KDE.

I have the correct driver and a little utility that automates installation. It doesn't work (surprise, surprise), so I moved on to manual installation. It doesn't work either (surprise, surprise).

I 've searched the web, but I can't find the answer.

I'm using the SuSE Linux 6.3 with 2.2.13 Kernel.

All help will be usefull and appreciated. Thanks.
LVL 1
TattooAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

didierCommented:
Please describe what you mean by 'doesn't work'.

What does it do (or doesn't) ?

What errors do you get?

-D
0
NikmisCommented:
I think SB Live is supported with Mandrake Linux V7(AIR)

Check out   www.linux-mandrake.com
0
psimationCommented:
I don't know if SBLIVE is supported under SUSE, but anyway, this is how I got mine to work under RedHat 6.1.
Go to opensource.creative.com.
You will find a link to the anonymous ftp site.Go to the snapshots dir, then download the latest emu10k1-xxx.tar.gz, when I just checked now, it was emu10k1-20000201.tar.gz.
Untar this file (tar -xvzf emu10k1....). You will then have a emu10k1 dir. Got to that directory in a terminal window and type "make".
When finished, you will have a emu10k1.o module (amongst others) in that dir. You now need to copy it to your /lib/modules/2.2.xx-xx/misc dir, where the xx are your kernel...
Now you need to edit your conf.modules file (/etc/conf.modules)
add the following line to it:
alias sound emu10k1
save it and reboot. That's it. Now just make sure you have the speakers plugged into the right socket and that your mixer volume isn't turned down, and you should have sound.
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

TattooAuthor Commented:
thanks...

I'll try previous comment and keep you informed

Kindest regards
0
boeckjCommented:
Tattoo,
I am also using SuSE.  The problem you are having is identical to the one i just had.  The way you fix it is To goto SuSE.com and download the patch.  It is in the Snd section of the bugs and fixes section.  Then you delete the Directory for the Drivers for your sound card in the /usr/lib/ directory should be emu10k1_0.4.SuSE directory.  Then run the rpm with the command rpm -i emu10k1.rpm and then run the archive with the ./install_emu10k1 in the shell in the directory you installed it into the save directory when you deleted before and you should be setup.
0
boeckjCommented:
I have my SB Live working myself, now I am trying to get Quake 2 to work with my voodoo 2 and mouse at the same time
0
TattooAuthor Commented:
Dear boekj,

I've done what you said:

Downloaded the file
removed dir emu10k1-0.4.SuSE
rpm -i emu10k1.rpm
runned ./install_emu10k1

I've received message that the emu10k1-driver was installed succesfully.

But ...
No sound !!

I get the following errors in the KDE errorlog:
- modprobe: Can't locate module sound-slot-0
- modprobe: Can't locate module service-0-3

Any solutions ?
Thanks
0
TattooAuthor Commented:
Dear boekj,

I've done what you said:

Downloaded the file
removed dir emu10k1-0.4.SuSE
rpm -i emu10k1.rpm
runned ./install_emu10k1

I've received message that the emu10k1-driver was installed succesfully.

But ...
No sound !!

I get the following errors in the KDE errorlog:
- modprobe: Can't locate module sound-slot-0
- modprobe: Can't locate module service-0-3

Any solutions ?
Thanks
0
boeckjCommented:
Don't know, might be that your kernel is not compiled with the correct options.  When I did it, it worked the first time and after rebooting it stopped working.  I downloaded the latest driver from opensource.creative.com and it did not work i kept messing with it back and forth until for whatever reason now I have full sound.  Go figure?  If you have SuSE you might try there tech support.  It comes with 60 days of tech support
0
boeckjCommented:
Here is SuSE's support page for that.

http://sdb.suse.de/sdb/en/html/swgkern_soundlive.html
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
boeckjCommented:
http://lc.experts-exchange.com/Computers/Operating_Systems/Linux/Q_10258016.html

Try that link... and try the command depmod -a under root after installing the update and then try modprobe emu10k1
0
TattooAuthor Commented:
Awaiting more comments
0
TattooAuthor Commented:
I still get the errormessages in my xconsole:

modprobe: can't locate modules sound-slot-o
modprobe: can't locate modules sound-service-0-3

when I execute 'modprobe emu10k1' to load the driver, I get a click, so that's something allready.

when i 'cat /dev/sndstat' I can see that devices are set up properly.

I also modified the '/opt/kde/bin/startkde'-file in the following way:
startifaudio kaudioserver
startifaudio kwmsound
became
kaudioserver &
kwmsound &

I checked the 'modules.conf'-file and the correct lines were added.

In my kerneldirectory the compiled module 'emu10k1.o' is present.

I really don't know what else to do.
Maybe I need to recompile my entire kernel.
How is this done?
Do I need to add settings in the kernel-configuration before compiling?
Which file is this?

Thanks for all help.
0
TattooAuthor Commented:
Got it.

Thanks all.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.