HP Printer steals IP address

I stumped HP and QMS with this, so I'll ask real experts . . .

We have network with the following configuration:  PII-233, file-and-print server with NT 4.0/SP4, 10/100 hub, DHCP, WINS, and mainly Windows 98 clients.  In December of last year, we installed a QMS Magicolor2 color laser, to go along with our (monochrome) HP 4000N.  Both are networked and attached to the server, each with its own port.  

About two weeks into January, the QMS decides to stop working.  Can't for the life of me figure out why -- with troubleshooting help from QMS, I determined that the problem is that the HP is stealing the QMS's IP address!  The HP is at 192.168.0.8, while the QMS was at 192.168.0.15.  (I've since uninstalled it.) But when I unplug the QMS from the network and ping 192.168.0.15, I still get a response.  I print out the HP's configuration, and it tells me it's at 192.168.0.8.  Better yet, run Network Monitor while pinging, and you can see the 192.168.0.8 replies for 192.168.0.15 in the Echo/Echo Reply. Very weird.  

So, we're stuck with a printer that can't get connected.  Any ideas?  I've put a bunch of points here, so start those cards and letters coming.  Thanks in advance.
jonathanv_00Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

zombiwulfCommented:
Sounds to me like either the wins database is toasty or something is incorrectly caching arp entries.

Are you handing out ip's via dhcp or are they configured static?

Have they ever been handed out via dhcp?

The Jetdirect CANNOT 'steal' an ip address. If it isn't set static, itwill attempt to contact the dhcp server on powerup to renew it's lease and will take the ip handed to it.

It is possible for the dhcp reservation to be wrong because of either a corrupt database or because a switch has cached the wrong mac address.

What I would do is ping the ip of each device and then type 'arp -a' and see if the hardware address for each ip matches the hardware address of each network interface.

Which way to go from here depends on whether or not you have a switch/router on the network or a dhcp server.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
BigMarkCommented:
I would suggest manually assigning IP addresses to both printers (outside of the DHCP scope of course!).

Try setting them to the last couple of addresses in the subnet and see what happens....




BigMark
0
jonathanv_00Author Commented:
Hey, folks, thanks for the comments.  We use a hub, not a switch, so that's not it.  I was handing them out via DHCP, but then switched them to static in an attempt to solve the problem.  It didn't.

I did try arp -a after pinging both addresses, and the funny thing is that the 192.168.0.15 address _doesn't_ show up in the table.  192.168.0.8 does, however, show the correct MAC address.  I'm beginning to think that a corrupt database is the problem.  

Also, I apparently have my subnet all messed up.  Because the router I use (Netopia) is a 12-user model, their tech support had me enter a subnet mask of 255.255.255.240.  In my TCP/IP class this week, I now discover that my addressing scheme is completely incorrect for that subnet mask.  I've tried assigning the QMS, at least, a number outside of the scope, and it doesn't seem to help.  Can't spend much more time on this, so I'll leave you all with that.  Thanks again.



0
Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

jonathanv_00Author Commented:
Oh, and I forgot to mention that the QMS _can't_ be configured to use DHCP. I didn't realize that the first time I set it up.  Ya gets what ya pays for, I guess.
0
zombiwulfCommented:
Curious....

So what should be happening when you ping the QMS is a timeout.

x.x.x.240 gives you ip's of 1-14.
x.x.x.15 is the broadcast address, and x.x.x.16 is the network address of the next subnet.

When you pinged the broadcast address for the subnet, the Jetdirect responded.

If you are using 255.255.255.240, do not use x.x.x.15 or 16.

What I would probably do is change the subnet for the pc's and Jetdirect to 255.255.255.224. This will give you 30 ip's instead of 14. Just make sure that the pc's are using the first 12 ip's so that the Netopia can still route to them properly.
0
jonathanv_00Author Commented:
Wow, thanks. I'm just finishing my second time through a TCP/IP class, and all of a sudden that makes sense to me.  I'm not at work right now, but I can see why it should work.  I'll give it a try and get back to you.  

But here's a question -- do I also change the third octet of the IP address, since I'm subnetting?  Can I leave it at 192.168.0.2, or should the zero be something like 32?  Or do I have to subnet at all?  Thanks again.
0
zombiwulfCommented:
With private ip addresses and a flat network there usually isn't any point to subnetting it any further, since all the packets are travelling on the same wire it doesn't affect the network traffic. If you were routing between subnets with a hardware-based router (either a standalone router or a pc with multiple nics - not a single nic with two ip's assigned to it) then subnetting will allow you to minimize traffic on a particular segment.

I've done support for a router similar to the Netopia and while our 'out of the box' configuration specified a .240 subnet, many people used 255.255.255.0.

The router would not assign anything above .14 via dhcp, but for static configurations you could assign any ip from 2-254 - up to the maximum number of supported nodes. I assume the Netopia will do the same.

0
jonathanv_00Author Commented:
Hm.  Another busy day in paradise, so I may not get a chance to take the server offline for reboots until Friday evening.  But I tried changing the subnet mask in DHCP manager, and it won't let me -- ?  I tried stopping the service, deactivating the lease.  Nada.  I'm thinking it's time to re-install a service pack.  

Reading your note, I think I do actually need to subnet, since I do have this router and network connected to another router by ATMP, and will connect a third network when they get their DSL line in a couple of weeks. So, with a subnet mask of 255.255.255.224, would 192.68.32.x be the correct subnet?  

Gotta go study some more. Thanks.
0
zombiwulfCommented:
All the subnet mask does is determine what other nodes are logically local.

If you are going to be routing between the different subnets it doesn't much matter what network addresses you use, as long as the pc's that are supposed to be local to each other are in the same subnet as defined by the subnet mask.
0
jonathanv_00Author Commented:
I'm not entirely certain what I did, but I got the QMS to work.  Let's see if I can re-create the steps.  I re-assigned IP addresses to the two printers, using the next two addresses after the router and server.  Still didn't work, so I uninstalled the HP on all clients, then deleted my current DHCP scope and created a new one with the default subnet for class C, 255.255.255.0.  Then I re-installed the printers on the server. This seemed to do the trick, so I put all my clients back on the default subnet and reinstalled the printer on them.   Seems like a lot of effort for a printer I'm probably going to get rid of.

Anyway, thanks again for your comments.  I'll accept your comments as an answer, zombiwulf, because I think you were right -- DHCP or ARP cache was somehow messed up.  
0
jonathanv_00Author Commented:
Thanks, and take care!
0
goldrnrCommented:
Hi there,
I was just browsing for QMS and DHCP problems (thanx G**gl3)... And I stumbled over this thread...

We have the same sort of issues with QMS laserprinters and DHCP.
We run DCS by Nominum which gives good logging on what happens in our DHCP-environment...
What actually seems to happen is that the QMS-printers (type 2060 and 9100 at least) repeatedly drop in powersafemode,
come out of it (by a printer-request), and go into DISCOVER-mode...

In some occasions the Printer then rejects it's given address (as it finds it to be allready in use (by itself)) and sends a DHCP-DECLINE.
The DHCP-server then correctly abandons this lease and hands out a different one (if available (from a dynamic pool in the same network)).
Nominum DCS (perhaps other DHCP-services) has the feature to reset the lease, so the printer can reclaim it's original ip-address after a
reboot, also there's a server-parameter that regulates the interval for checking the abandoned leases so they will be reset automagically.

Allthough this might seem a bit as a commercial for DCS, I just wanted to shed some light on this matter from the perspective of a DHCP-server.

Regards,
Leon
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Printers and Scanners

From novice to tech pro — start learning today.