Win98 Client with a SAMBA Server - case problems

everytime i make a new directory with the win98 client on the server partition, and type in a name like this: "New directory", than later i can´t rename it to "New Directory. How can i change this ?
Please help

thanx
shadowmanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

hoaxCommented:
Try posting some more details. Relevant information would be:
a. your smb.conf file
b. On which share you're trying to create the directory (does this happen on all shares?)
c. Are you trying to rename using Win98 or using the linux server?

One suggestion that comes to mind immediately is checking the default file creation permissions (as defined in smb.conf). If  files are created read-only by default, you won't be able to rename them after creation.
0
TigreCommented:
In "New directory" name the very first charecter is capital bydefault. In betwwen New & directory, there is a space. For space ASCII is 32, and HEX value is 20. So in file naming convention the "New directory" in changed to "New%20%directory". We cant interact directly to the naming convention of system. "Name%20%directory " is a whole continuous string itself, where the first charecter should be in CAPs, and other should be in lower case. Sorry, shadowman , we cant do anything (unless we dive into SMB design internals) at this point of time.
Again, I like to tell you another thing, please go through your WIN32 env settings, and also smb.conf. You might hve made some unnecessary changes to it.
In time of binnary porting of file(s) info across the OS, there might be some proto which is controling that. Set all permissions ON for file/folder access, and try it again.
0
biard1Commented:
In the section for the relevant shares in the /etc/smb.conf file, set an option for create mode and one for directory mode.  If is to be publicly available, for example, do the following assuming the share root is "Shared Files":

[Shared Files]
create mode = 777
directory mode = 777

Add these two line, or modify them as necessary if the already exist.  If you only want the owner of the share to access, set them to 700 instead of 777.
0
mixerfix122699Commented:
I _could_ be file name mangling.

Mine works with Win98 game machine and the mangling is set with the samba default values.

Please check that your mangling is set as default or, alternatively, post your mangling values.
0
ashurbanipalCommented:
shadowman, you failed to mention what version of Samba you are running, but from the look of the problem, I'd wager it's probably something like 1.19.17, which, and it's having problems with the inconsistent way in which Win95 and Win98 handle long filenames.

There are two solutions which I know to work.  One, of course, is that you upgrade to NT, which does not have the long filename problem, but more helpful is to upgrade to the latest distribution of Samba, which is 2.0.6 presently.  If you're running Red Hat or SuSE, you can

rpm -U ftp://ftp.suse.com/pub/suse/i386/6.1/suse/n1/samba.rpm

to update your distribution; if you're running Slackware or some older version, look it up.

Anyway, by way of explanation, what's happening here is just name-mangling, nothing more, and the same case problems arises in passwords as in filenames.  These are the values, which you can set in smb.conf, that will do what you want:

[global]
mangle case = no
case sensitive = no
preserve case = yes
short preserve case = yes

They're also the default values in Samba 2.0 and above, so upgrading will fix your problem.  Don't worry about the Samba directives for any specific shares, file creation modes, and don't tweak anything on your Windows box.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.