Remote login linux by using reflectionX

I have some win32 remote login apps
support XWindow such as reflectionX and extra. I tried to use them to logon to a linux computer, but faild.
I can use them logon to a solaris
computer.
Why?
How to resolve it?
Thanks in advance
w3guyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

bernardhCommented:
  run xserver
   telnet remote-host

   # DISPLAY='10.10.10.200:0';export DISPLAY
   # xterm -display 10.10.10.200:0 &

replace remote-host with your remote host name and the ip address with the ip assigned to your pc.

this procedure assumes that you are using a local network connection; not dial-in.
0
rolhCommented:
Well... these are the settings I use with Reflection X connecting to a Linux server (as in your case):

Description: Whatever
Method: TELNET
Host Name: <your ip>
User Name: <your login>
Password: <your password>
Command: (/usr/bin/X11/xterm -fn 6x13 -sb -ls -display %IP#% &)

----------------

To check if there is some kind of connectivity, try changing the Command section to: xeyes, linuxconf, or any other visual application. And/or with the simple "telnet" app.

Another problem could be in the part of "Advanced...". Check that the words "login" and "password" appear exactly the way they are when you connect in a simple way (another terminal).

If I am right, just tell me for grading.

G'luck!
0
DineshNeheteCommented:


There might be number of reasons for this.

1. Display may not be set correctly
    ->   set environment variable DISPLAY correctly
2. xserver on linux machine does not allow any xsession
    from remote machine
    ->   login to linux machine by some other method and activate this
          the command for this is xhost
 3. the command xterm may not be available directly in the path and needs
    absolute path.


0
maxchowCommented:
Please try to do the following command on the unix console after you have started the reflectionX:

xterm -display <ipaddress of your PC>:0 to see whether you see any window pop up on your PC.

If you see the xterm poped to your screen, this is the matter of rexec or rsh, then you should setup in the inetd.conf.

If you cannot see the xterm, it may the problem of the security setting under the reflection which does not allow other station to send a Xapps to your server.

Regards

Max
0
ohad23Commented:
Hi,
have a look at /etc/hosts.[allow|deny] and see if you allow telnet connections from the win machine.
if you want to give access to your server from everymachine in the lan enter:
ALL : LOCAL
in /etc/hosts.allow
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.