Linux won't boot, missing fstab

Following a crash and lots of disc corruption, my machine will no longer boot.
fsck complains about a missing /etc/fstab.  I eventually get into the maintenance mode, and I can see a file called /etc/fstab~, but no fstab.  I can't rename it either because the file system is read-only.

How can I bring back this file ? I have no boot or rescue disk of course...
mprovencAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

bernardhCommented:
you can still rename it even if its read-only. do:

   # mv /etc/fstab~ /etc/fstab
0
TigreCommented:
If your file system have already locked and only mountable as Readonly then "You have nothing to loos any more". Try with 'bernardh's suggestion, if your luck fever!!! If not Try the followings:
1) Try to collect a rescue Disk of Linux; from your nearest friends and Boot your system, mount with specifying the file system ext and ext2 both. If not then..
2) Try to arrenge another Hard Disk, put it on your system, load Windows'98 on the foreign HD, keep your Linux Disk 'ON ' within the system, Now: A Free software available (www.linuxapps.com) in Win32 plateform which can mount ext2fs from Win32, there is an option to enable  Read+write both. Write option is not anough mature, but still you can access your LnxHD, reName the required file and try Linux.
3) or Simply try to upgrade your system with Installetion bootDisk (CD), it can help you..
Best of luck...
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
bernardhCommented:
oh boy, you're making it hard for her. all you need to do is boot to single-user mode and remount the file system using:

   mount -n -o remount,rw /

or replace / with other partition like /etc, /usr.

tsk...tsk
0
mprovencAuthor Commented:
Thanks to everyone !!

I think that last one with the remount option might have done it, however
because we've had so many problems with the hard disk and the network
card (it kept crashing under heavy traffic), the powers that be have told
me to intall NT on this machine and see if it would work better.

I know, that sucks.

Thanks again to everyone !!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.