Explorer has performed an illegal operation

I'm running 98 se and have not been able to fix this problem. When I click on control panel, The "explorer" box pops up and says Explorer has performed an illegal operation, contact your software vendor. If I hit "close"
the box closes and then opens the control panel and everything works as it should. Reloading 98se did not fix the problem(I did not reformat, just ran set-up again). I have run scanreg / fix and also sfc.  Thank for any help
NoStaticAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sarangk_14Commented:
FIRST OF ALL TELL ME IF YOU ENCOUNTERED ANY PROBLEMS SAYING " GENERAL PROTECTION FAULT" OR SOMETHING LIKE THAT DURING THE INSTALLATION?
IF YES THEN I MIGHT HAVE AN ANSWER FOR THIS PROBLEM OF YOURS!
0
NoStaticAuthor Commented:
Here is what it says(as far as I,m concerned, 98se is a piece of crap). I never had any trouble with 98 osr2. The only reason I loaded this piece of junk was I was planning on running a 3com isdn ta and I didn't know if I would be running the ta on the usb port or serial. I read that 98se had better usb support.

Explorer has caused an illegal page fault..bla bla bla Contact your vendor

Under details:
EXPLORER caused an invalid page faultin module<unknown> at 0000:0000000003

and then the register stuf
0
CoolAssCommented:
Go to the System Info program located on your startmenu (somewhere... it's in there, trust me.)

In one of the menus in that program there is a Repair System Files or something similar, run that. If there are poopy DLLs or system EXEs it will repair them for you.
0
Starting with Angular 5

Learn the essential features and functions of the popular JavaScript framework for building mobile, desktop and web applications.

sarangk_14Commented:
First try to locate Explorer.exe in windows directory ( usual size of this file is 176KB).
If the size differs, go to MS-DOS prompt. From your win directory, type:
extract /y /a d:\win98\base4.cab explorer.exe, where d: is the drive letter where windows setup files are stored.

keep me posted.

sarang
0
MATTCEICommented:
Try deleting \Windows\Shelliconcache.This is a cache file for icons; it can cause these types of errors if it gets corrupted.Windows will re-create it upon reboot.

If that doesn't fix it,do a Find -  Files for *.CPL.These are what the icons within the Control Panel group are associated with.Double-click on each of them,see if one causes the error.If so,uninstall/reinstall that program.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
craig_capelCommented:
ok then.... Try this

Start
Run
Type in: sfc

Hit Start and let it go...
Watch Watch
Watch it still
And Wait.....


if it finds any files corrupted, it will fix them.....
0
trekie1Commented:
I had this problem with 98 se upgrade, then got 98se full version and it works ok( had same problem on 5 different comp)
0
trekie1Commented:
I had this problem with 98 se upgrade, then got 98se full version and it works ok( had similar problem on 5 different comp)
0
NoStaticAuthor Commented:
Hello All,
Thanks to everyone for their comments. Mattcei, you get the points. It's ironic that about a month ago, I looked at the "cpl" list of files, but only clicked on the first several. When the associated panels came up, I thought ok, thats what they do. I never continued thru the whole list. It turns out that I had 3 entries for tweakui. One of them launched the Tweak ui application, but the other two did nothing when I clicked on them. I deleted those two and the problem went away.
0
MATTCEICommented:
Glad all is well,NoStatic.Thanks for the points.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.