Problems with a Personal LaserWriter NT and System 8.6

I am a beige Power Macintosh G3 user. I have also a Personal LaserWriter NT with 2 MB of RAM. Until now, I've been using system 8.1 BUT with the original LaserWriter controller, because with the LaserWriter8 controller (installed with the system), my printings did'nt look well: the printer “eated” three or four lines at the top of the sheet and in the bottom, the margin was increased in the same way.
When I decided to upgrade to system 8.6, the problem was still there. Worst: the trick with the original controller doesn't already work (printer is out of memory).
I've tried to disable the desktop printer and also the print spooler, with the same bad results.
What can I do? Is the problem due to the RAM of my printer? Anyone knows the answer?
cursesAsked:
Who is Participating?
 
TheHubConnect With a Mentor Commented:
Did you allocate more RAM to Print Monitor (located in the Extensions folder)? This can be changed by doing a Get Info. The default is 160k, but usually complains if it does not have 512k.

Did you try using a different Printer Description?

Did you install the LaserWriter 8.6.1 update (I cannot remember if MacOS 8.6 ships with this already applied)?
ftp://ftp.info.apple.com/Apple_Support_Area/Apple_Software_Updates/English-North_American/Macintosh/Printing/LaserWriter/LW_8.6.1.smi.hqx

Does this unwanted behavior exist on both Ethernet and Serial (Printer Port) connections?

Does the problem exist when printing from all applications?

Does the problem exist when you boot your machine with all extensions off except the ones used for printing (and Ethernet if applicable)?

After you have gone through this list of questions and applied their solutions and you problem persists, you may need to add more RAM to the printer, downgrade your MacOS or buy an new printer (I like HP Printers).

You may also want to call an Authorized Apple Dealer and talk to their tech about it. The Personal LW NT was not their best printer product and there may be a hardware reason that Apple has not published on their web site as to why your machine is misbehaving. This may lead to an upgrade or the dreaded, "No, we are no longer suporting that model." answer from the tech. In either case, you'll know for sure if the issue can be resolved.

Good Luck,
-TheHub
http://www.MacintoshMagician.com/
0
 
weedCommented:
It depends on where and when it tells you yer out of memory. It could be that your computer is running out of ram or that the ram in your printer isnt enough to handle what youre sending to it.
0
 
BatemanCommented:
If the printer is running out of memory I seem to remember ages ago when using low memory printers that clicking Unlimited Downloadable Fonts sometimes worked (usually in Page Setup)
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
cursesAuthor Commented:
Thank you for your comments about Ram but, in fact, I could expect that the oldie LaserWriter driver that I've been using until now (v. E1-7.1.2) doesn't work (ram errors, crashes...) with the new system I've installed. I think that the real problem must be located in why the new printer driver (v. E1-8.5.1) installed whith the new system seems to be incompatible with my LaserWriterNT.
0
 
centervCommented:
curses
I'm not totally familiar with your hardware, but I can tell you that 2megs of printer ram is the absolute minimum. More ram may be the answer to your "eated" problem.
My printer gave me such a run for my money for weeks, conflicting with every extension I had at one time or another.
Turned out to be virtual memory. Shut virtual off and printer works perfect, except for the "eated" problem.
Mine was scaling larger than the page.
Set the page printing at 90% of size, and it's been printing flawlessly since in all apps.
I have 10 megs of printer ram.
Hope you can make sense of this and get some ideas from it.
Good luck.
0
 
BatemanCommented:
I have a feeling virtual memory is the answer here. Try turning it on, there is an Apple Tech Doc somewhere about it. I'm afraid that is the only fix if it works.
0
 
cursesAuthor Commented:
I'm afraid this cannot be the solution, because I've done all my unsuccessful attempts from the start with virtual memory on.
Sorry, but I must reject your answer.
0
 
Steven_KCommented:
OS 8.6 installs LW 8.6.x so that's not the problem. It probably is the memory partition of the print monitor. Desktop printers work the same way but there are more memory partitions to worry about (anything called monitor in the extensions folder plus the desktop icon itself.)
0
All Courses

From novice to tech pro — start learning today.