Notify function in CVS

Hello, I want to use the notify function in the CVS (I'm using 1.10.8)

I add a watch (for commit action) for a file. Also, I uncomment the file named notify in the server's CVSROOT. The line I uncomment is like following:
ALL mail %s -s "CVS notification"

Then I use another person to login and commit changes to the file that watched by the first people. But the first people did not get the mail notification. Also, when the second people commit changes, an message like "mail: Options MUST PRECEDE persons" display.

Why?
How do I set the notify file to notify people when their watched files are changed. Also, in the mail, I 'd like to include the the changed filename.

Thanks.

LVL 2
jonaleeAsked:
Who is Participating?
 
jlevieConnect With a Mentor Commented:
Okay, now that I know what the platforms are I can tell you how to fix the problem.

The "notify" file simply contains an example email notification command. It isn't meant to be used as is. You're supposed to use it as a guide when adding a command for the platform CVS is running on.

On Solaris the command would look like:

ALL mailx -s "CVS notification" %s

And on RedHat it would be:

ALL mail -s "CVS notification" %s

From the above, the error message should now make more sense. "mail" was complaining that it had encountered a recipient name (PERSONS) before the options (-s) and it requires all options to preceed the recipients.

As I recall, the email contains the name of the file (amoung other things) in the body.
0
 
jlevieCommented:
What platform are you running the CVS server on?
0
 
jonaleeAuthor Commented:
Solaris 2.6 (x86), also Linux (Red Hat 6.2)

0
All Courses

From novice to tech pro — start learning today.