Plug and pray "killed" me!

I'm not sure if anyone can really help me here, perhaps I'm just looking for a shoulder to cry on. ha!

I recently turned on BIOS PnP (on Intel 440BX-2) in order to assist Win98 in finding a firewire card.  Even though Win98 did find the card, it also re-found all the other components and system resources.  What I mean is that Win98 went insane and doubled-up the keyboard, mouse, floppy, most of the system resources, etc.  Needless to say, Win98 will now only boot up in safe mode.  I tried removing every doubled device and resource (both original and Win98 did boot up again...unfortunately, it then proceeded to double up everything again.

Has anyone ever seen such craziness before?   This computer has been extremely reliable for over 1 year now and has all of the latest Win98 patches.

My next and final(?) step is to just remove one of every doubled device and resource and reboot without BIOS PnP.  I have my doubts...

Word of advice to everyone... never trust [especially] a Microsoft product.  Backup before any change is made to any of there OS's!!
LVL 4
S ConnellyTechnical WriterAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

malinonCommented:
Plug&Play is kinda evil.  And if you've detected your hardware without PnP enabled, and then enable it, odd things happen (like this).

Wihtout PnP, a non-PCI device is detected as a legacy device (ISA cards or embedded devices, keyboards, etc).

You claimed that you removed the doubled-up items from the device manager, but I'm not clear on if you removed ONE item, or BOTH items.  

What you need to do is remove BOTH items of a doubled-up item while in Safe Mode.  Then shutdown the system and reboot.

Unless you've already tried this, I beleive it will solve your problem.
0
ajmcgarryCommented:
Or simply try removing the origonal ones!
0
malinonCommented:
That's assuming he can tell them apart.  I don't think you can unless you look at the actual registry entries.
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

mzieseCommented:
in bios mode seleckt irq available and take the manual then use the irq who is used by your hardware that makes trouble an selekt an manual irq. then start w98 the hardware detect will start and all hardware will be detect. goto coltrol center and delete the older hradware that was detected on erlier time. restart windows and this fix the problem.
greeting from moonblaster.
0
dew_associatesCommented:
mziese, your are new to this site, and with that, welcome. However, unlike Newsgroups and Usenets, we observe a protocol or policy at this site with which you should become familiar. Experts do not post proposed answers that are incomplete or that are speculative, nor do they post proposed answers that incorporate the comments of others that have preceded you. Since questioners can accept comments as answers, it is beneficial to the questioner that speculative answers be posted as comments, especially when the issue involves further troubleshooting.
In this particular case your proposed answer was, at best, a guess and obviously was not a method to resolve duplcate device entries and should have been merely a comment. We hope that you will follow the protocols and netiquette that other techs have observed here for quite some time. Thanks you in advance for you cooperation. Kindly withdraw your proposed answer in order to reopen this issue.

Dennis
0
dew_associatesCommented:
Sconnel, the proposed answer does nothing to resolve your problem. If, by the time you receive the email notification, it has not been withdrawn, kindly reject it so that we can help you resolve this issue.

=======================================
There are two ways you can deal with this problem. First and foremost, this is an issue with the dynamic portion of the bios, not Windows 9X, but it easy enough to fix. Here are the two methods you can use to resolve this problem.

Method #1:
------------

1. Boot the system into safemode.

2. Go into device manager and expand each area starting at the top and when ever you see a duplicate of the same device remove "BOTH", do not leave any behind. Since you originally installed the OS without PnP, Windows 98 views those devices as static devices via the bios and treats them as legacy devices not PnP. When you enable PnP, the dynamic side of the bios reports all of the devices again to Win98 anew except for those that are truly legacy.

3. Now reboot the system. Windows will reinstall just one device instead of duplicates.

Note: Unfortunately the above will note resolve duplicate motherboard devices, and since you want to incorporate firewire, the following is a better choice.

1. Boot into the bios setup reset the bios defaults.

2. After resetting the bios defaults, go back in and verify, and change if necessary, the individual settings for the CPU, memory type etc, hard drive parameters (use auto).

3. Make sure that you enable plug and play and disable Advanced Power Management.

4. Now boot into safemode.

5. Click Start, Run and type in REGEDIT and click OK.

6. Scroll down to this key:

HKEY_LOCAL_MACHINE\Enum

Right click on each key below ENUM and then choose delete.

Next, go to this key:

HKEY_CURRENT_CONFIG\Enum

and repeat the process as above, deleting each key below ENUM.

This will force windows to re-read and reinstall all of the system devices including the motherboard devices. I would recommend though that if you have a zip drive, scanner etc installed, remove it temporarily as sometimes they cause problems in determining device ID's.

Dennis


0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Adam LeinssServer SpecialistCommented:
Had this happen to me a couple of times (esp. Acers).  Dangerous procedure, but it has worked for me.  Remove EVERYTHING from the device manager.  It will find everything and it will add it and since you don't have any devices, it will re-add them and all will be good (at least you hope! =) )
0
S ConnellyTechnical WriterAuthor Commented:
Malinon:

"What you need to do is remove BOTH items of a doubled-up item while in Safe Mode." - I tried this too. Some of my [explaination] explaination got cut out.
Anyway, it didn't help as the next time I rebooted, all of these items were found again and doubled up.

To all others: I haven't had time to review your suggestions.  Thank you!! I'll continue this in two days.




0
thetdkCommented:
I'm just commenting so I can monitor the conversation. I recently had a similar problem and may have and answer. Try everone elses suggestions first, especially Dennis's.

One question though, are all of your devices PCI?
0
S ConnellyTechnical WriterAuthor Commented:
thetdk: yes, all PCI
dew_associates: Your idea is a slight variation of what I tried.  You've given me some good ideas. Thanks.. I'll try your suggestions and report back asap.
0
dew_associatesCommented:
Okay, I'll wait on you!
0
S ConnellyTechnical WriterAuthor Commented:
everyone: Thank you for your help.
dew_associates: Since you had the most 'correct'  answer, I'm happy to award you with the points.  

The solution, however, turned out to be much easier than expected. Some program actually backed up the "system.dat" file back about 2 months ago (which was good enough) so I replaced the newest one with this backed up registry and turned off PnP (BIOS)... rebooted. Now all is well!!

To prevent such an occurrence in the future, this is what I did (I didn't have a chance to do this before the mishap!!):

1. Using Partition Magic 5, I repartitioned the 8gb HD into 1.5gb/7gb.  
2. Removed many of the applications and re-installed them on the new D: partition (d:\program files\..) in order to make the C: partition as small as possible.  
3. Permanently removed PM 5 (did not require it any longer)
4. Ran Norton Ghost - Partition to Image. Imaged C: (high compression) to a file on D:
5. Burned the resulting Ghost image (610mb) to a CD ROM.

Next time something "bad" happens, I'll have a fully recoverable image available.  I've been using this (and similar methods) since Ghost first arrived on the market about 2 years ago for all NT/95/98 workstations - works like a charm!!

Take care all!
0
dew_associatesCommented:
Glad you're back!
0
S ConnellyTechnical WriterAuthor Commented:
Thanks...
BTW, I have a 500pts plus question in the Outlook SIG.  Give that one a 'crack'.

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.