• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 265
  • Last Modified:

Problem with /dev/tape

I'm using slackware 2.0 and I just
installed a tape unit (4mm,SCSI).
When the system boots up it doesn´t
recognize the tape unit.

I tried with
ln -s /dev/st0 /dev/tape

But it didn´t work.

What do I need to do in order to make it work.

Under DOS the controller is aspi4dos.sys

Any idea. Thanks in advance....
0
cblazque
Asked:
cblazque
  • 2
1 Solution
 
mixerfix122699Commented:
hi,

make sure that you have scsi tape support compiled into the kernel or compiled as a module and loaded.

also, make sure that the /dev/st0 device file is actuually there.
0
 
cblazqueAuthor Commented:
To mixerfix

Could you be more specific about the way to
check if my kernel supports scsi, and how to recompile the kernel (I've never done that before)

Thanks
0
 
mixerfix122699Commented:
ok... let's try to do this by numbers.

1. Slackware 2.0 is rather ancient (current version is 7.0)... Update, maybe.

2. Ftp to ftp.us.kernel.org and download the latest stable kernel (2.2.14 as of this time).

3. Unpack it in /usr/src (using tar zxvf linux-2.2.14.tar.gz).

4. cd to linux and rune "make config".

5. Select CONFIG_SCSI and CONFIG_CHR_DEV_ST.

6. run "make dep clean bzImage"

7. read the kernel howto on kernel installation.

8. install the kernel

0
 
gruseCommented:
What does the kernel say at boot time? When your SCSI controller gets initialized, it scans the SCSI bus and prints out every device it can find. Does your tape turn up? If not, it might be a SCSI hardware installation error,
wrong termination, duplicate target ID or just a bad or too long SCSI cable.

If /dev/st0 doesn't exist, it can be created by

mknod -m 660 /dev/st0 b 9 0

as root. If the SCSI tape driver doesn't get loaded automatically, try a

modprobe st

If your kernel doesn't support SCSI tape right now, follow mixerfix' tips, you'll have to follow mixerfix' tips.


0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now