mem=80M ??

I am using Linux Mandrake 6.1 .  The Compaq machine that it is running on contains 80 meg ram.  THe machine seems really slow though.  I have read that you need to specify any amount of ram over 16m??

How exactly do I let Linux know about the extra ram now that the system is allready installed???


Thanks
iowa1Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jlevieCommented:
If the bios sees the memory, so should Linux. If you want to check how much memory Linux knows about and how much is in use, you can do so from KDE's Settings->Information->Memory. The same information can be seen by examining the contents of /proc/meminfo.

Now, if Linux isn't seeing all of the installed memory, it could be that not all of it is actually usable, i.e., a bad chip or a hole in the address space. I don't have a url handy, but there are memory checkers for PC platforms that will do a pretty exhaustive test of a machine's memory.

BTW, 80Mb isn't that much memory, especially if the system is very heavily loaded. I'm on a laptop with 128Mb and as the only user I have no problem at all using up all available physical memory. When that happens the system slows down as it has to start swapping/paging.
0
iowa1Author Commented:
I  opened the /proc directory and it listed meminfo in the directory, yet I did not know how to open it.  I tried usings emacs, but nothing was showing in the window.

I don't have KDE because I set this up as a server install.

If Linux should automaticly see the memory then, why do they recommend setting it with mem = 80m??

Thanks for the help, yet I need some more.
0
jlevieCommented:
I just did "more /proc/meminfo". Who is "they" and where do you see the reference to setting "mem = 80m"?
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

bernardhCommented:
There are a couple of things that could be causing Linux to not see all your memory. On some 386's you need to compile your kernel with Limit memory to 16M? enabled.

On most systems, the reason is that the BIOS has a limit of how much memory it will tell the OS is present in the machine, even though the board can have more. Common limits seen with this promel are 16M, 32M, 64M, and 128M. To get around this, we need to explicitly specify the amount of memory to the kernel at boot time via the mem=memory goes
here> flag.

In the following example, we have a 32M machine but only 16M are being seen by Linux. At the LILO prompt, we type

     LILO: linux mem=32M

After the machine boots, we use the free command to see if the larger amount of memory was recognized by the kernel. If so, we can add an append line to the /etc/lilo.conf file and rerun lilo to make it happen permanently. The example from above could look like the following:

         boot=/dev/sda
         map=/boot/map
         install=/boot/boot.b
         prompt
         timeout=50
         image=/boot/vmlinuz-2.0.32
         label=linux
         root=/dev/sda1
         initrd=/boot/initrd-2.0.32.img
         read-only
         append="mem=32M"

Do not forget to run lilo after editing the file for the changes to be made to your Master Boot Record (MBR).
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
j2Commented:
just type "free" and get over it ;) It is the ram >64 you _needed_ to specify in the 2.0.x kernels.
0
iowa1Author Commented:
Good answer!  Thanks for the help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.