Samba and Linux permissions problem!

I have my Win98 PC and Linux connected by Samba and I am able to view the shares I have setup, but I don't have write access. How do I get write access?

Before you answer a few notes:

I have Linux dual booting with Win2k and the two partitions for Win2k are C and D and are Fat32. Linux is on its own partition.

When I installed Linux I mounted these drives as /dosc and /dosd and these are the drives I want to be able to access from Win98.

The following is the sections of my smb.conf file to map these drives.

[C]
   comment = C Drive
   path = /dosc
   valid users = Name
   public = no
   read only = no
   writeable = yes
   printable = no
   create mask = 0765

[D]
   comment = D Drive
   path = /dosd
   valid users =Name
   public = no
   read only = no
   writeable = yes
   printable = no
   create mask = 0765

Given this information, how can I get write access to these drives from Win98?
BeaufordAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
RobWMartinConnect With a Mentor Commented:
Most likely, the answer to your problem involves mount options rather than samba configuration.  When  mounting the dos partitions you should specify  ownership and possibly mode.  The default ownership is likely root.  This  is an example of what you will have to  do:

mount /dev/hda /dosc -t vfat -o uid=99,gid=99,mode=777

Of course the actual values will need to fit your particulars.  man mount for more details.

Hope this helps,
Rob

0
 
BeaufordAuthor Commented:
I have made some adjustments to my Linux box and removed Win2k and now have 3 Linux partitions. I am now able to read and write to the shares I specified.  A question though. I had to chmod 777 <dir-name> in order for write access - is this not insecure opening the directories like this?
0
All Courses

From novice to tech pro — start learning today.