• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 219
  • Last Modified:

problem retreiving from sendmail

We are running a RH 6.1 system, currently with fixed IP, and have configured sendmail for virtual domains. Inbound mail to the domain is working fine, I can see the contents of the spool files increasing steadily, and no error messages are encountered when mailing to a member of the virtual domain.
The problem occurs when you try to retreive the mail from a another client. According to the log, the user is authenticated correctly, but we get a message -
 "the mail server responded: cannot open mailbox /var/spool/vmail/<the domain>//rcflisik
Note: I have substituted <the domain> for the real one for privacy.
No error messages are generated in the log, the last entry is the user authenticated correctly.
We tried creating another domain - same problem. We tried eliminating the vdomains, and we get the same answer with basic use. This was working correctly a few days ago.
Any help would be greatly appreciated.
Thanks
0
rcflisik
Asked:
rcflisik
1 Solution
 
jlevieCommented:
This doesn't sound like a sendmail problem, as sendmail is delivering to the mailboxes. What mechanism is the client using to access the mailbox (POP, IMAP, NFS mounted mailspool)?
0
 
maxchowCommented:
If you have only 1 IP but multiple v-pop domains, you should setup the mail program (client) in this way:

pop username: <vdomain>/<vpopuser>
e.g.      abc.com/rcflisik

moreover, you should setup all pop user account under the virtual mail users option in linuxconf.

Regards

Max
0

Featured Post

The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now