MP3 recording runs SLOWLY

I want to know why this is. I've looked at all the info I can find, and nothing has answered my question: Why is it too slow? On my brother's Mac, MP3 ripping runs very quickly, often a minute or two (and sometimes) faster than the song being copied.

The rippers I use are available at:

http://www.cdex.n3.net  CDex Version 1.20

http://www.exactaudiocopy.de/  Exact Audio Copy V0.9 prebeta 3

I have had no other problems using these rippers. I set the rippers to record directly to MP3 format, and set thread priority to Highest. My only complaint is that they are too slow. Feel free to click on my screen name to view my PC specs.

Alex

P.S. I want to send a short, thirty second sample to a friend ASAP, so any prompt responses are welcome.



grater120898Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

zacharCommented:
0
jsextonCommented:
I had the same problem early-on and after trying several DOZEN programs, found MusicMatch Jukebox to be the fastest and all-around easiest way to make MP3s.

I normally get between 4x and 5x (a five minute song encodes in a minute!)with MusicMatch Jukebox (they advertise up to 12x recording but I don't have the hardware for that!):

http://www.musicmatch.com

There are many things that can slow down mp3 encoding.  The biggest problem is the way the software encodes the mp3 (there are a ton of different ways to encode an mp3, and some software implementations are better and/or faster than others - MusicMatch has been my favorite).  Hardware-wise, usually flat out processor speed (the MHz of your computer) makes the biggest difference.  
0
grater120898Author Commented:
Thanks for the responses so far. I'll try both players, and hopefully get back in 2-3 days in order to fully evaluate what works best. (Somewhat busy college student...)

More responses welcome.

Alex
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

hiap_hoCommented:
I have tried both, I think audiocatalyst is better. The speed may be the same, but I like the quality of audiocatalyst better =)
0
grater120898Author Commented:
Okay...back earlier on this than I expected! :)

I got the free, standard version of the MusicMatch. The Xing didn't install because the file I received was corrupted. (Maybe later...) I recorded a 5 minute MP3 of one track off a Dream Theater album at 96k, 22,050 Hz, and the sound quality was smoother, when compared to my other rippers at this rate.

When I recorded in digital mode, the MusicMatch actually recorded slower than the freeware rippers (see my first post)! I was getting 0.4x to 0.5x speed using the freeware stuff. With MusicMatch, I got around 0.2x. Too slow! In analog mode, MusicMatch did better than the RealJukeBox basic, which I also use. The MusicMatch was easier to use in this mode than the RealJukebox, for it automatically set the record volume before every track.

Now that I've solved the software side (for now), can someone please tell me why my PC is slow to record in digital mode?

To see my PC info, just click on my screen name, grater.


Alex
0
jsextonCommented:
hi grater,

Looking at the specs on your system I wouldn't think there would be any problems.  You've got twice the memory I have now and we're both using Win98.  The only major difference between your computer and mine hardware-wise is that I'm using a 366MHz Celeron P2 while you're using an AMD k6-2 350.  I don't  personally hold Intel over AMD (except that I am an overclocker and Celery makes it easy), but it seems that I recall reading somewhere that the K6-2 was not as fast as Intel with floating-point calculations.  MP3 encoding is very processor-intensive, so I don't know what else the problem could be.  

Can anyone else verify that AMD k6-2 is short on floating-point arithmetic?

Jon
0
boom23Commented:
I'd say the FPU in k6-2/3 is much better than the FPU in intel.

Grater, have you tried using audiograbber? I'm using it right now and I luv it. It rips quick fast.
0
rlippertCommented:
It might not be the ripping portion that is a problem and not the encoding portion.  Try just ripping to a plain .wav file and then encoding it, and see if that makes a difference.  Some CD-ROM drives are just lousy at DAE (digital audio extraction) and have to keep re-reading the data which causes it to go very slow.  In analog mode, the fastest you could get is 1:1 (ie a 74min CD would take atleast 74mins to rip and encode).  So try recording to .wav to see if your problem is with the actual ripping or just the encoding part.
0
grater120898Author Commented:
Thanks for the tip. I'll try that. In the meantime, I've contacted MusicMatch about a bug in their standard player. What happens is, when I record at 96k in digital mode, I get this message: "error (10) read error; retry in analog activated". The player converts transfer to analog mode. But I get a problem there, too. The MusicMatch GUI freezes and the resulting MP3 is out of sync in relation to the CD track. I hope to get an answer from them ASAP. While I wait for that, I'll try rlippert's advice.
More later...
0
jsextonCommented:
grater,

I noticed the same bug!  I just upgraded MusicMatch and got that bug on several CDs I ripped.  They are pretty good about getting patches out, so hopefully they'll fix it soon.  

BTW, I use 128k (registered version) so at 96k it should be even faster.  Definately try rlippert's suggestion just in case it is the CD.

Jon
0
grater120898Author Commented:
I just got a response from them. Here it is, along with a log I sent them:


Alex,

I apologize for the recording difficulty you are experiencing.

Error message 10 is an unrecoverable read error from the drive. It usually
means the drive does not support digital audio extraction. Sometimes it will
work when you set Max. Mismatch=255 and Multipass=On in "Advanced". To get
to the Advanced window go to "Options/Recorder/Settings" at the top of the
MusicMatch window then click "Advanced". If this still doesn't work analog
mode should be used.  I see you have adjusted the Advanced Recording options
with no improvement.

Generally there is little you can do to improve analog recording
capabilities.  The advanced options only effect digital recordings.

 For best recording performance, in any mode:

·      Avoid simultaneously running other applications that would drain the CPU’s
power (graphics programs, scanners, other compressors, etc.)

·      Avoid simultaneously running other applications, which are writing to the
hard drive.

·      Certain configurations, which cause the operating system to thrash, such
as low memory or many open windows, will also affect recording quality.


If you have not already checked for updated drivers for your CDROM drive,
video and
sound cards, you should do so. Outdated drivers can cause software
conflicts, which result in this type of problem. To locate updated drivers,
check with your PC manufacturer or the maker of your CDROM drive, sound or
video card. If
updated drivers are available, please install them and try to repeat the
problem you have experienced.

I hope this will be of some help.

Kind regards,

Kim
----------------
MusicMatch, Inc.
Technical Support
----------------


> -----Original Message-----
> From: TED ticket 59530
> Sent: Tuesday, February 08, 2000 9:17 PM
> Subject: [trk:59530] Technical Support Request # 41105
>
>
>
>
> DIA_ID           41105
> MMJB_KEY         RND-9-5-16-45-190
> VERSION          4.50.0029
> TSR PUSH
>
> EMAIL            tazzola@juno.com
> CUSTOMER         Alex Ramos
>
> The following files were submitted with this request:
>      usr = Yes
>      mmcd = Yes
>      dia = No
>      rec = Yes
>      mmcd_rpt = Yes
>      altlog = Yes
>      mmjblog_sav = No
>
>
> The following files did not upload correctly:
> MMCD_RPT not uploaded: file not found
>
>
> ------------------------------------------------
> PC DESCRIPTION
> == ===========
>
> Compaq Presario 5150 PC:
> AMD K6-2 350 MHz
> 128 MB SDRAM
> 8 GB Quantum Bigfoot HD Ultra 33
> Windows 98
> ESS AudioDrive 1869 chipset (SoundBlaster 16 compatible)
> JBL Pro speakers
> Compaq Presario MV500 monitor
> Rockwell HCF 56k PCI modem
> Voodoo3 2000 PCI video card w/ 16 MB SDRAM
> Compaq CRD 8322B CD-ROM 32X
>
>
> ------------------------------------------------
> DETAIL
> ======
>
> I am using the free, standard version of MusicMatch v. 4.5
>
> Whenever I try to record in the 96k modes, in digital mode,
> MusicMatch fails to record. I get the message: "error (10) read
> error; retry in analog mode". The other problem is, analog mode
> for the 96k causes the MusicMatch GUI to freeze and the resulting
> recordings are out of sync in relation to the original CD track.
> In this case, I unfreeze it by hitting Ctrl-Alt-Del, and End Task
> on MMJB Recorder. 64k and WAV modes work fine in digital and analog mode.
>
>
> ------------------------------------------------
> LOG ACCESS
> === ======
>
> Uploaded logfiles can found at:
>
http://logs.musicmatch.com/logs/view.cgi?STAGE=VIEW&DIA_LOG_ID=41105&MODE=2

------------------------------------------------

I'm going to try their suggestions...
More later

Alex

0
grater120898Author Commented:
I've solved my MP3 problem as best as I can.

I will still give out 200 points as promised; however, I will split it between rlippert and jsexton. So for you guys, I'll post two questions at 100 points each and after I get your responses, contact Customer Support to delete this question.

As far as the MusicMatch goes, I can use the 4.5 version, but with some limitations. Priority is at Very High. I can encode at 96k, but I have to turn off error correction.  The DAE settings are at MAX, block is at 26, overlap is at 7, and mismatches at 255. In analog mode, I set the priority as Normal. I 've sent a note along with my digital settings to MusicMatch tech support.

I've also contacted tech support at Compaq, but their forum site has been down since this afternoon, around 4:30 PM ET or so. I just tried a few minutes ago, and it's still down. My request there was to see if I could upgrade my firmware.

Alex
0
ianBCommented:
Hi,

I am answering this question so it can be saved as a PAQ, and refunding the 200 points back to the users account since he has already split points.

Ian
Community Support @ Experts Exchange
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.