Continual HardDrive Accesses - why?

Every 10-30 seconds, my HD (eide 18 gig Quantum) makes a HD access (read or write or seek), for no apparent reason. No logging seems to be taking place, from what I can see. However, this prevents the drive from entering standby mode. It is a standalone system with a cable modem, so inactivity should put the sys. into standby - no one is loging in to the system. Does anyone have a clue as to why this is happening? I've posted a process list (ie. results from ps aux) at http://home.cc.umanitoba.ca/~umvajcne/pslist if anyone wants to see what's running in case that gives a clue. The only odd thing I can see is that dmesg reports continually VFS: Disk change detected on device ide1(22,0). Guh?

thanks in advance
wunderpupAsked:
Who is Participating?
 
jlevieConnect With a Mentor Commented:
The first thing to know is that Unix systems in general, and Linux in particular, are never idle. The kernel is always running and will periodically "sync" it's in memory image of the filesystems with the disk image, although those intervals are much greater than 10-30 sec. Other tasks, syslog, cron, etc. can also cause disk activity in the once a minute or more range.

The dmesg entries about the "Disk change detected are probes to detect when a CD has been put in the drive. you can easily prove this by doing a "dmesg -c", the watching dmesg report more "Disk change", then load a cd, do another "dmesg -c", and as long as the CD is in the drive you'll not see any more messages.

There is some information in the "Battery Powered Mini How-To" that might be useful in tuning the system such that you can get the disk to spin down.
0
 
ReinierCommented:
Actually the syncing period is 5 secs for metadata and 30 secs for data. Check /etc/crontab and /etc/cron.d/* for periodically started jobs. Especially if you have the newer atd running then there should not be the older "at" line in your crontab. Many upgraders have both a crontab line and the deamon running. The crontab line causes a disk access every minute, so if you don't have the atd, upgrade to a distro that has.

At my desktop box at home I have to set the spindown time to at least 15 minutes in order to prevent the harddisks from spinning down during normal operation. Spinning up and down causes a lot of wear and tear in a harddrive, which will cause it to burn out sooner. So unless you have a laptop running on batteries you want to avoid spinning down. I use the apm command to manually suspend the box for the night, and then after 15 minutes of absolute idleness the harddisks spin down.
0
 
freesourceCommented:
I see lots of processes which could be causing this behavior.  I'd recommend that you simply go through each process and stop them (gently if you can).  If you aren't sure what a process does, then use either rpm (for rpm package based installations) or swim (for debian package based installations) with at least the -qf options.  For example:

$ which atd
/usr/sbin/atd
$ swim -qfi /usr/sbin/atd
Package: at                          Status: hold ok installed
Version: 3.1.8-2.1                   Essential: no
Section: admin                       Priority: important
Installed-Size: 89
Maintainer: Thomas Koenig <ig25@rz.uni-karlsruhe.de>
Description: Delayed job execution and batch processing
 At and batch read commands which are to be executed at
 a later time.
 .
 At is used to run a command at some specified future time,
 and batch is used to run a command when system load levels permit.

You could also add the -l option to find out where the SysV script is.  On Debian it's found here: /etc/init.d/atd
On most rpm based systems these scripts are found in /etc/init.d.  These scripts usually provide start|stop|reload|force-reload|restart options.

Obviously, you don't want to kill process 1 init :)
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
freesourceCommented:
When I said:

"On most rpm based systems these scripts are found in /etc/init.d.  These scripts usually provide start|stop|reload|force-reload|restart options."

That should be /etc/rc.d/init.d.
0
 
freesourceCommented:
You should post your inetd.conf, too.  I wouldn't be too surprised if some service is being accessed through inetd .. so you should either stop inetd or disable the offending service in inetd.conf, and restart inetd.

You didn't really explain whether or not you were connected to the internet with your cable modem.
0
 
wunderpupAuthor Commented:
I've checked all of your comments and checked with RedHat support. They had me kill magicdev which was constantly trying to see if a cd was inserted in the drive. The cable modem is used to connect to the internet, to answer the question, but that wasn't causing the accesses. I can now safely dump my computer into standby mode for the night.

Thanks for all your help.
0
All Courses

From novice to tech pro — start learning today.