RedHat 6.1 FTP server setup how?

I can't get the FTP server working on my RH 6.1 x86 box, which
is connected to my  LAN.  I can telnet, and can access the web
server from elsewhere on the LAN, just not FTP.  What config
have I missed?

Here's what happens when I try to open ftp:

---

[root@localhost /etc]# ftp
ftp> open localhost.localdomain
Connected to localhost.localdomain.
421 Service not available, remote server has closed connection#

---

This is what the inetc.conf file says

---

ftp     stream  tcp     nowait  root    /usr/sbin/tcpd  in.ftpd -l -a
telnet  stream  tcp     nowait  root    /usr/sbin/tcpd  in.telnetd
#
# Shell, login, exec, comsat and talk are BSD protocols.
---

And here is the passwd file

 
ftp:x:14:50:FTP User:/home/ftp:
nobody:x:99:99:Nobody:/:
xfs:x:100:101:X Font Server:/etc/X11/fs:/bin/false

---

Here is the services entry:

ftp-data        20/tcp
ftp             21/tcp
fsp             21/udp          fspd
ssh             22/tcp                          # SSH Remote Login Protocol
ssh             22/udp                          # SSH Remote Login Protocol
telnet          23/tcp

---

[root@localhost /etc]# cat hosts.allow
#
# hosts.allow   This file describes the names of the hosts which are
#               allowed to use the local INET services, as decided
#               by the '/usr/sbin/tcpd' server.
#

[root@localhost /etc]#
[root@localhost /etc]# cat hosts.deny
#
# hosts.deny    This file describes the names of the hosts which are
#               *not* allowed to use the local INET services, as decided
#               by the '/usr/sbin/tcpd' server.
#
# The portmap line is redundant, but it is left to remind you that
# the new secure portmap uses hosts.deny and hosts.allow.  In particular
# you should know that NFS uses portmap!

[root@localhost /etc]# cat hosts
192.168.1.0     Chaika
127.0.0.1       localhost.localdomain   localhost
192.168.1.254   Okina

thanx in advance, experts!
talkingdogAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jlevieCommented:
Error 421 is what you usually get when there is not an FTP server available on the remote. Since there doesn't appear to be a any obvious flaws in the config, I have to ask if you sure that an FTP server is installed on the system.

If you installed RH as a KDE or Gnome workstation, you'll need to add the wu-ftp package.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
psimationCommented:
I would agree with jlevie, during installation of RedHat, you have the option to select a FTP service, if you didn't selelct it during install, then you will have to install the rpm now, same goes for samba, http etc.
0
talkingdogAuthor Commented:
Thanks that did the trick.  I mistakenly assumed that the workstation install for Linux included an FTP server.  
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.