W98R2 loses USB mouse drivers seemingly at random

I am using a USB scrolling mouse (XLR8 from Interex) with W98R2 on a new Athlon 700 PC (I think the MB is Microstar, but am not certain).  The PC originally came with a PS/2 mouse, which I used while installing everything, then installed the USB mouse and removed the PS/2 one.

W98 now occasionally 'loses' my USB mouse drivers.  i.e. I boot, and the W98 user login is displayed, and the mouse does not work.  I then go into Add New Hardware and it says there is an unknown device under the USB controller.  If I re-install the driver and reboot, it's fine.

I can't seem to see a pattern in this, except that it sometimes happens when I start typing in my windows password while the pointer is still an hourglass (but also can still happen when I sit still for minute and let it settle down, so this may be a red herring)

I should add that I was supplied with a Mac version of the mouse drivers by mistake, then my supplier downloaded the Win98 drivers from the internet and emailled them to me.
mtorrAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

1cellCommented:
I'd say it's a problem with the drivers.  Everytime I have seen this problem in relation to a USB device, whether it be printer, scanner, mouse, whatever, I have seen the problem be solved by getting an updated driver  ( Yes, I see that you have ) from the manufacturer or using one of the Windows drivers.  
Further, since it makes the connection and works, it shows that the motherboard is doing its job and Windows USB support is working.  I say, blame the driver!
0
rayt333Commented:
I'm not sure if this applies or not but here it is:
Universal Serial Bus (USB) devices that are plugged in to a computer running Microsoft Windows 98 Second Edition may not work if the your computer uses the following hardware components:
An AMD processor (running at 350 MHz or faster)
A VIA Technologies USB controller
This behavior occurs because there is a timing-specific problem in the Universal Host Controller driver (Uhcd.sys), which may prevent USB devices from enumerating under specific timing conditions. To resolve this issue, download and run the appropriate file for your language version of Windows. The following files are available for download from the Microsoft Download Center:
http://download.microsoft.com/download/win98SE/Patch/4.10.2223/W98/EN-US/240075up.exe
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Asta CuTechnical consultant & graphic designCommented:
When I had USB device and mouse anomolies, did what has been recommended, but ended up needing to boot in SAFE MODE, and taking the following actions:

   Prior to rebooting in SAFE MODE, made sure my BIOS had USB enabled

 then ...

   In Safe mode, right click-my computer, choose properties, device manager and removed all ports, mouse, usb items.

   Had all my updated drivers, so rebooting and rediscovery fixed the problem; having my driver disks handy with updates rather than using the Win98 supplied drivers.  Although I should add, that my daughter with similar problems used the Win98 defaults and was OK as well, after the processes described.

Asta
0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

Asta CuTechnical consultant & graphic designCommented:
Wanted to add that you had a PS/2 mouse, which uses only IRQ 12.  Now that IRQ is free, but nothing else can use it (too bad).  Just wanted to ask what IRQs are reflected as open/free and/or if you have any problem devices listed here:

start
run
msinfo32
on the left, under IRQ, details
on the left also, Problem devices?

Under Tools - ASD - any problems listed or devices disabled by ASD?

Asta
0
mtorrAuthor Commented:
Thanks for all your comments, everyone.

1cell: After reading your comment, I checked my drivers against the latest one on the manufacturer's site, and it's the same.

rayt333: Sounds extremely helpful; I downloaded your link, but I'm in England, so I also tried to find the patch directly on Microsoft's page, so I could set English (Great Britain) - however, MS download page doesn't seem to like me, and won't respond to searches for that particular patch, I've tried everything!  Do I need a different version for England, or can I use the EN-US one?

astaec: I think I'll reserve your suggestion for a last resort :-) FYI, here's my setup (you were right about IRQ12, isn't that a pain?)

0      System timer
1      Standard 101/102-Key or Microsoft Natural Keyboard
2      Programmable interrupt controller
3      Communications Port (COM2)
4      Communications Port (COM1)
5      Iomega Ditto Dash
6      Standard Floppy Disk Controller
7      ECP Printer Port (LPT1)
8      System CMOS/real time clock
9      (free)
10      IRQ Holder for PCI Steering
10      Creative SB Live! 1024
10      NVIDIA RIVA TNT2 Model 64
11      Initio INI-9XXXU/UW PCI SCSI Host Adapter
11      IRQ Holder for PCI Steering
11      AMD 756 PCI to USB Open Host Controller
12      (free)
13      Numeric data processor
14      Primary IDE controller (dual fifo)
14      AMD 756 PCI Bus Master Dual IDE Controller
15      Secondary IDE controller (dual fifo)
15      AMD 756 PCI Bus Master Dual IDE Controller

No problem devices reported.
0
rayt333Commented:
mtorr
These are the different versions available, non separate for UK.

English
German
Spanish
French
Italian
Japanese
Portuguese
Swedish

I wasn't sure if it applied in your case but I thought I would at least post it for you to take a look at it.
0
Asta CuTechnical consultant & graphic designCommented:
SCSI devices (from what I've read) don't do well with IRQ Steering. Your modem looks like it's using IRQ 3, com port 2 (probably), and I'm unclear what is using your Com1 IrQ4, but believe USB can exist well there.  Perhaps you'll want to free up this IRQ, assuming it's not used other than for the port nothing's attached to.  That's the normal default assignment for a serial mouse, and since you're using USB (or trying) and have a PS/2 option still that would free one IRQ up.  You'd have to disable this in your bios if not needed to free the resource for Windows.

I guess at this point, if I were you, I'd consider reinstating my PS/2 mouse until we can sort this all out (assuming you're mouseless at this point).  I'd also consider removing ports in SAFE MODE and, in fact, any/all devices involved in the conflict or 'stand off' and then seeing if the reassignment improves your setup.  

There was a similar USB Question here that I read just yesterday.  Have you tried searching the E-E database here just in case a fix may already have been found?

Asta
0
mtorrAuthor Commented:
Thanks, that really seems to have cleared up the problem.  Thanks to everyone else too for their comments.
0
Asta CuTechnical consultant & graphic designCommented:
Great information, thanks as well.

Asta
0
mtorrAuthor Commented:
Er.. sorry, I might have mislead people here.  I have accepted rayt333's answer.  I didn't suss that my comment would be posted under Asta's.  Oops!  I'm new to this, sorry if I confused anybody.
0
Asta CuTechnical consultant & graphic designCommented:
You did everything as you wished, Rayt333 did receive your points.  There are no problems at all.  Having participated here, just commented that I also appreciated the information.  All is well.

;)

Asta
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.