global.asa changes not taking effect

Using NT4 IIS.
Whenever we make changes to global.asa the changes do not show through the browser.
The only way to get changes to take effect is to reboot the server.
erk! has anyone ever had this under NT?
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Try to stop and start IIS.
glenramseyAuthor Commented:
yep, tried that.  tried restarting the server - still no joy.
we are now getting all files acting like this - if you make a change you do not see it through the browser
What service pack are you on?

To use the Global.asa file after applying SP4, ensure that the file is in an application root folder. This is a change from the implementation in the Windows NT Option Pack, in which Global.asa was mistakenly processed from within a virtual directory.

The Global.asa file specifies event scripts and declares objects that have session or application scope. In the Windows NT Option Pack, the file Asp.dll processed Global.asa from the lowest defined virtual directory. This has been changed in SP4. After SP4 is installed, customers who are using Global.asa may need to make changes to IIS for the file to work properly. For more information, see the "Global.asa Reference" topic in the Windows NT Option Pack online documentation.

To ensure that Global.asa is available to Asp.dll after applying SP4, folders that contain Global.asa files should be marked as applications. For more information, see the "Creating Applications" topic in the Windows NT Option Pack online documentation.

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

Tim HolmanCommented:
Does the browser on the IIS server itself show these changes (logged on as administrator) ?
did you allow caching of asp files?  we removed that and specifically added the cachetime=0 to all asp files to keep it from happening.
I had the same problem. When trying to use different global.asa files on one machine.

Have you tried running it under a different port number for instance 100 than stop and start the webserver and try again.

That helped on my machine.



Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.