setup samba on solaris2.6

Does anyone know how to setup samba on solaris2.6? if yes, please give me step by step how to do it.
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Have you read all the documentation yet ??
It does show you step by step ... or almost on
how to install Samba on a Unix box.
     Depending on your method of installation, you can either get the source and install it from scratch (compile, install, and configure) or you can get a precompiled binaries and eliminate the tedious compilation step (but it's fun though).
   You can check out the Samba homepage at

   Or you can grab a precompiled binaries from htp://  The distribution are in pkgadd format and compressed with gzip.  So you must have gzip installed on your system (Sunfreeware have it too).

   Once you have obtained the package, uncompress it
   # gunzip samba-2.0.0-sol26-sparc-local.gz
  Then install it using pkgadd

   # pkgadd -d./samba-2.0.0-sol26-sparc-local

   The package will be installed in /usr/local/samba

   The configuration file will be in /usr/local/samba/lib/smb.conf

   workgroup = MYGROUP

      guest ok = no
      read only = no    

   * This is the simplest configuration as obtained from Samba Documentation.

   To start samba, there are two way, standalone, or from inetd.  I bet you are already familiar with this.

   For standalone setup, you must execute smbd and nmbd, from your startup scripts ( in /etc/rc3.d)

   For inetd, you have to do the following:
  1. You have to edit you /etc/services to include these two line
       netbios-ssn     139/tcp
       netbios-ns      137/udp
  2. Your /etc/inetd.conf should have these line (make sure it is in one line with no line breaks)

      netbios-ssn stream tcp nowait root /usr/local/samba/bin/smbd smbd       netbios-ns dgram udp wait root /usr/local/samba/bin/nmbd nmbd

   Then restart you inetd (kill -HUP <pid of inetd>)

   Then you Samba should be running.

   Please check the file UNIX_INSTALL.txt for detail description on the  step by step to get it running.  The documentation is /usr/local/samba/doc contains a bunch of things you need to get it running.  Check it out.

   To facilitate the configuration you can check out Samab site for some GUI based configuration tools.  I'm happy with Webmin (  To get webmin running, you must have at least Perl 5.004.

Good luck,

there is no better doc than that which comes with Samba (or on
Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

qtruongAuthor Commented:
Dear Samri

Thanks for getting back to my question. I did just about everything you mentioned above. However, when I go to my NT work station to map that UNIX  driver, I got a small pop up window asking me to enter login/passwd. No matter what I tried, I kept getting an error message saying "The account is not authorized to login from this station" .
according to your error message, check in smb.conf:
  hosts allow =
  hosts deny  =

Assuming that you have added the user's password to Samba's passwd file with smbpasswd, you also might check in smb.conf:
  security =
  password server =
  encrypt passwords =
by default samba expects unencrypted passwds and nt supplies encrypted ones. You have to configure NT to use unencrypted passwords - you can find out how in the file ENCRYPTION.TXT which is supplied with tha samba
source code - it is a simple registry change.

Alternatively, you can leave NT alone and configure samba to use encrypted passwords, this involves activating the encrypt passwords = yes line in smb.conf, and making the smbpasswd file - there are instructions for this too - can't remeber which file, so go to the docs directory and do grep smbpasswd * to find it
qtruongAuthor Commented:
I would like to express my appreciation to all of you for helping me set up the samba working properly on UNIX. I'm glad I found this website.

Best Regards,

  I think I'll lock the question, and wait till it;s get autograded.


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
samri changed the proposed answer to a comment
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Unix OS

From novice to tech pro — start learning today.