Canon 6100

Error message is "error writing to LPT1"
I have checked LPT settings and even reinstalled port. Have followed all guidlines in tech book and CD-ROM i.e. the printer is selected, the port is selected, I've tried with "print directly to printer", turned off bi-directional support, all is back on again as the error message still appears. Drivers are current. I have installed this on another machine here in the office and same message. We had HP printers and they worked fine till they died. Could this be some sort of .ini problem?
michelewellsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

michelewellsAuthor Commented:
Have tried the Dos C:\windows\DIR>LPT1 and get message "write fault error writing device LPT1"
0
briancassinCommented:
1. Check your cable It needs to say IEEE-1284 compliant... if it does nto say this get one that does.

2. Make sure any previous printer you had is completely uninstalled

3. Make sure the printer is connected direct no switchboxes or running through other ports

4. When your computer boots up it will say press this key to enter setup press that key then go under integrated perphrials or ports look for the lpt1 port setting set to either SPP (standard Parallel Port), normal, or Bi-directional whichever mode you have in your bios.

I would say from what you have wrote it is one of three possibilities

1. bad cable or incorrect cable

2. previous printer drivers have the lpt1 port locked uninstall them and check the win.ini for the previous printer remark any lines that pertain to the previous printer

3. The port mode in the bios is incorrect

4. Bad parallel port on the printer (try another printer on the pc if it works then this is most likely the problem)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
michelewellsAuthor Commented:
Turned out to be a bad port pin! The problem was on again/off again and I finally got it down to the connector on the MB itself. I replaced the MB and all is working fine now. Thanks for pointing the way!
0
briancassinCommented:
your welcome
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Development

From novice to tech pro — start learning today.