Access Bug: MSysModules???

I've got a problem with trying to import objects into a certain Access Database. Whenever I try to import a report, form or a module I get the error "Record(s) can't be read; no read permission on 'MSysModules' ", I click ok to this and another error comes up "Object Invalid or no longer set", I click OK to this one and I get an application error telling me that certain memory could not be 'read', and advising me to click OK to terminate the application or cancel to debug the application! Here I click Cancel (why not, hey?!?) and visual C++ opens with an error that says: "Unhandled Exception in MSAccess.exe (VBA332.dll); 0xC0000005:Access Violation".
I click ok here and it lets me debug access (?). As i don't know C++, this isn't much good to me.
All I want to do is import a report!!

Anyway, a little background: I'm running NT SP4, the database I'm trying to import to is on an NT server and the database I'm trying to import from is on my PC. I have full access to the database I'm trying to import to (in fact, I'm the owner of the database). I've tried doing this on other NT machines and a WIN95 machine all with the same result. I can create objects of any kind in the database, I can edit whatever I want, but I just can't import.
Now, as far as i know MSysModules is a system table that seems to store details of all the modules in the database. To start with I thought that there was some buggy problem with access securities or something, but it's not even using a security file!
To start with I couldn't open MSysModules directly, so I went into the User & Group Permissions section and gave every group & user administration access to everything.
This seemed to alow me to open the table, but it didn't fix the problem.

Can anyone help???

thanks in advance,

-Pinko
pinkoAsked:
Who is Participating?
 
chewhoungConnect With a Mentor Commented:
have you try export from the original mdb?
If still cannot, try repair and compact the original mdb, and try export/import.
0
 
chewhoungCommented:
You need to set permission on both the mdb you are going to import from and import into.

For both mdb, do this step:
-open the mdb.
-select Tools menu, select Options sub menu
-Select View tab, check on both the System object and Hidden object check box.
-go to user permission place and set all permission to current login user for all msys... tables.

Do this step for both mdb then try again to import.
0
 
simonbennettCommented:
Have you tried to repair the source DB?
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
pinkoAuthor Commented:
Setting permissions in both databases seems to have done the trick ... on part of the problem.
But now, when I try to import the report, I get an error saying that: "'Index 1' isn't an index in this table. Look in the indexes collection of the tabledef object to detremine the alid index names".
And it still won't let me import the report.
Now, I had a look in MSysModules, but there wasn't an index called 'Index1', however, there was and index called 'Index1' in MSysModules2....

Any ideas???

I checked both DBs and both of the MSysModules and MSysModules2 tables had identical index setups.....
0
 
pinkoAuthor Commented:
I've been tweaking the MSysModules tables in both databases and I've got Forms and Modules to import!!! This means that I can import every object, except reports..... When I try to import reports it says 'Automation Error' and doesn't do anything.

What i did was: The MSysModules table seemed to have been stuffed up somehow - there was only one column in it called __A__, there were no records at all. The MSysModules2 table looked a lot more healthy - it seemed to have what looked like proper information - ie: valid records and column names.
So I made a copy of MSysModules2 and named it MSysModules (after backing up both tables of course). This allowed me to import everything except Reports!

any ideas on this??
0
 
chewhoungCommented:
I think you better create a new blank mdb and import into that mdb.

or export from the original mdb to the new mdb.
0
 
pinkoAuthor Commented:
Yeah, I'll try that. But the database is pushing 200MB, so there's going to be some copy time involved....
I'll get back to you & tell you how it went in about 2 hours..

thanks,
-Pinko
0
 
pinkoAuthor Commented:
OK, nah - that didn't work. It still won't let me import reports. I get "Automation Error".
0
 
pinkoAuthor Commented:
Wow, export works! Import still doesn't work, but export works! I can export reports, but I can't import them. Access is a wonderous product isn't it? At least I can use this to work around the problem for now.

Thanks for all your help,

-Pinko
0
All Courses

From novice to tech pro — start learning today.