MODEM MISERY

Modem Misery

by T.S.C.


CONTENTS:

I    - Objective
II   - Problem
III  - Hardware
IV   - Software
V    - Steps Taken
VI   - Ideas
VII  - Conclusion


I) Hi expert person(s). Basically I am trying to connect to the internet using the Linux OS (kernel 2.2.14).

II) The problem is that my modem does not seem to be sending response signals (OK, etc.) when given commands during a Linux session. I do not have a "Winmodem" - it responds to standard AT commands during Windows 98 sessions (using the "Hyperterminal" application) - I receive "OK" responses and all commands seem to be carried out properly. In Linux I am able to issue commands and achieve the desired result using the terminal option of my PPP program, which is, obviously, a relatively laborious solution. However, when I use the same PPP program to connect automatically with a script, the process hangs on the first command (initialization). There does not appear to be a way to force the script to follow through without receiving the "OK" responses it expects from the modem. I will detail "solutions" I have tried to implement in section V.

III) My system components: Intel SE440BX-2 motherboard, Pentium II 300 mhz CPU, Western Digital 8.4 gigabyte hard drive, US Robotics Sportster (OEM) ISA 56k internal faxmodem (model 0460, FCC registration number: CJEUSA - 30429 - MM - E, serial/product number(?) 22112828DCKP 66178781 R2). Toshiba 32x ATAPI CD-ROM, ATI Mach 64 3D Rage Pro video card, generic floppy drive.

IV) I am running the Linux Mandrake 7.0 OS, using the KDE desktop environment. I installed the OS with the "Custom - Normal" options. Recent pppd and chat packages are installed. The PPP program I'm working with (mentioned in section II) is "Kppp," (the KDE PPP application).  I have an "isapnp.conf" script running at boot time (no errors reported) to set the modem at the same port and IRQ as found in my "serial.conf" file (which I initially tweaked with the "setserial" program to adjust where the OS looks for input from the modem).

V) I have, I believe, read all relevant HOWTO, INFO, and MAN pages. I went to the 3COM/US Robotics web site and downloaded manuals and spec sheets for the modems that looked most similar to mine (none match my model number - maybe because the modem is OEM and/or too old?) I reviewed these documents and found nothing useful. I visited several Linux chat channels and pestered many people - no one had the answers. I have tried creating a custom chat/pppd script to connect. Connection fails. I have also tried using various modem commands during terminal sessions (in Linux) to change modem settings before using the automatic connect feature of Kppp, such as "ATQ1" (used to make modem responses visible in a terminal (it works in Windows 98 with "Hyperterminal") but it fails to do so with the Kppp terminal in Linux). I have also begun to adjust terminal modes in Windows with "Hyperterminal" (ASCII, TTY, AUTO-DETECT, etc.) but so far the modem responds correctly in every mode I've tried (my thinking was that the modem "mode" could be set wrong by Linux at boot time).

VI) It seems to me that Windows must be setting the modem configuration differently than Linux. My only ideas at this point are A) The modem "mode" could be set wrong as described above, B) The Kppp program could be faulty, C) There could be a conflict in hardware settings (?) (I found a conflict notice in the Linux boot log, but the modem carries out commands, such as dialing and hanging up, from the Kppp terminal - as stated in section II, the only problem is using the auto-connect feature, since it will not proceed without receiving the proper modem response after each command), D) I have overlooked critical information given in the documentation, or E) My brain is faulty (no upgrades available).

VII) So there you have it. I am a Linux newbie, as well as a modem novice, so I expect I'm missing something simple and/or obvious. I hope you can tell me what I'm doing wrong!

reply to: tsc_88@hotmail.com
 
tsc8Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jlevieCommented:
This sounds suspiciously like a resource confict that's interfering with interrupt handling. If there is a interrupt problem, you'd probably be able to send data to the modem, but the driver would never get the interrupt indicating data was ready to be read.

Are you certain that you're not conflicting with an on-board serial port? If you want to use the same IRQ & I/O port as one of the on-board serial ports you need to disable that port in the bios.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
j2Commented:
1. Could i see your pnpconf file?
2. you have to run setserial after the modem is initialized
0
tsc8Author Commented:
You were right! Thanks a lot!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.