New drives not displaying in explorer

I've just installed a new hard drive in addition to my exisiting one. The original drive is just C:, and the new drive is partitioned into 3 which are D:, E:, and F:.
The zip drive is now G:, and the cd-rom is R:.
All the drives are functioning fine, I partitioned and formatted the new one using FDISK and it is all FAT32.

The problem is that in Windows 98 I can initially only see C:,D: and E: in Windows Explorer, but if I type any of the missing drive letters into the command line or the explorer bar, that drive appears in the tree and everythings fine!

So, I can see all of my drives once I have entered the missing drive letters into the explorer bar one at a time, and they all work fine.
But then when I close Explorer and reopen it they are gone again, leaving just C:, D: and E:.
It occurs to me that this is either one of two things:

1) Something to do with Active Desktop or whatever remembering the drives I had before and only displaying those three drive letters until I specifically ask it to show me the others.
OR
2) A bug in the first release of Win98 (which is what I am using).

Can anyone help?
REMarlowAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Patricia Siu-Lai HoCommented:
REMarlow,
(1) First, checking if you've installed the TweakUi. If yes, go to the control panel, TweakUi, My computer, inspect in the drive F has been unchecked. Enabled it again by checked the box next to the drive F.
(2) Go to the command mode, create a directory in drive F.
(3) At the normal desktop, Start-run, type "sysedit" without the quotation and at the config.sys add a line at the bottom.
     LASTDRIVE=Z
     Save the file and exit.
(4) Inspect if you F drive is partitioned less than 540Mb. If so, you may try to re-partition your new drive to make each partition size larger than 540Mb.
(5) Try to go to the control panel, inspect if you've installed the Findfast. Inspect if you have enabled the C,D,E drive but excluded the F drive.

Let me know how you made out.      pslh
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
REMarlowAuthor Commented:
How daft am I? I've been home for lunch and figured it out while I was there. Obviously you hit the nail on the head straight off so you get the points anyway!
Yes it was TweakUI. For some reason when I first installed it a long time ago I unchecked all the unused drive letters in the My Computer tab.
Once I'd re-enabled F,G and R and restarted, there they all are in explorer!
Thanks ;)
REMarlow

0
Patricia Siu-Lai HoCommented:
Thanks REMarlow!     pslh
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.