Raw partitions on linux

Hi
Im trying to set up sybase on suse 6.3 and can't specify a raw partition for master.dat. I can specify the block device i.e. /dev/hdb6 but it really wants a character device. I can see devices called raw* but I dont know what they relate to also a man of raw gives me a command that will set up character devices but I don't have the command only the man page.

Any help appreciated
orangoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

chanderCommented:
Try "/dev/rhdbX".. ("X" is your raw partition number.......If the device does not exist do a
"mknod c /dev/rhdbX <maj> <min>".......where "X" is your raw partition number...where <maj> is the device major number....and <min> is the device minor number....<maj> and <min> will be the same for both "hdbX" and "rhdbX"....use "fdisk /dev/hdb" and create the partition "/dev/hdbX".....
0
chanderCommented:
Just one more thing..... Which version of Sybase are you configuring.....you might want to cheak the Sybase document to see if raw devices are supported...
0
orangoAuthor Commented:
Chander
I have set up the devices as you suggested the syntax didn't work until I moved the c after the device.
This gave me an ls -al of
brw-rw----   1 sybase   disk       3,  69 Dec  6 22:26 /dev/hdb5
brw-rw----   1 sybase   disk       3,  70 Dec  6 22:26 /dev/hdb6
brw-rw----   1 sybase   disk       3,  72 Dec  6 22:26 /dev/hdb8
brw-rw----   1 sybase   disk       3,  73 Dec  6 22:26 /dev/hdb9
crw-r--r--   1 sybase   root       3,  69 Feb 11 10:11 /dev/rhdb5
crw-r--r--   1 sybase   root       3,  70 Feb 11 10:14 /dev/rhdb6
crw-r--r--   1 sybase   root       3,  72 Feb 11 10:14 /dev/rhdb8
crw-r--r--   1 sybase   root       3,  73 Feb 11 10:14 /dev/rhdb9

but when I tried to specify /dev/rhdb5 as the master device it returns
cannot open file '/dev/rhdb5' Operating system returned :Input/output error.

I have tried changing the permissions to 660 (also tried 777) and the group to "disk" like /dev/hdb5 but it still gives the same error.

Thanks for your help.
Regards
Orango

Also the sybase version is 11.0.3.3-23 and when you specify a block device it warns you and says it really wants a raw/character device so writes are performed without buffering.
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

orangoAuthor Commented:
Adjusted points to 300
0
orangoAuthor Commented:
see text above.
(sorry added it as a comment)
0
tosiCommented:
I supect that RAW support is planned in Linux, but it's not yet a reality.

I quote SuSE ( http://sdb.suse.de/sdb/en/html/adabas_raw_device.html )

You want Adabas D to store its data directly onto a raw device instead of a file. However xcontrol only returns with an error message upon this request. This
is caused by the Linux Kernel, which has no driver for a raw device. However there exists a buffered block device.

Sorry.
0
orangoAuthor Commented:
Thanks for the help. I had read in a raid howto on the web that raw devices were not supported yet but didn't know how old the howto was and finding the raw man page I thought I was in with a chance.

Next question is can I give chander and tosi 150 points each ?
0
mixerfix122699Commented:
you might want to have a look at the TiVO sources which _do_ support raw devices...
0
proglotCommented:
I have not seen 'charaster' devices for disk in /usr/src/linux/Documentation/devices.txt
0
darinwCommented:
Community Support has reduced points from 300 to 100
0
darinwCommented:
Reducing points to allow points to be split among experts.

darinw
Customer Service
0
mapcCommented:
There's raw device support in FreeBSD, and the application can happily run under amulation, even better - since FreeBSD has better VM subsystem.
Give it a try.
0
mapcCommented:
I'll post it as an answer; there is
a RAW io support available - from
Silicon Graphics Inc.:
http://oss.sgi.com/projects/rawio/
Use with care.
I still think that FreeBSD is better.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
tosiCommented:
According to SuSE's announcement of SuSE 6.4, they already support raw IO devices ( disks ) from April 4:th. That should make many a man happy :-)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.