IIS FTP

Why can't I connect to a server running an IIS FTP site?  When not on the machine, I can ping it, but cannot get an ftp connection to it. When on the machine I can get an ftp connection but am not able to logon.

OK as of 2/11/00 I can login with a user name of \domain\username but not with just username.  The allow anonymous connection is disabled, and in the FTP Operators listbox I have 3 entries 1. Administrators(local account I assume) 2. domain\admins (global I assume) 3. domain\username for a user who needs this type of access (also global).

So I guess that my question is now why do I have to use the domain name in the username? Thanks for your responses, I did check everything that was suggested.

The IIS Server and any user that needs to logon are in the same domain.
mpaulsmeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

TooKoolKrisCommented:
How are the permissions setup? In the MMC got to your FTP site right click on it and choose properties - directory security, is every one granted access?
Is the port set to 21?
How are you trying to connect?
0
mhartogCommented:
do u have "allow only anonymous connections" checked, because if u do, its only possible to connect as the anonymous user. Let me hear......
0
TooKoolKrisCommented:
Is the Username that is specified for anonymous access been changed from the default one that was created during setup?
If so you need to make sure that whatever account is being used for anonymous access has the right to log on localy and you should make sure that "Enable Auto Password Synch." is checked as well.
0
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

mpaulsmeAuthor Commented:
Edited text of question.
0
mpaulsmeAuthor Commented:
Edited text of question.
0
mpaulsmeAuthor Commented:
Edited text of question.
0
TooKoolKrisCommented:
Is the user in a different domain than the IIS server?
0
Tim HolmanCommented:
Is there a router or Proxy in between, with port 21 blocked ?
0
mpaulsmeAuthor Commented:
Edited text of question.
0
mpaulsmeAuthor Commented:
Edited text of question.
0
TooKoolKrisCommented:
Just to make sure we aren't overlooking something basic and simple go here and follow the instructions given and let us know if the problems still exsit.

http://support.microsoft.com/support/kb/articles/Q185/3/77.ASP?LNG=ENG&SA=ALLKB&FR=0

0
mspoolCommented:
Make sure the FTP site in IIS is setup to use accounts from the NT domain.
0
jagoodieCommented:
I have had issues with this aswell.
I know that one way to resolve this is to make the server a Primary or Backup domain controller instead of a stand alone.
Which version of IIS do you have?
0
EJET97Commented:
The users who need to have access to specific folders on the FTP servers have to have the right to log on locally. So what we did is creating a group with this right and than put the FTP users in that group.

What I overlooked myself the first time is that you should select the option password never expires. Otherwise the user arrives at the server and logs in and NT says please change your password this is not recognised by FTP and the user goes out.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jagoodieCommented:
did you even read the question ejet97?
0
Tim HolmanCommented:
Bear in mind that if you do choose authentication based on a Win NT account, the NT account and password are sent as CLEAR text, so anyone with network monitor or some other analyzer will be able to trap user credentials...

I recommend you set FTP based on anonymous authentication.

I think the problem you're having is that maybe a domain controller is not visible to the IIS server, or maybe a BDC is failing ?
It could be a case of ensuring PDC > BDC replication is working OK.

Also, if you want to assign authentication in this manner, you have to set these properties on the FTP object itself, not the default one, if that makes sense ?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.