Thumbnails & File Previews

When I try to view my folders through my computer as a web page.  I used to see a preview of the file contents on the left but recently this has not been occuring with jpgs and gifs I have created with microsoft Photo Editor.  I'm now only getting file previews of .bmp .txt and .html.  Also when I switch my view to thumbnails I only see thumbnails of my bitmaps.

I think something happen to the file type association when I had to reinstall Photo Editor.

I can't get things back the way they were.  Please tell me if there any particular settings to make this work again.
TimSchildAsked:
Who is Participating?
 
dew_associatesConnect With a Mentor Commented:
Hi Tim,

In order to resolve this, Click Start, Run and type in regedit and click OK. Now drill down to the key listed below and verify that the following entries exist in this key:

HKEY_CLASSES_ROOT\<file type>

There must be one entry for each file type in this registry key for the type of file you are trying to preview:
 
Registry Key: [HKEY_CLASSES_ROOT\<file type>\ShellEx]
 
Registry Key: [HKEY_CLASSES_ROOT\<file
   type>\ShellEx\{BB2E617C-0920-11d1-9A0B-00C04FC2D6C1}]
 
Value: (Default)="{7376D660-C583-11d0-A3A5-00C04FD706EC}"
 
 
The following file types use the registry values listed above:
 
   .art
   .bmp
   .dib
   .gif
   .jfif
   .jpe
   .jpeg
   .jpg
   .png
   .wmf
 

As an example, for GIF files, you should see this key:

Registry Key: [HKEY_CLASSES_ROOT\.gif\ShellEx]

If you click on the word ShellEx in the left window to highlight it and then click the + sign to the left to expand, right beneath ShellEx should be another entry that looks like this:

{BB2E617C-0920-11d1-9A0B-00C04FC2D6C1}

Now, if you click on this entry to highlight it, in the right window, you should see this:

(Default)   "{7376D660-C583-11d0-A3A5-00C04FD706EC}"

These values are identical for each type of file, so if these keys are missing for your JPG, JPEG and GIF files, they will need to be recreated. Verify if they are present for these three file types, and if they are not, they will need to be added. If you're uncertain as to how to do this, let me know.

Dennis
0
 
PasciCommented:
Hi TimShild:

If you have Internet Explorer 5.0 go to: Start-Run then type:
"regsvr32.exe /i shdoc401.dll" without the quotes, then OK.

If you have Internet Explorer 4 type:
"regsvr32.exe /i shdocvw.dll"    
 
See if that helps!!

0
 
aux5Commented:
Please try this and let us know if it helps:

If you don't have TweakUI on your hard drive, copy the following files from the Windows98 CD:

in the tools/reskit/powertoys directory,

there are 4 files that begin with TWEAK,

copy them to your c:\windows directory

right click on TWEAKUI.INF and choose Install

Once it's installed, in the Control Panel, click on TWEAKUI, go to the REPAIR tab, and in the dropdown box, select Repair File Associations.

Reboot and see if things are better.

If not, it is my experience that both NORTON UTILITIES and NUTS & BOLTS are pretty good at restoring File Associations

you can download demos of either of those to fix your problem!
0
 
eversoslightlyCommented:
Here's a program you might like (not associated in any way, just use it everyday)--
Jet Photo Shell from http://www.cowon.com/engdefault.htm

The icons actually appear as the pictures they are, and right clicking will give you a slightly larger view of them.  I love this program.
0
 
TimSchildAuthor Commented:
I tried the TweakUI suggestion but it didn't solve my problem.
0
All Courses

From novice to tech pro — start learning today.