LPTx not recognized

I am not able to install the Epson 440 Color printer due to the LPT port not being properly installed, detected in Win95 (OSR2).
I reinstalled Win95 (prior to which, the printer was running fine) and no LPT1 was detected.  I spoke with my PC manufacturer, Quantex, and they tried to resolve the problem, but were unable and indicated that it is an Epson Port issue.
In System Devices in Ports, the only port listed is Epson Printer Port (there is no LPTx).  I tried to remove the port, in SAFE MODE also, but was not able to.  Windows indicates that the Epson Printer Port is a device category and cannot be removed.
While trying to install the printer, I received and error: Unable to install specified printer. Windows is in abnormal condition.  Restart Windows or reinstall OS.
I realize that this sounds like a Hardware issue, but Quantex insisted that it has to do with the Epson Printer Port.
I tried:
Disabling the LPT port in the BIOS
Uninstalling the Epson Printer Port in Safe Mode
Uninstalling the Epson Printer Port in Normal Mode
Installing Win98

Nothing has worked.  Any asssitance would be greatly appreciated.
Who is Participating?
TascanConnect With a Mentor Commented:
Com 1 should be the mouse unless you have a PS2 style mouse
Com 2 should be the modem usually and 3 sometimes but that
conflicts with modem on com 1 almost always...
My usual way of dealing with Com problems.. in bios turn of Com 2
or set it to 3 if it can, then set up the modem

You mean to say that the epson port refuses to go away? (yuck)
I'd do a search of the entire C: Drive for eps using start, find,  files or folders
and delete every single one of em at this point but not empyt the recycle bin
then restart and go into control panel, system, devices and remove
all lpt ports and look for the other devices or epson ports and remove
any that could possibly be the epson... shut down, power off,
unplug the printer from the system end of the cable.
start up system  go into regedit search for eps in here as well
if it looks like it's epson related remove it.
go into sysedit and remove all lpt or epson stuff you find here (autoexec.bat config.sys win.ini and system.ini) as well.
restart system again check control panel, system, devices
and see if your com ports and lpt ports show up right...
If they still don't then a complete fdisk repartition with shutdown and restarts on each step of fdisk and an fdisk /mbr to rewrite the master boot record, install dos 6 or whatever dos you have.. a Win 95/98 startup disk
will work as well as long as you don't use newer than the version you
plan to install, eg if you have OSR2 disk's to reinstall OSR2 then
the OSR2 startup disk will do but the Win98 disk would be a mistake.
get CD rom going again, reinstall Win and get all the hardware up and
running right without the printer hooked up..
Once you have that all done and your Lpt1 shows up as epp/ecp
you could then power down plug the printer back in and run the install
from the disks for it and see if it gets it right this time..
(but at this point I'd have soaked the printer in gasoline or naptha and put it out of it's misery and bought a new one...)
funny how since the epson 400 series printer they seem to have been
nothing but trouble but before that they were THE printer company to go with....  My personal printer preferences since win95 are Lexmark or HP
I won't deal with any other printer's if I can help it.. quality of print, speed of print and using standard system ports to run off of are good thing's..
any printer or modem that insist's that it has to have a port dedicated to it with a driver in the way is just an annoyance.. and in the case of modem's
it means that there is no modem on that card... period jus tthe wiring to get to the telco.. the modem is that port driver on com whatever and your CPU is then doing the work.. I still havent figured out why Epson built these printers that way..
Oh and I usually don't give up on tough problem's... I make my living doing
this stuff and tend to be a tad tenacious about I can fix almost anything..
but these epson printers eat up far too much time.. the other two that refused to reinstall ... well one did go up in flames..  (client heard me muttering about naptha and a match if it was my printer..  they liked the idea... go figure.. <chuckle>)
whup's this is a lot more than I usually type ... heh
Do you have anything in your load= line of your win.ini file?    if so remove any lines ref. LOAD=<example wakeup.exe.

Hope it helps.

pctech052197Author Commented:
Glenn,  Load=    is blank, but thanks for trying
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Hmm a fun one.. heh ok you say you removed all ref's to Lpt# in
control panel/system? and tried to remove epson port as well..
on bootup go into bios and check to see that the port is on and
set to one of the following
bi-directional, ecp, epp and not spp
if it is set as one of those and is hooked to irq 7 or 5 does it have
dma 3?

If all of the above match then we get into tricky stuff, you might want to
try uninstalling the epson software before trying this... :)

click start, run , type regedit, make a backup
search for all references to lpt1 lpt2 and remove them
search for all references to epson and remove them
save and exit
reboot and cross your fingers that it autodetects the silly thing.
More directly, head to Control Panel, then Add New Hardware. Tell the Wizard not to search for new hardware. The Wizard will then give you a list of hardware types. Look for Ports on the list and select it. The rest should be obvious.

It was this very question which I needed answering, that brought me to Experts Exchange almost two years ago. It took the experts then a lot longer to come up with an answer for me.

I just checked, and it was three years ago, not two, when I first arrived here. My how time flies.
pctech052197Author Commented:
Tascan:  No luck on the registry.  Windows redetected and installed and I am back to square one.

Bparnes:  trying to add a port through control panel just creates a new Epson Printer port which cannot be removed through the Control Panel (it is recognized as a device category, rather than a device).

Strangely, the first installed Epson Printer port (which is recognized as a device category) is assigned IRQ 7.

Very frustrating.

Please help
Have you established that the printer is functional on some machine? Do you have the Epson uncabled from the parallel port when you do all this?

let's step back and take a deep breath. I may be repeating what you've already done, but a little redundancy might help here. Go into Device Manager and remove all references to the printer, and to the printer port. Do this after disconnecting the Epson from the port. Now shut down the computer and leave it powered off for 10-15 seconds. Power up and go into CMOS setup and make sure you have LPT1 active and in the mode that Epson says is optimal for their printer (EPP, ECP,...). Then reboot to Windows and see if Windows finds the parallel port. If it doesn't, then do the Add New Hardware routine to add the LPT1 port. Finally check with device manager to make sure that LPT1 is really listed as a port. If it isn't, then you know the problem has nothing to do with the Epson.

If it is listed, then you should be able to go through the normal Add New Printer Wizard to get the Epson installed. Once it is installed, it will change the name of the port to reflect which printer is attached.

Let us know how all this goes. Make sure you spend time removing everything, and then rebooting without the printer attached, so you can determine that you are at a decent clean starting point. It is critical to remove all vestiges of the old printer install. Also make sure you have the latest print driver available for the version of Windows you are running. I remember how frustrating this was for me to solve as well. In the worst case, you can run out and get an I/O card that will let you add another printer port to the computer; you could then use that port.
pctech052197Author Commented:
Adjusted points to 200
pctech052197Author Commented:
Bparnes: I am unable to remove the Epson Port(s) from Device Manager, they are recognized as device categories, rather than devices.  I need to remove them from the registry to clear them.

I believe that this is a hardware problem and has nothing to do with the Epson Printer (Stylus 440 Color).

I have already tried adding a parallel port card (ISA), but have had no luck.

I work in a help desk environment and senior help desk employees are not able to solve this problem.  I realize this is a tough solve and have increased the points to 200
I'm not sure how helpful I can be from this distance (expecially given your lack of success using folks who are much closer by), but I'll keep trying for a while.

First I'd make sure the printer port LPT1 was working by checking the CMOS settings, attaching a DOS-friendly printer to the port and then booting to DOS using a floppy. I'd then attempt to print something to the printer and look for success. If so, then I'd feel fairly confident it wasn't a hardware port problem.

I'd then FDISK the hard drive (actually I'd use a spare drive I keep around for just this kind of problem), format it, and install Windows. I would not have the Epson attached or even within 15 feet of the computer at this point, so I could feel confident that it had no influence whatsoever on the install <small grin>. I would then look at Device Manager and see what it reports. I should see a simple instance of LPT1 under the ports heading. If I don't, then I point the finger at Quantex.

I'd then probably install a fairly standard printer (I keep an HP LaserJet II around for this kind of problem) into Windows and see how it goes. If things are still on track at this point, I'd feel fairly comfortable in giving Quantex a clean bill of health.

Finally, I'd have a go at the Epson again and see what happens when I install it according to the method recommended by Epson. (Sometimes they want me to use the Add New Printer Wizard, sometimes it is a Setup.exe, etc.) I'd make sure I had the latest driver from Epson for this, and that it was written for the operating system I am installing into. I'll either experience success or failure here. If it fails, I have a good sense of who to point my finger at. If it succeeds, then I emit a deep sigh of relief, and go read a book for fun (you could choose to have a beer at this point).

Hope this helps.

There may be an item written in the boot sector
of the hard drive.
Determine who's drive it is, and download diagnostic software
from their site.

Many of them will let you restore the drive to its original boot sector,
or at the least erase the one on there.

Best of luck with this.
If you did a clean install of the port without the epson on it and it
came up with Lpt1=ECP EPP for the port and it's on the standard parallel
port Irq and the printer still doesnt install and behave I'd say it's hardware
on the printer..
Standard ECP port setting from my system is
DMA 03 I/O 378-378 I/O 778-77A Irq 7
Hmm I have seen a case before of a boot virus being in the way
as mentioned by a few others above in a slightly different way.
For some reason the Epson 400 printer seem's to be a real pain
this is the third time I've seen one that someone say's wont reinstall
under any circumstances. Hope you get it going.
pctech052197Author Commented:
Centery:  Dosen't FDISK /MBR erase the boot record?  I have used it during the reinstallation of Windows.

Tascan:  I appreciate your diligence.  I have not been able to successfully have LPT1 detect.  All that is recognized is Epson Printer Port, there is no LPT1 anywhere on my Device Manager.

I may reinstall the OS again and install the printer prior to the modem.
Thats the original way I installed Win95.  I needed to install the modem on COM5, COM1 was detected, but had a conflict.  Id there possibly a connection between COM1 and LPT1?

Thanks again.

In some cases, I seem to recall that I ran in to the boot record situatuation, and was very surprised at the time that it was still there.

You dont have the usual situation, so it may be worth a try.

Your LPT1 and COM 1 and 2 are hardware ports, even if they are integrated in the MB, with assigned IRQ interrups in your CMOS

The others are virtual ports unless you have a card istalled for more.

Check the setup by accessing your BIOS and see if the numbers in your BIOS match in device managers settings.

If you have an unresolved conflict in COM 1, that you cannot repair in software,
then that leaves a hardware problem.

The COM and LTP ports are part of the motherboard, so yes they can feed of of each other's problems.

I would definately resolve that conflict before proceeding with any additional software or hardware installation.

Don't know if the drivers at the Epson site might help or not, but its worth checking it out.

It occurs to me that some other hardware device may be "sharing" resources, IO or even DMA, with the printer port, perhaps a sound card or SCSI card, and that it interferes with proper identification of the port. You might have to physically remove some devices from the PC to see. Years ago, I had a network card and floppy controller DMA conflict that shouldn't have existed, but removing one allowed the other to work.
Did you have a printer installed before?If not, do you have a scanner using a ISA card. I have seen conflicts of a ISA card attached to a scanner killing the LPT port.
pctech052197Author Commented:
Thanks for everone's help.  Tascan answer drove me to reinstall the OS one more time,  I installed the printer prior to the modem and it worked fine.
The modem is now recognized on COM5, which I did not install, but it is workinging.

Thanks again
The Com 5 the modem is on is due to plug and play on the modem...
you could remove the modem check for hardware/jumper
settings .. set it to com 2 irq 3 turn off the bios com 2 or set
to com 3 then reinstall the modem for more reliable use of modem
Hope you didnt have to actually do the Fdisk step in mine...
The modem will probly work fine on 5 tho
Don't use fdisk/mbr unless you have no alternative! In some cases, it can lose data on drives that otherwise can be recovered.

It may lose data in the case of certain boot sector viruses, when the alternative is that anti-virus scanners can detect them and clean them for you without data loss. Also, certain hard drives specially formatted won't work after using fdisk/mbr. A quick search using www.google.com had the following information. It also refers to the alt.computer.virus Frequently Asked Questions (FAQ) - if anyone is interested, I'll look for it for them.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.