Adding a modem to linux for the 1st time.

My modem is an internal creative labs modemblaster flash pci dl5630 and I've installed  linux on a computer which is already running win98.  
First, I"m not sure if it's compatible and I've altready tried finding out w/ no luck.
Second, assuming that it is compatible, it's on com1 irq 5 on win98 and I tried setting it up in linux using the following command. "setserial /dev/ttyS0 uart 16450 port 0x3f8 irq 5".  I've run minicom to 'talk' to the modem but it doesn't look like it's being seen because it doesn't give me an 'OK' and nothing I type shows up on the minicom screen.
Can anyone shed some light?

Also, I've noticed that my books say to use /dev/ttyS? and other online
help I've been to refer to /dev/cua?..  what is cua used for?? At first
I thought it was a com port but then I got the impression that ttsy's
are com port because of what my books say but this  wouldn't make sense
either since I  have to assign a port to it using "setserial 'device'
port 'whatever' ".    I'm royally conused about this.


-Tania
TaniaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

xemaCommented:
I'm also new with linux how ever I can tell you that CUA? and TTY? are two different ways of calling the COM ports, normally a PCI modem is difficult to set for linux.

There is a place on the Web with a huge list of compatible modems, I don't recall the address but you can find it searching for "Linux Modem"
0
orz012999Commented:
Have you tried running the command
# netconfig


Going through the setup process and cancelling everything except for the modem might help too.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.