Solved

Netscape preference dll's

Posted on 2000-02-14
6
220 Views
Last Modified: 2012-06-27
I'm running Netscape Navigator 4.08. If I try to access the preferences option from the EDIT menu I get the message "Unable to load the preference dll's. Please re-install Netscape Communicator"

I want to avoid a re- install if possible.Is there anyway I can re-instate the dll's in question.

Before this problem arose I had run Microsoft's Reg Clean. Has it buggered up this setting in the Registry?


JWROBBO
0
Comment
Question by:jwrobbo
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
6 Comments
 
LVL 19

Expert Comment

by:cheekycj
ID: 2518838
I think your only option is to re-install netscape unless you know someone with the same prefs as you and copy their dlls.

Why don't you want to re-install NN4.08? It won't delete anything nor overwrite any of your prefs.

CJ
0
 
LVL 7

Accepted Solution

by:
bjt3 earned 200 total points
ID: 2519775
Yes, you've hosed the registry and will need to reinstall.  My recollection of this problem is that the files are present, but the registry entries required to make use of them have been removed.  And, sorry, I don't know what the actual entries were.

A reinstall isn't really that bad, and it won't hurt your existing user data and profiles.  You might also want to consider this an opportunity to move to version 4.7, if you haven't already.
0
 
LVL 19

Expert Comment

by:cheekycj
ID: 2522425
hey bjt3.. you just stated what I commented. :-)

No harm.

CJ
0
On Demand Webinar: Networking for the Cloud Era

Ready to improve network connectivity? Watch this webinar to learn how SD-WANs and a one-click instant connect tool can boost provisions, deployment, and management of your cloud connection.

 
LVL 7

Expert Comment

by:bjt3
ID: 2522515
Yes, that's true.  I posted it as a comment, and added the information that this is a known problem and that the registry entries had in fact been hosed.  The solution, not suggestion, is to reinstall to restore all of the registry entries. Copying the prefs.js and the dlls would not have solved this problem.  On that basis, I don't view it as a restatement of a previous comment, but I can understand how your view may differ.

It's unfortunate that you feel that there is a comment collision here.  As I explained above, I don't quite see it that way, but I do understand your statement.  I concur that there is a lot of restated-comment-as-answer that happens in these forums and it can be annoying.  (In fact, and meant only in good spirit, if you look back you'll see that you've done that to me a few times in the past.  I generally let them go without comment - what's the point ?)

jwrobbo - despite this little bit of confusion, I'm pleased that this solved your problem.  That, ultimately, is what these forums are all about.
0
 
LVL 19

Expert Comment

by:cheekycj
ID: 2523004
I have no problem here actually.

But please clarify:
>what you've done that to me a few time in the past.

I hope I didn't.  Sometimes I do elaborate more (as you did) but never received the points (as far as I know).

Anyhow, you are right, we are here to help and that is the bottom line.

I do get annoyed with people posting as answers when its a re-statement.. I thought you did that but I should have known that you know better being a part of EE for some time now :-)

Cheers,
CJ
0
 

Expert Comment

by:kissdman
ID: 2557526
jwrobbo,

Please do the following, you DO NOT need to re install Netscape.

Go to your REGCLEAN directory.  Double click on UNDOblahblahblah.reg corresponding to the date you ran RegClean and lost your Netscape prefs.  Re-Boot, and you'll be fine.

How do I know?  I use both NN 4.08 and RegClean, and I know from experience.

Hope I'm not to late...

Matt
0

Featured Post

Announcing the Most Valuable Experts of 2016

MVEs are more concerned with the satisfaction of those they help than with the considerable points they can earn. They are the types of people you feel privileged to call colleagues. Join us in honoring this amazing group of Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Citrix XenApp, Internet Explorer 11 set to Enterprise Mode and using central hosted sites.xml file.
Several part series to implement Internet Explorer 11 Enterprise Mode
Google currently has a new report that is in beta and coming soon to Webmaster Tool accounts. This Micro Tutorial will highlight new features for Google Webmaster Tools.
How to create a custom search shortcut to site-search Experts Exchange using Google in the Firefox browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch your Bookmark Menu: Press 'Ctrl +…

626 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question