Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 223
  • Last Modified:

Newbie asking X-windows questions

I'm fairly new to Linux and have experimented with several of the windows managers that come with Redhat 5.0.  I am very eager to use Linux and X-Windows, but I'm finding that there are 2 problems that I can't seem to shake.  
1.) I've set my machine up to run Windows 95 and Redhat Linux.  When I start my X-Windows session, the monitor controls must be readjusted to make the viewable screen area look normal again.  This can be quite a hassle.  There must be some way to do this whithout readjusting my monitor controls.
2.) The mouse movement I'm used to in Windows 95 and Unix (Mosaic I think) is very smooth and easy to adjust.  When I'm in my X-windows session, I find that the mouse movements lack the same "smoothness" (for lack of a better word).  Is there a better way to control mouse properties that by using the "Fast, Next Fastest, Fastest" command in X-Windows?
0
jamesclancy
Asked:
jamesclancy
1 Solution
 
kufelCommented:
First of all - I would suggest to upgrade to RH 6.1. It includes the newest Window Managers where most of the bugs are fixed. Personally I use KDE. My PC is P166, so I get much smoother cursor movements under Linux then in Win98... Also, for the screen sizes, seems like your monitor does not remember settings for each refresh rate and resolution settings. Make sure that those are the same in X-Windows as in Windows, otherwise you need a newer multisync monitor.
0
 
ReinierCommented:
1. Yes it's possible, but perhaps it is not really a beginners task. Use xvidtune to adjust the image without touching the monitor buttons. When you are satisfied copy the 8 numbers xvidtune gives you to the appropriate Modeline in /etc/X11/XF86Config, i.e. the line with the same resolution and
"Pixel Clock" speed as you saw in xvidtune.

2. What window manager are you using?
0
 
jamesclancyAuthor Commented:
Afterstep in Rehat 5.1
0
 
ReinierCommented:
Hmm, never used Afterstep and never lost a night of sleep because of that. Perhaps somewhere some Afterstep adepts who know a way around this problem still exist. Try the zoo, in the rare species department.

Without kidding, I can only second the suggestion to upgrade and try KDE or Gnome. You can use Afterstep and/or WindowMaker with Gnome I think.
0
 
EatEmAndSmileCommented:
Your video has to be adjusted everytime probably because the refresh rates were not set properly. Run XF86Setup again (as root) and make sure you input there the right frequencies that you'll find on your monitor's back or in the manual. Just make sure you don't read the "power" frequencies on your monitor's back. It's the vertical and horizontal refresh rates that you want.

 Upgrading to a better and newer Linux distribution could be also very pleasant. Check out www.slackware.com

 Good luck!
0

Featured Post

[Webinar] Cloud and Mobile-First Strategy

Maybe you’ve fully adopted the cloud since the beginning. Or maybe you started with on-prem resources but are pursuing a “cloud and mobile first” strategy. Getting to that end state has its challenges. Discover how to build out a 100% cloud and mobile IT strategy in this webinar.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now