ActiveX problem

Hi,
I have created an active form and despite the fact that I check the fileversion in web deployment options, IE refuses to automaticaly download it except for the first time.
apostolostAsked:
Who is Participating?
 
rwilson032697Connect With a Mentor Commented:
You only need to change the clsid when you change the interface (sorry if I meant every time you update the software).

Cheers,

Raymond.
0
 
florisbCommented:
So you did register. Hint: Check BDEINST on Delphi cd if you use a database.

F.
0
 
apostolostAuthor Commented:
I don't use a database at least directly, I use a DataServer and connect through IIS. I Don't think it is a missing dll or something since once the ActiveX is registered for the first time, it works perfectly. IE just ignores my versioning. Is there a way that I can force the download.

Thanks

0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
florisbCommented:
I don't know an answer....

Did you try it without the versioning?
Did you set the security settings of your browser low?

hmmm, is there an .inf file in the dir you deploy to? Does it look like:
;Delphi-generated INF file for testWebDelpoyProj1.ocx
[Add.Code]
testWebDelpoyProj1.ocx=testWebDelpoyProj1.ocx

[testWebDelpoyProj1.ocx]
file=E:/Dev/webdelpoy/deployTo/testWebDelpoyProj1.ocx
clsid={544D9186-D568-11D3-BBCD-00105A2766AC}
RegisterServer=yes
FileVersion=1,0,0,0

html:
<HTML>
<H1> Delphi 5 ActiveX Test Page </H1><p>
You should see your Delphi 5 forms or controls embedded in the form below.
<HR><center><P>
<OBJECT
        classid="clsid:544D9186-D568-11D3-BBCD-00105A2766AC"
        codebase="E:/Dev/webdelpoy/deployTo/testWebDelpoyProj1.inf"
        width=241
        height=231
        align=center
        hspace=0
        vspace=0
>
</OBJECT>
</HTML>


Somebody else?

Greetings,
Floris.
0
 
rwilson032697Commented:
You can force the download by deleting the file from "Downloaded Program Files" in your windows directory...

You can also do this by changing the clsid (which is what you should do anyway if you are changing the version (=interface) of the ActiveX)

Cheers,

Raymond.

0
 
apostolostAuthor Commented:
Yes the security settings are set to low and the .inf file looks exactly as floris pointed out. No success however.
Raymond, if I change the clsid every time I release a new version doesn't that mean that after a while the user will end up with a bunch of useless registry keys ?

Cheers,

Apostolos


 
0
 
apostolostAuthor Commented:
I see, Ok I will give it a try and see how it goes.

Thank you very much,

Apostolos.
0
 
apostolostAuthor Commented:
Changing the clsid worked fine.

Thanks for the help
Apostolos.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.