Solved

Can't find File Association in File Types

Posted on 2000-02-15
18
174 Views
Last Modified: 2013-12-28
I can't find where Win 98 has listed htm files in the file types list since I set IE5 as my default browser.  I used to have a type for .htm that allowed me to associate editors etc that worked.  Since setting IE5 as default browser the .htm type is overridden by something so my favourite edditor is not listed when I right mouse click an .htm file.  The .htm type is still there with my editor as listed at the editor.  When I right click I only get an Open option.

I used to be able to overcome this with Tweak in Win95 but Tweakall for 98 does not have this ability.
0
Comment
Question by:jim220742
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
  • 2
  • +7
18 Comments
 

Expert Comment

by:thetdk
ID: 2525783
I don't know what has caused your problem. But I suggest you create your own and copy the command lines and DDE commands from and .html extension or similar file type that uses EI5. This will allow you to click on .htm extensions and have IE5 come up.

Let me know if this works. If not I can give you the settings from my machine.
0
 
LVL 12

Expert Comment

by:Patricia Siu-Lai Ho
ID: 2525791
Jim, you may try to check this: -

Go to the Start-Settings-Folder Options-File Types-
Search down to find the registered file types name: -
[Microsoft HTML Document 5.0     ]
You will find Extension    :  HTM HTML
                   Opens with  : IEXPLORE

The file type of *.htm is now set as opened with IE5.

You click the [Edit] button, select the [Open] Actions. Further click the [Edit] button underneath the [Actions: ] window.

At the Editing action for type : Microsoft HTML Document 5.0
Change the Application used to perform action:
["C:\PROGRA~1\INTERN~1\iexplore.exe" ]

Using browse to search the executable program of your editor. Click OK.

Exit.

See if you can use back your editor to open with *.htm file type.

Let me know if you've any queries.      pslh
0
 
LVL 12

Expert Comment

by:Patricia Siu-Lai Ho
ID: 2525803
Jim, <<The .htm type is still there with my editor as listed at the editor.>> Please elaborate at what editor?
pslh
0
Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

 

Expert Comment

by:paugusta
ID: 2525831
There is NO listing for .htm in the file types list nor is there a listing for Microsoft HTML Document 5.0 as in pslh's comment.  I have tried creating a new type for .htm files which is STILL in the list of file types but it must be over ridden by whatever happened when the problem arose.

I know how to make changes to file types in the list but the question is "how do you change associations" when you can't find it in the list

Thanks for the help in refining the problem guys

0
 

Author Comment

by:jim220742
ID: 2525850
The comments made by paugusta were mine, I used my brother's login on his PC

Jim
0
 
LVL 12

Expert Comment

by:Patricia Siu-Lai Ho
ID: 2526297
Jim/paugusta,  please list the right click context menu for a *.htm file so that I can see through what has been happened in your system. What you are desired how it looks like?
pslh
0
 
LVL 3

Expert Comment

by:mitrakis
ID: 2526480
Fiddling around with file type associations and DDE exchange or whatever else by yourself could result in a mess...

Best bet would be to reassign the file type to the application you wish.
To do this, here's the quite easy how-to:

- highlight a file with the extension *.htm (or *.html) from within explorer
- hold down the shift-key and right-click the highlighted file
- now choose the option "open with..." from the pop-up menu
- browse through the list and choose the app you want to assign your file type with
- highlight the check box "always open with this app" if desired/needed

Your file type *.htm/*.html is now assigned to the chosen application.

Best regards
-Stavi-
0
 

Author Comment

by:jim220742
ID: 2526693
Thanks Stavi but Opening is not the problem, I want to add the name of the program I want to edit with, which used to be there
0
 
LVL 3

Expert Comment

by:mitrakis
ID: 2526748
Ah, sorry...now I see.
First, you won't be able to add this to the main pop-up menu manually !

As an alternative, how about adding the program to the "send to" menu ?
To do this, you only need to add a shortcut into the "send to" folder located in the windir...

Otherwise, you have to reinstall the application you want to be assigned with *.htm(l) files.
After your editor has reassigned the file types, MSIE will ask you if you want to make MSIE as the default app for *.htm files.
Be sure not to confirm this dialog...

Regards
-Stavi-
0
 

Author Comment

by:jim220742
ID: 2526755
Comment for pslh

I have a screen dump of the .htm right click drop down menu as it now is and as it used to be and how I want it to be.

http://www.home.mtx.net/x.gif

Thanks

Jim
0
 
LVL 12

Expert Comment

by:Patricia Siu-Lai Ho
ID: 2526759
Jim, looking forward to receiving your reply on my questions previously stated and I'll show you how to do it.
pslh
0
 
LVL 12

Expert Comment

by:Patricia Siu-Lai Ho
ID: 2526782
Jim, I saw that x.gif. I would like to ask if "Edit with HTMEDIT" appears at the other file type's context menu? What kind of file type is now right click having this option?
pslh
0
 
LVL 18

Accepted Solution

by:
centerv earned 100 total points
ID: 2526789
The problem may be with IE
From control panel/ add/remove programs
Click on Ms IE and tools
Click add/remove
Choose the Fix explorer option.
Good luck.
0
 
LVL 14

Expert Comment

by:smeebud
ID: 2526928
jim,

Windows\inf\shell.inf Reset All Associations

The solution for resetting, is to go to Windows\inf\shell.inf and right click on the inf file, then Click Install. This resets all associations to their default.

Regards, Bud
http://www.geocities.com/~budallen/
Bud's Win95 Win98 Tips and Troubleshooter
0
 
LVL 4

Expert Comment

by:tengage
ID: 2527372
IE5 | Tools | internet options | programs.  Is your HTMEDIT Program listed in the HTML Editor drop down menu??
0
 
LVL 25

Expert Comment

by:dew_associates
ID: 2527468
Jim, open regedit and drill down to:

HKEY_CLASSES_ROOT and search there for these four files:

..htm
..html
htmfile
htmlfile

Note: You will only have the .htm and htmfile files if the program you want to use created them, otherwise the context menu will be controlled by .html and htmlfile.

Now drill down further to:

HKEY_CLASSES_ROOT\htmlfile\shell

You should see a few entries, two of which are "open" and "open with <program type>" With program type being the program that is being used or you wish to be used.

Now click on the reg entry for "open with <program type>" and expand it by clicking the + sign.

When clicking on "open with <program type>", in the right window will be listed the menu context.

If you drop down below that reg entry to "command", you will see the actual open with command associated with that context menu entry.

You can now edit these entries as necessary to use your program.

Dennis

Click on the
0
 

Expert Comment

by:kallstrk
ID: 2528915
A simple way to open files that don't have the correct association you want is to hold down "Shift", then right click on the file.  You should have the "open with" option now...use it to change what you want to open it with for editing.  This won't be a "perm" fix, but if all you do is edit documents in windows explorer, just choose the option of "always use this program...".  You'll still be able to browse the internet fine.  Everytime you try open an html file that is local though, it will try to have you edit it.

A fairly straight forward way of getting the "edit" option on the rt-click is to just re-install the program that you used to edit it with.  It should give you the option back.

0
 

Author Comment

by:jim220742
ID: 2529091
Thanks centery, this is the exzct result I wanted.  Microsoft HTML Document 5.0 has reappeared in the Files Type list.  It was then easy to add my editor back in again.  Now when I right click an htm file I can either Open with IE or edit with my editor.

Thanks again

Jim
0

Featured Post

Optimize your web performance

What's in the eBook?
- Full list of reasons for poor performance
- Ultimate measures to speed things up
- Primary web monitoring types
- KPIs you should be monitoring in order to increase your ROI

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

No single Antivirus application (despite claims by manufacturers) will catch or protect you from all Virus / Malware or Spyware threats. That doesn't stop you from further protecting yourself however - and this article is to show you how.
An introduction to the wonderful sport of Scam Baiting.  Learn how to help fight scammers by beating them at their own game. This great pass time helps the world, while providing an endless source of entertainment. Enjoy!
In this video, viewers will be given step by step instructions on adjusting mouse, pointer and cursor visibility in Microsoft Windows 10. The video seeks to educate those who are struggling with the new Windows 10 Graphical User Interface. Change Cu…
If you’ve ever visited a web page and noticed a cool font that you really liked the look of, but couldn’t figure out which font it was so that you could use it for your own work, then this video is for you! In this Micro Tutorial, you'll learn yo…

623 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question