Solved

Setting up networking with Linux and win98

Posted on 2000-02-16
4
200 Views
Last Modified: 2010-03-18
I have two computers both with Win98 networked together and networked properly. Recently I installed Linux-Mandrake 7.0 on one of them, but can't get it to work with the network card. During linux boot, I get something like Initialisation Delayed  [Failed]. I used the installation programme to setup the NIC.
The NIC is a 3com 3c509b running in Legacy ISA mode (I have tries PNP mode, with reinstalling Linux, but that didn't work either).
All I know about Linux/Unix is what I have worked out in the last month. I need some simple help!!!
0
Comment
Question by:LocutusBorg
4 Comments
 
LVL 40

Expert Comment

by:jlevie
ID: 2529775
Using 3c5x9cfg to set the 509b in non-pnp mode is heading in the right direction. What IRQ & IO port did you assign to it? Since the IRQ and IO port can't conflict with anything else, look at /proc/ioports and /proc/interrupts and see if the values you chose would conflict. I've you are using a system with PCI support, you may also need to set the bios to reserve that IRQ to legacy ISA mode.
0
 
LVL 3

Expert Comment

by:jyu_88
ID: 2532181
i'd watch device info by 'dmesg' while trying 'modprobe 3c509', 'modprobe 3c509 irq=10'
Once it works, you can put eth0 alias in to /etc/conf.modules

One thing to watch out though,
I noticed that dmesg not always report to the REAL irq the card is listening to.
I have a dual-boot setup, 95 sees it at irq=3. Dmesg says it at 10 but card not working. I tried irq=3 then it works since, although dmesg still claims that the card is at irq=10.

From /proc/interrupts, you can also see if a given IRQ has really hear any thing. In my case, irq=10 shows up as eth0, but nothing heard there.
0
 
LVL 7

Accepted Solution

by:
lewisg earned 100 total points
ID: 2537680
If you don't have a sound card or a LPT2 port set the 3c509 to IRQ:5 IO:300. If the 3c509 is a combo card (multiple flavors of network connectors) BE SURE to set the correct one in 3c5x9cfg. (other options: server, no modem)

Next be sure /etc/conf.modules has an entry in it that looks like:
alias eth0 3c509

This should get rid of the "Initialisation Delayed  [Failed]." message which indicates linux was unable to bring up the card.
0
 

Author Comment

by:LocutusBorg
ID: 2539274
Brilliant!!!

Thanks very much. I can now PING between my Linux and Windows machines!!
0

Featured Post

What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now