Solved

Windows NT 4 Cannot Recognize New Modem

Posted on 2000-02-18
16
500 Views
Last Modified: 2013-12-27
Hello!

I have a Windows NT/modem emergency and would appreciate any help! (I am running NT 4.0, SP6a, on a 500-MHz Pentium-III Arrow PC, with 256 MB of RAM.)

I just purchased and installed an internal 3Com Courier V.Everything 56k internal modem to replace an internal OEM Sportster modem for which my computer manufacturer would offer no support, since they did not install Windows NT on my PC, and for which 3Com nor my ISP could offer help. (It could not sustain a connection with my ISP.)

I installed the Courier (Product Code 002805-00) in the same ISA slot, using the same COM port (2) and IRQ settings (3) as the OEM modem (via the jumpers), but Windows NT 4 (SP 6) fails to recognize it (which was not a problem with the OEM modem, even if it was not reliable).

I tried using the driver on the 3Com Connections CD-ROM, the V.90 driver from the Courier section of their Web site's support section, and the V.Everything V.90 internal driver from Windows NT, 'Courier V.Everything INT (V.90&x2)'.

I deleted and re-entered my ISP information in my Dial-Up Networking address book and even deleted and reinstalled RAS and TCP/IP, and then reinstalled Service Pack 6.

When I try to dial-out with DUN, I get the error message, "Error 692: Hardware failure in port or attached device." I have the base I/O port address and IRQ settings for the Ports control panel set for the default IRQ settings, which worked fine for the OEM modem, and -- as I say -- I do have the jumpers set for COM 2 and IRQ 3 -- which worked for my OEM modem (which NT at least recognized).

I suspect I am making a mistake in the configuration of NT for use with this modem, not that the modem is bad, but I am at a total loss. This situation is a business emergency for me; I went from an unreliable modem to one which NT will not recognize at all. (By the way, I tried using HyperTerminal to test the modem, but it acts as if no modem is installed.)

Could you please offer me some advice? I am in urgent need of a reliable modem for my PC, since I leave to teach a Web-development workshop in Ukraine soon and cannot prepare without a modem!

Finally, I had a corrupted hive in my NT registry several months ago; I had to take the PC into a shop. Although they restored my data, I had many problems with NT and did a fresh installation. When I installed my OEM Sportster modem after installing NT, I had this same problem. After working at it for a week, I finally took the PC back to the shop and they got it working. They said it was set for plug-and-play, which I had discovered before taking it in and had set the jumpers; oddly, when I first installed NT and the old modem in early 1999, NT recognized the modem and I had reliable connections with my previous ISP (even though the modem was in plug-and-play mode at that time)!

Thank you, very much, in advance! I would appreciate prompt responses; I am up against a deadline and am totally frustrated.

I suspect the new modem is okay -- but I have done something to mess up Windows NT and its ability to recognize the modem!

Cordially,

David Dickerson

P.S. -- I used the 3Com Knowledgebase, but it was of no help. I have also contacted 3Com support via their Web site, but my experience had not been very good with them, and it takes them a while to respond.

I have also searched the Microsoft KnowledgeBase and followed all the recommendations in the documents I found.
0
Comment
Question by:ddickerson
  • 7
  • 6
  • 3
16 Comments
 
LVL 3

Expert Comment

by:Alisher_N
ID: 2536480

1. try to boot in DOS (use floppy) and test a modem with simple terminal like Telix, or put tha Courier to another PC for testing

2. try to use another COMx, for internal modems I usulally disable com2 in BIOS SETUP and set a modem to Com4 (2e8, IRQ3)

3. check all setting in BIOS, like COM ports setting for address/IRQ
also there are ISA/PnP settings like 'ISA slot use IRQ x', also Pnp OS installed and resource controlled by

4. Disable all unused ports in BIOS SETUP (gold gule ;-)

0
 

Expert Comment

by:Edy1988
ID: 2540053
Hello!
I had problems with my modem and win NT, it was solved when i found with the NT driver(in the winnt directory in the modem's disk)a readme file that explained that i had to operate a setup program that was in that directory, the program asked me to which com port i want to connect it ,after that i restarted the computer,when then i ordered him to detect modem he found it, it is important not to configure the com ports by your self!
I believe in that manner you can install yours.
0
 

Accepted Solution

by:
Edy1988 earned 100 total points
ID: 2540089
Go to:
http://consumer.3com.com/couriera/inf/index.html

download crinf.zip, after that open it, its include a readme file that explain how to install the modem on 95/98/NT
0
 

Author Comment

by:ddickerson
ID: 2544055
Hi, Alisher_N and Edy1988:

Alisher_N, by the time I received your comment "Disable all unused ports in BIOS SETUP (gold gule ;-)," I had already tried disabling COM4 (serial 2) in the CMOS section of BIOS, which did solve the problem, so your comment was confirmation. :-)

Edy1988, I had already tried the option you suggested, downloading CRINF.ZIP from the Courier support section of the 3Com Web site, but it made no difference. (I also tried the driver which came with the modem and the V.Everything/V.90&56k driver which came with NT, which I am still using.)

Still, I think your proposed answer is a VERY good one and I would have certainly given it an "Excellent!" grade, if I had not already tried it. :-)

Since you are obviously knowledgeable, Edy1988, perhaps you can suggest a comment or solution to a complication which haunts me now that I have the internal Courier V.Everything modem working.

I STILL have the same problem I had with the OEM Sportster modem with which I replaced the Courier modem. I cannot sustain a connection with my ISP, MindSpring, and I have followed their configuration instructions to the letter!

My guess is that the same problem which prevented the Sportster modem from establishing a reliable connection still affects the Courier. So, while I have 3Com's best analog modem, I still have the same problem. Getting knocked off-line, usuall in less than three minutes is preventing me from using the Internet with my Windows NT PC. Downloading a file is out of the question, of course.

3Com support had suggested via e-mail that my modem might be bad, when it was unrecognized by NT, but clearly the modem is not defective, since I got it working by disabling COM4. (I have asked 3Com support for suggestions about establishing a reliable connection, by the way and await their reply.)

If you have any suggestions, I would be most grateful, and thank you again for the solution you offered!

Cordially,

David
0
 

Expert Comment

by:Edy1988
ID: 2544946
have you tried to test the phone dialer?
if it works than your modem is O.K. ,
0
 

Author Comment

by:ddickerson
ID: 2559242
Hi, Edy1988!

I tested the modem, as instructed by 3Com, using HyperTerminal.

The results of the test were as follows:

>     ate1
>     OK
>     ati7
>     USRobotics Courier V.Everything Configuration Profile...
>
>     Product type           US/Canada Internal
>     Options                HST,V32bis,Terbo,VFC,V34+,x2,V90
>     Fax Options            Class 1,Class 2.0
>     Clock Freq             25 Mhz
>     Flash ROM              512k
>     Ram                    64k
>
>     Supervisor date        03/13/98
>     DSP date               03/13/98
>
>     Supervisor rev         7.3.14
>     DSP rev                3.0.13
>
>     Serial Number          22IKBCB9GOQ1
>
>     OK
>     ati12
>     ERROR

As you can see, the Hayes command 'ATI12' yielded an error.

3Com support had no comment on the test results, nor did they have any recommendations as to how I can keep my Courier modem connected with my ISP, now that I have it working. (They told me to disable COM4, which I already told them I did, and that the modem's getting started guide might have wrong instructions for setting the IRQ jumper, but I have checked the modem board and it is unclear to me from the markings how to set IRQ 3, so I told 3Com support to tell me the proper shut setting if the manual was wrong.) :-|

I am about ready to give up. I cannot stay connected to the Internet for more than three minutes at a time with my NT PC! If it were not for my Power Macintosh, I could not use the Internet!

Does anyone have any other suggestions. I have reached the point of despair.

Thanks!

Cordially,

David
0
 
LVL 3

Expert Comment

by:Alisher_N
ID: 2559329
connect to that ISP manually (via hyperterm) or turn ON logging for modem and look (and let us look) at CONNECT string, what are the protocols ? also after it lost connection you can use (in terminal again) command ati6 (I suppose... or it i8 ??? ) to find out 'Disconnect reason'

do you have at the moment this problem with only one ISP ? try to connect other computers with modems via hyperterm and transfer files to detect where the problem is - ISP or modem....
0
 

Author Comment

by:ddickerson
ID: 2561742
Hi, Alisher!

Thank you very much for your suggestion.

I tried the test with HyperTerminal; I am afraid, however, that my reason for disconnecting is inconclusive:

<PRE>
atdt 254-1671
CONNECT 26400/ARQ/V34/LAPM/V42BIS
Welcome to MindSpring Dialup Service
arc-1a.nash login: ddickerson@igc.org
Password:
Packet mode enabled: ~*}#¿!}!}!} }8}!}$}%Ð}"}&****}%}&-}-«ê}'}"}(}"¡~~*}#¿!}!}"
} }8}!}$}%Ð}"}&****}%}&-}-«ê}'}"}(}"5S~~*}#¿!}!}#} }8}!}$}%Ð}"}&****}%}&-}-«ê}'}
"}(}"¸/~~*}#¿!}!}$} }8}!}$}%Ð}"}&****}%}&-}-«ê}'}"}(}"*~~*}#¿!}!}%} }8}!}$}%Ð}"
}&****}%}&-}-«ê}'}"}(}"yˆ~~*}#¿!}!}&} }8}!}$}%Ð}"}&****}%}&-}-«ê}'}"}(}"3d~~*}#¿
!}!}'} }8}!}$}%Ð}"}&****}%}&-}-«ê}'}"}(}"·Ì~~*}#¿!}!}(} }8}!}$}%Ð}"}&****}%}&-}-
«ê}'}"}(}"*&~~*}#¿!}!})} }8}!}$}%Ð}"}&****}%}&-}-«ê}'}"}(}"sØ~~*}#¿!}!}*} }8}!}$
}%Ð}"}&****}%}&-}-«ê}'}"}(}"9=~
NO CARRIER
ati6
USRobotics Courier V.Everything Link Diagnostics...

Chars sent                   31      Chars Received              600
Chars lost                    0
Octets sent                  31      Octets Received             355
Blocks sent                  31      Blocks Received              34
Blocks resent                 0

Retrains Requested            0      Retrains Granted              0
Line Reversals                0      Blers                         0
Link Timeouts                 0      Link Naks                     0

Data Compression       V42BIS 2048/32
Equalization           Long
Fallback               Enabled
Protocol               LAPM SREJ 128/15
Speed                  26400/21600
Last Call              00:00:45

Disconnect Reason is DISC Received
OK
</PRE>

I do not have another ISP to which I can connect, and the fact that packets will be transmitted during the session may be part of the problem with the short connection via HyperTerminal.

I also used DUN to connect to my ISP and made sure I had Windows NT record a modem log. I then used the Telnet program and stayed on for about ten minutes before being disconnected.

When I checked, however, NT did not create a modem log, a problem I have been having, so I have no data. I am not sure why the modem log is not being created. (I know the file name and search for it, but never find it.)

One gentleman, who has the MCSE and MCT certifications, told me to try reinstalling the modem in plug-and-play mode (using PnP ISA), but I have tried that option before. I could try it again, but I do not thing the results will differ.

I feel like pulling my hair out! :-|

Do you have any other suggestions, Alisher?

Thanks again!

Cordially,

David
0
Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

 
LVL 3

Expert Comment

by:Alisher_N
ID: 2562567
thanks for posting....

0) don't know how could it be with .log file - very strange... tried to reinstall drivers ?

1) "DISC received" it is a general word for normal disconnect (meaning that it is a problem of negotiation or forced disconnect)

2) those packets you can see in a terminal are normal, this is PPP (PAP/CHAP) configuration packets sent by ISP (dynamic IP addr. etc)

3) VERY important question, please answer exactly: can you connect for a short time or not connecting AT ALL ? I mean if you have normal connect you can see those icons with small computers ;-), but what is more important can you PING something outside ISP ? (if you have connection, try to go Start/Run, then type "ping -t www.microsoft.com" or something.

4) if you can ping anybody that means that TCP/IP stack installed properly if NO - then you have aproblem with IP settings (like DNS,Gateway,PAP/CHAP mode or even a password)

5) if you can not connect AT ALL could be a problem of authentification mode (which is usually plain text password, but NT uses 'encrypton' by default)

6) if you have IP working fine and disconnected anyway - this is a problem of your modem (hardware, but it is unlikely) or ISP problem, that's why you HAVE TO find a friend with a modem and connect to his PC via terminal and send/receive some files using Zmodem protocol to be sure that modem is running well

7) did you ask ISP if they have special settings to be used for modems ? for TCP/IP configuration on your side ? (List to check - DNS, gateway, type of server, protocol in DUN)

as you can see I suggest an approach to narrow a search, to throw away as many reasons as you can detect... this is the only way in such situation...

ps. and don't think about hairs ;-)), if I pull out a single hair for every problem I met - I would be bold now ;-)..... As I tell in such cases "she is ( a machine ) a stubborn, but I am even more stubborn" ;-)

Fight with that callous peace of hardware ! ;-)



0
 

Author Comment

by:ddickerson
ID: 2563431
Hi, Alisher!

Thank you very much for your detailed suggestion!

I have reinstalled the modem drivers, so I do not know why the log file is not being created!

I understand what you say about the PPP packets (and I expected to see them), but I am, of course, unable to do anything with HyperTerminal, while receiving the stream of packets.

I can connect to my ISP. In fact, I downloaded MS Internet Explorer 5.01 and the 128-bit encryption updater this afternoon! Once I started trying to visit Web sites after my downloads, however, I started getting my usual disconnections within two to five minutes, although sometimes I can stay on for almost fifteen minutes.

The fact that I was able to download a large file today, but am not able to "surf" the Web is probably significant. It is almost as if DUN interprets any inactivity as an indication that it should disconnect (and I have not selected the option to have DUN disconnect after a certain period of inactivity). Since I don't get disconnections with the same ISP with my Power Macintosh, I don't think my ISP is disconnecting me on my Windows NT PC, but I could (of course) be wrong. :-)

I was able successfully to 'ping' <mindspring.com>, by the way.

I do not know what you mean by "those icons with small computers." I do have DUN Monitoring in my toolbar and can see that my connections are active before they suddenly drop.

I have my computer configured exactly as MindSpring support suggests (TCP/IP configuration, DNS, gateway, type of server, and DUN protocol), including having my ISP accept a plain-text password, so I do not see authentication as being a problem, particularly since I can connect.

The few friends I have with PCs come to ME for advice (about very simple matters), so I would not be able to connect to their PCs via my modem, since they would never understand my instructions. :-) Also, the fact that I was able to download Internet Explorer 5.01 today suggests my modem is running well, don't you think (at least in terms of file transfers, albeit via PPP and TCP/IP, and not ZModem)?

I did get a message today from 3Com support, telling me how to set the shunts for the COM and IRQ jumpers (for COM 2 and IRQ 3); the quick start guide for the V.Everything modem was indeed wrong about the jumper settings, although the message I received from 3Com was almost unintelligible: "On the Com settings jumper the pins above the B and C and the pins above the 3. The jumper setting diagram is printed on the non-component side of the modem." One does not put shunts "above" jumper pins, but on the desired pair of jumper pins -- but I'm just being picky because 3Com has been so useless! ;-)

I am afraid I have not given you much else in this message to go on, Alisher. I really do not know what to do at this point. I could take the PC and modem to a local shop I use, but that would mean losing access to my PC for a day or two -- and I am frantically trying to prepare to teach a Web development workshop in Ukraine early next month, and February is about gone!

Thanks again, Alisher! I welcome any further suggestions, but I realize this problem is a very nebulous one, with many possible causes.

Cordially,

David
0
 
LVL 3

Expert Comment

by:Alisher_N
ID: 2564445
ok, if you can connect it is half-good news...

now the first thing I suspect is a browser ! yes, that's right... I don't trust MS too much (as you don't trust 3com tech.support anymore ?? ;-)).

'icons' is a indication that you connected, they just have different appearence in win9x and NT

now a suggestion:

try to connect to ISP, but do not start anything (Email or browser) over this connection, just run that 'ping -t www.microsoft.com' and watch how much time it will hold the connection UP ! if it works - that was a browser problem, so download Netscape ;-))

also check for magnetic fields close to modem (what have changed since upgrade ?) do you use another slot now ? have extra cables around modem ?

if it disconnects anyway I am afraid you have to replace a modem...

'no experienced friend with a modem' is REALLY bad thing in your situation ;-))

ps. have a good trip to Kiev !  by the way I am also from xUSSR ;-))

0
 

Author Comment

by:ddickerson
ID: 2565505
Hi, Alisher.

Thanks for your message!

If I continue to 'ping' a site, isn't it consider bad "netiquette"?

Also, I used Windows NT's Telnet program on Saturday and I was able to stay connected for about 25 minutes, which is longer than I can with a Web browser (MSIE), but I still lost my connection.

I have downloaded Netscape Communicator via another PC, so I can intall it and see how it does compared to MSIE 5.01.

My setup has not changed since replacing the modem, so I do not suspect magnetic fields. I even took the precaution of replacing the RJ-11 cable from the modem to the wall jack last week, in case the phone cable was bad (but it made no difference).

Here, incidentally, is the message I got from 3Com support today:

> Dear David,
>
> Thank you for contacting 3COM Online Support.  I
> understand that you are having problems staying
> connected to the internet.
>
> The modem has an inactivity timer, which is
> controlled by the S19 register. If the s19
> register is set to 0 then the timer is disabled.
> The command for setting a register is example:
> ats19=0. To save the command put an &w at the end
> of the string example: ats19=0&w.  This can be set
> in a terminal program like Hyperterminal. You may
> also put s19=0 in the extra settings box in Modem
> Properties. The ISP should keep a log file of the
> connections which will give a disconnect reason.
> NT also keeps a log.
>
> Have we resolved your issue to your satisfaction
> today?  If the response we have provided you does
> not meet with your satisfaction, please reply to
> this message with an explanation as to why.
>
> Please post all replies under this message.
>
> Gary S. 3com online support.

I have told 3Com I am not getting NT to create a modem log, but they seem to ignore much of what I tell them.

Thanks for your warm wishes about my trip to Kiev! I will also spend a week in Odessa!

Cordially,

David
0
 
LVL 3

Expert Comment

by:Alisher_N
ID: 2568249
did you try that (with s19 ?)
you can also put s10=50 in extra settings (long delay before drop line if carrier lost)

off topic:
If you have this possibility, try to visit Sevastopol, and especially Hersones (wonderful ancient city near Sevastopol), but this is quite difficult because there is a headquarters of naval military forces in Sevastopol ;-))
0
 

Author Comment

by:ddickerson
ID: 2569553
Hi, Alisher!

Thank you for your message.

I did try 's19=0', but it did not help. I also tried 's19=255', which is supposed to keep the modem from hanging up even when the carrier is lost, but it did not help either.

I will try 's10=50' and let you know!

Also, I am going to get an account with another ISP (either a local one, or one of the free ones) to see if my connections drop with another ISP besides MindSpring. If I pay for an ISP, I will close the account as soon as I see if I have the same problem I am having with MindSpring. Since I do not have the problem with my Power Macintosh and MindSpring, however, I am very baffled, and suspect the problem will occur with another ISP (on my NT PC).

I also contacted MindSpring support last night, giving them times when I was disconnected and asking them to check their connection log, hoping it records the reason for disconnections.

Thanks for recommending Sevastapol, Alisher, but my visa is only good for going to Kiev and Odessa (based on my business letter of invitation to visit Ukraine); on the visa application, I had to indicate which cities I was visiting and give an address for each location.

Thanks again for your message!

Cordially,

David
0
 
LVL 3

Expert Comment

by:Alisher_N
ID: 2576590
this is one more test for you
connect to yout ISP via terminal
after it disconnects run this command
ATI6I11Y11
this will give a line & connection statistic, you can analyze it manually or use this utility
ftp://ftp.usr.spb.ru/utils/usrst419.zip

this will tell you about line quality
0
 

Author Comment

by:ddickerson
ID: 2577016
Hi, Alisher!

Thanks for the information on the test. I will give it a try!

I called 3Com support yesterday and they suggested adding three modem strings (separately, of course) to disable x2 and V.90, V.90, and x2, respectively. (I also got a modem string addition from MindSpring, my ISP, but it did not help either.)

I tried all three and got disconnected each time. I had hoped that disabling V.90 alone would help, since the external V.Everything 56k modem I have connected to my Power Macintosh was manufactured just before the V.90 standard was finalized. I never did a flash upgrade, so that modem is using x2 alone, but such was not the case with the internal V.Everything 56k in my Windows NT PC.

3Com also suggested that I connect to their support BBS via HyperTerminal to see if I could sustain a connection. After staying on for 26 minutes, I disconnected myself, since I did not want to run up the phone bill. I also ran the 3COM LINETEST utility and it determined that my phone line, at least at that time, will not support a 56k connection, which I already knew, since I typically connect at 24-26k (with both the Mac and the PC, but at least the Mac holds a connection!).

I will give the test you suggest a try, Alisher. What I do not understand is that, if my Mac's V.Everything can sustain a connection to my ISP, even given the quality of my phone lines and using the same ISP, why the PC's internal V.Everything cannot do so as well. I suspect a problem with DUN, Remote Access, or TCP/IP, but I have reinstalled all three, with no improvement.

When I had the OEM Sportster installed, before it started to have failed ISP connections, it worked perfectly. I guess my phone line quality could have deteriorated, but (if so) this deterioration is not a problem for the V.Everything external modem my Macintosh uses.

Thanks again, Alisher. I will let you know the results of the test!

Cordially,

David
0

Featured Post

Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

Join & Write a Comment

Suggested Solutions

The following recovery method will work on All Cisco Switchs that run ISO software. You will need a good copy of the IOS version you want you use saved on your PC and a Com's Cable. The software for these switches comes as a .tar file. Tar is …
This article will step through configuring a SonicWALL appliance to utilize an internal DHCP server for Global VPN Client (GVC) hosts.  There are times when using an external (external to the SonicWALL) DHCP server, such as Windows Servers, isn’t pr…
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now